The Joomla! Forum ™



Forum rules


Please use the official Bug Tracker to report a bug: http://joomlacode.org/gf/project/joomla ... er_id=8103



Post new topic Reply to topic  [ 11 posts ] 
Author Message
PostPosted: Thu Aug 08, 2013 1:43 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Aug 08, 2013 1:25 pm
Posts: 2
We Upgraded Joomla 3 to 3.1.5 and tooltips for the registration page no longer work correctly.

The class changed from "hasTip" to "hasTooltip" and now the tool tip does not function correctly. The tips make the form move.

Thanks!


Top
 Profile  
 
PostPosted: Thu Aug 08, 2013 2:12 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Aug 08, 2013 1:25 pm
Posts: 2
Update:

Joomla 3.0.3 the registration form worked correctly with the Protostar and Breez3 templates.

When upgrading to Joomla 3.1.5, the Protostar Template worked, but the Breez3 template did not work correctly with the registration form.

Are there changes we should make in the template to handle the Joomla upgrade?

Thanks!


Top
 Profile  
 
PostPosted: Tue Aug 20, 2013 5:11 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Jul 29, 2013 3:44 am
Posts: 1
yaya..i also having the same problem..


Top
 Profile  
 
PostPosted: Thu Aug 29, 2013 1:52 pm 
User avatar
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Mar 26, 2009 8:42 pm
Posts: 3
Hello guys! I'm having this terrible problem also and I made some research. Here's what my progress so far:

1. I am using Isis Template (For Administrator), and Beez Template (For Site).
2. I uses the debug tool of Google Chrome (Press F12 on your google chrome web browser to launch it)
3. Open both admin and site pages in different tabs
4. Examine the list of .css file loaded on separate tabs

When I look closely, I am not seeing a "template.css" on the site page, but in the admin page I can see. When you hover the mouse to the field that launches the tooltip, there's a "div" tag inserting below the "label" tag and it has a class name "tooltip fade top in". I searched for the entire .css files of the Beez template but I cannot see it.

THAT IS WHAT IS MISSING! [As I thought :) ]

What you have to do is open the "template.css" of the Isis template using Notepad, copy the entire "tooltip" class starting from ".tooltip" up to ".tooltip.bottom .tooltip-arrow" (lines 3958 to 4033), and paste it to the one of the .css file where Beez template is using. I tried "personal.css" and paste the entire code class at the bottom.

Save it (don't close yet), go back to google chrome and activate the site tab, hit refresh (F5) and check if there's any changes on the tooltip.

The tooltip shows but it is not in the right position. I haven't tweaked the codes yet. Maybe if you find a fix please post it here. I'll try it tomorrow.

Cheers!

_________________
The best programmers in the world, are those who doesn't work alone.


Top
 Profile  
 
PostPosted: Tue Sep 17, 2013 12:22 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Jun 05, 2009 6:51 am
Posts: 1
Well done, adding the styles from administrator template css file solves the problem.
Wrong position of the tooltip you can fix by removing display: block; from label tag in your template's css.


Top
 Profile  
 
PostPosted: Tue Sep 17, 2013 10:54 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Mon Mar 24, 2008 4:04 pm
Posts: 120
I will try that later.

_________________
Fashions http://www.fashionsjamaica.com/


Real Estate http://www.realjamaicaestate.com


Top
 Profile  
 
PostPosted: Fri Sep 27, 2013 12:49 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Dec 12, 2008 7:54 pm
Posts: 15
The answer is 100% correct and saved me a lot of time! To save others a lil more, here is the CSS from the template.css file:

Code:
.tooltip {
   position: absolute;
   z-index: 1030;
   display: block;
   visibility: visible;
   font-size: 11px;
   line-height: 1.4;
   opacity: 0;
   filter: alpha(opacity=0);
}
.tooltip.in {
   opacity: 0.8;
   filter: alpha(opacity=80);
}
.tooltip.top {
   margin-top: -3px;
   padding: 5px 0;
}
.tooltip.right {
   margin-left: 3px;
   padding: 0 5px;
}
.tooltip.bottom {
   margin-top: 3px;
   padding: 5px 0;
}
.tooltip.left {
   margin-left: -3px;
   padding: 0 5px;
}
.tooltip-inner {
   max-width: 200px;
   padding: 8px;
   color: #fff;
   text-align: center;
   text-decoration: none;
   background-color: #000;
   -webkit-border-radius: 4px;
   -moz-border-radius: 4px;
   border-radius: 4px;
}
.tooltip-arrow {
   position: absolute;
   width: 0;
   height: 0;
   border-color: transparent;
   border-style: solid;
}
.tooltip.top .tooltip-arrow {
   bottom: 0;
   left: 50%;
   margin-left: -5px;
   border-width: 5px 5px 0;
   border-top-color: #000;
}
.tooltip.right .tooltip-arrow {
   top: 50%;
   left: 0;
   margin-top: -5px;
   border-width: 5px 5px 5px 0;
   border-right-color: #000;
}
.tooltip.left .tooltip-arrow {
   top: 50%;
   right: 0;
   margin-top: -5px;
   border-width: 5px 0 5px 5px;
   border-left-color: #000;
}
.tooltip.bottom .tooltip-arrow {
   top: 0;
   left: 50%;
   margin-left: -5px;
   border-width: 0 5px 5px;
   border-bottom-color: #000;
}
.tooltip {
   max-width: 400px;
}
.tooltip-inner {
   max-width: none;
   text-align: left;
   text-shadow: none;
}
th .tooltip-inner {
   font-weight: normal;
}
.tooltip.hasimage {
   opacity: 1;
}
.tip-text {
   text-align: left;
}


Top
 Profile  
 
PostPosted: Mon Oct 14, 2013 8:59 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Sep 18, 2013 11:26 pm
Posts: 6
Thank you! Thank you! Thank you! for the css and taking the time to post - resolved my problem completely!!!


Top
 Profile  
 
PostPosted: Fri Oct 25, 2013 2:43 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Fri Dec 16, 2011 6:13 pm
Posts: 1169
Location: Millersburg, OH
Thanks, this was really helpful!

_________________
Ryan
Numinous Productions
Custom Joomla Templates, Joomla Troubleshooting and Personalized Tutorials
http://www.numinousmedia.com


Top
 Profile  
 
PostPosted: Wed Oct 30, 2013 4:02 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Feb 17, 2009 2:19 pm
Posts: 20
roicarl wrote:
Thank you! Thank you! Thank you! for the css and taking the time to post - resolved my problem completely!!!

The same over here!

Thanks a lot,
Frits


Top
 Profile  
 
PostPosted: Thu Nov 14, 2013 5:22 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Nov 01, 2010 5:42 pm
Posts: 10
this also helped me a lot. My registration form no longer gets distorted on mouseovers. However, I am still seeing the tooltip get cutoff by the registration form border. I can't read the beginning of the tooltip text for tooltips that appear on short field labels, because the tooltip starts too far left of the form border. I think I need to increase the left margin somehow, but haven't found the right rule to tweak... any thoughts?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 



Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group