Joomla 3.1.5 Registration tooltips now not working correctly

Did you may have found a bug in Joomla! 3.x but aren't sure? This forum is the place to help figure out if the problem is a bug and how to report it. If you are an experienced Joomla! user and are certain that you have found a bug please use the Bug Tracker to submit your issue.
This forum is for discussion about bugs and to get help with reporting them to the Bug Tracker: http://issues.joomla.org

Moderators: ooffick, dam-man

Forum rules
Please use the official Bug Tracker to report a bug: http://issues.joomla.org
allanmcnabb
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Aug 08, 2013 1:25 pm

Joomla 3.1.5 Registration tooltips now not working correctly

Postby allanmcnabb » Thu Aug 08, 2013 1:43 pm

We Upgraded Joomla 3 to 3.1.5 and tooltips for the registration page no longer work correctly.

The class changed from "hasTip" to "hasTooltip" and now the tool tip does not function correctly. The tips make the form move.

Thanks!

allanmcnabb
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Aug 08, 2013 1:25 pm

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby allanmcnabb » Thu Aug 08, 2013 2:12 pm

Update:

Joomla 3.0.3 the registration form worked correctly with the Protostar and Breez3 templates.

When upgrading to Joomla 3.1.5, the Protostar Template worked, but the Breez3 template did not work correctly with the registration form.

Are there changes we should make in the template to handle the Joomla upgrade?

Thanks!

vinnchow
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jul 29, 2013 3:44 am

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby vinnchow » Tue Aug 20, 2013 5:11 am

yaya..i also having the same problem..

User avatar
flpblackforest
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Mar 26, 2009 8:42 pm

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby flpblackforest » Thu Aug 29, 2013 1:52 pm

Hello guys! I'm having this terrible problem also and I made some research. Here's what my progress so far:

1. I am using Isis Template (For Administrator), and Beez Template (For Site).
2. I uses the debug tool of Google Chrome (Press F12 on your google chrome web browser to launch it)
3. Open both admin and site pages in different tabs
4. Examine the list of .css file loaded on separate tabs

When I look closely, I am not seeing a "template.css" on the site page, but in the admin page I can see. When you hover the mouse to the field that launches the tooltip, there's a "div" tag inserting below the "label" tag and it has a class name "tooltip fade top in". I searched for the entire .css files of the Beez template but I cannot see it.

THAT IS WHAT IS MISSING! [As I thought :) ]

What you have to do is open the "template.css" of the Isis template using Notepad, copy the entire "tooltip" class starting from ".tooltip" up to ".tooltip.bottom .tooltip-arrow" (lines 3958 to 4033), and paste it to the one of the .css file where Beez template is using. I tried "personal.css" and paste the entire code class at the bottom.

Save it (don't close yet), go back to google chrome and activate the site tab, hit refresh (F5) and check if there's any changes on the tooltip.

The tooltip shows but it is not in the right position. I haven't tweaked the codes yet. Maybe if you find a fix please post it here. I'll try it tomorrow.

Cheers!
The best programmers in the world, are those who doesn't work alone.

szgruca
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Jun 05, 2009 6:51 am

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby szgruca » Tue Sep 17, 2013 12:22 pm

Well done, adding the styles from administrator template css file solves the problem.
Wrong position of the tooltip you can fix by removing display: block; from label tag in your template's css.

User avatar
Utech22
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 120
Joined: Mon Mar 24, 2008 4:04 pm
Contact:

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby Utech22 » Tue Sep 17, 2013 10:54 pm

I will try that later.

ist_04
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Fri Dec 12, 2008 7:54 pm

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby ist_04 » Fri Sep 27, 2013 12:49 pm

The answer is 100% correct and saved me a lot of time! To save others a lil more, here is the CSS from the template.css file:

Code: Select all

.tooltip {
   position: absolute;
   z-index: 1030;
   display: block;
   visibility: visible;
   font-size: 11px;
   line-height: 1.4;
   opacity: 0;
   filter: alpha(opacity=0);
}
.tooltip.in {
   opacity: 0.8;
   filter: alpha(opacity=80);
}
.tooltip.top {
   margin-top: -3px;
   padding: 5px 0;
}
.tooltip.right {
   margin-left: 3px;
   padding: 0 5px;
}
.tooltip.bottom {
   margin-top: 3px;
   padding: 5px 0;
}
.tooltip.left {
   margin-left: -3px;
   padding: 0 5px;
}
.tooltip-inner {
   max-width: 200px;
   padding: 8px;
   color: #fff;
   text-align: center;
   text-decoration: none;
   background-color: #000;
   -webkit-border-radius: 4px;
   -moz-border-radius: 4px;
   border-radius: 4px;
}
.tooltip-arrow {
   position: absolute;
   width: 0;
   height: 0;
   border-color: transparent;
   border-style: solid;
}
.tooltip.top .tooltip-arrow {
   bottom: 0;
   left: 50%;
   margin-left: -5px;
   border-width: 5px 5px 0;
   border-top-color: #000;
}
.tooltip.right .tooltip-arrow {
   top: 50%;
   left: 0;
   margin-top: -5px;
   border-width: 5px 5px 5px 0;
   border-right-color: #000;
}
.tooltip.left .tooltip-arrow {
   top: 50%;
   right: 0;
   margin-top: -5px;
   border-width: 5px 0 5px 5px;
   border-left-color: #000;
}
.tooltip.bottom .tooltip-arrow {
   top: 0;
   left: 50%;
   margin-left: -5px;
   border-width: 0 5px 5px;
   border-bottom-color: #000;
}
.tooltip {
   max-width: 400px;
}
.tooltip-inner {
   max-width: none;
   text-align: left;
   text-shadow: none;
}
th .tooltip-inner {
   font-weight: normal;
}
.tooltip.hasimage {
   opacity: 1;
}
.tip-text {
   text-align: left;
}

roicarl
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Sep 18, 2013 11:26 pm

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby roicarl » Mon Oct 14, 2013 8:59 pm

Thank you! Thank you! Thank you! for the css and taking the time to post - resolved my problem completely!!!

User avatar
numinousmedia
Joomla! Ace
Joomla! Ace
Posts: 1474
Joined: Fri Dec 16, 2011 6:13 pm
Location: Millersburg, OH
Contact:

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby numinousmedia » Fri Oct 25, 2013 2:43 pm

Thanks, this was really helpful!
Ryan
Frontend Developer and Joomla Professional
Ethode Website Development: http://www.ethode.com
Personal Site: http://www.numinousmedia.com

oorzaak
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Tue Feb 17, 2009 2:19 pm

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby oorzaak » Wed Oct 30, 2013 4:02 pm

roicarl wrote:Thank you! Thank you! Thank you! for the css and taking the time to post - resolved my problem completely!!!

The same over here!

Thanks a lot,
Frits

irosas
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Mon Nov 01, 2010 5:42 pm

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby irosas » Thu Nov 14, 2013 5:22 pm

this also helped me a lot. My registration form no longer gets distorted on mouseovers. However, I am still seeing the tooltip get cutoff by the registration form border. I can't read the beginning of the tooltip text for tooltips that appear on short field labels, because the tooltip starts too far left of the form border. I think I need to increase the left margin somehow, but haven't found the right rule to tweak... any thoughts?

oxygencreative
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Feb 07, 2012 6:39 pm

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby oxygencreative » Mon Nov 24, 2014 4:08 pm

ist_04 wrote:The answer is 100% correct and saved me a lot of time! To save others a lil more, here is the CSS from the template.css file:


Thanks to all but especially for taking the time to post the CSS. It took me less time to fix my issue with the tooltips than it did to find my login for the forum here! :-[

yoann
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Mar 10, 2015 10:12 am

Re: Joomla 3.1.5 Registration tooltips now not working corre

Postby yoann » Tue Mar 10, 2015 10:18 am

Wonderfull, i'm breaking my head since 4 hours to adapt it on 4 of my websites...

Thanks alot for sharing


Return to “Joomla! 3.x Bug Reporting”

Who is online

Users browsing this forum: No registered users and 2 guests