URLs amigáveis causando erro estranho!

Moderator: ariadneduvessa

Locked
ArquivoTI
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Nov 18, 2006 4:22 am

URLs amigáveis causando erro estranho!

Post by ArquivoTI » Sat Nov 18, 2006 4:28 am

Caros,

Estou com uma instalação do Joomla 1.0.10 (PTB) funcionando em http://www.arquivoti.com.br/site, com apenas uma notícia postada para que possa ficar melhor explicado o meu problema.

Utilizei a opção de SEF (Urls Amigáveis) em minha página, e nela também utilizo aquela opção de links para categorias juntamente com cada notícia, e é aí onde está o problema!!!

Se eu estiver utilizando Urls Amigáveis, o link para categoria não funciona corretamente!

Por exemplo, eu tenho a notícia postada, abro ela normalmente no link 'Leia Mais...', e se por acaso, eu me interesso em clicar no link para categoria 'inclusão digital', ele vai parar na categoria 'armazenamento' que é outra totalmente diferente!!

Se eu utilizar urls normais, tudo funciona perfeitamente, sem maiores problemas!!

Aguardo um retorno... Abraços a todos!!  :'(

User avatar
bigodines
Joomla! Hero
Joomla! Hero
Posts: 2237
Joined: Thu Aug 18, 2005 11:10 am
Location: Floripa, Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by bigodines » Tue Nov 21, 2006 2:51 pm

o site não abriu aqui. :/

ArquivoTI
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Nov 18, 2006 4:22 am

Re: URLs amigáveis causando erro estranho!

Post by ArquivoTI » Tue Nov 21, 2006 4:15 pm

Caros,

Peço desculpas pela url que repasse...

É que de tanto tentar sem sucesso implantar urls amigáveis, eu acabei desistindo, inclusive, agradeço muito ao Kapone_pt do Joomlapt que tentou me ajudar, mas também, sem sucesso.

Coloquei de volta ao ar sem utilizar urls amigáveis, com as urls normais mesmo, e todos os meus problemas acabaram...

http://www.arquivoti.com.br

User avatar
ronildo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4022
Joined: Thu Aug 18, 2005 12:39 pm
Location: São Paulo - Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by ronildo » Tue Nov 21, 2006 5:37 pm

Putz cara, parabéns pelo site, ficou muito bom.
http://www.ronildo.com.br/blog/ pt-br | twitter: twitter.com/ronildo
http://forum.joomla.org/viewtopic.php?f=23&t=144443 - FAQ Joomla [pt]
Pessoal por favor não tiro dúvidas por e-mail nem mensagem privada, por favor não insistam.

User avatar
fititnt
Joomla! Hero
Joomla! Hero
Posts: 2350
Joined: Sat Jul 15, 2006 1:41 am
Location: Porto Alegre - RS - Brazil
Contact:

Saiba como USAR URLs amigáveis com o Opensef

Post by fititnt » Sat Dec 02, 2006 2:51 pm

Cara, eu to sem tempo pra digitar, mas lá vai uma ajuda. Eu demorei semanas pra botar meu site funcionar decentemente. Alias, se algum site aqui desejar, eu posto um TUTORIAL mais decente e padrão em português para quem não se defende bem em ingles se achar. Por isso, depois do dia 15 de dezembro, se um pessoal de alguns do joomla por estado, ou do joomlabrasil.com.br quiserem, é so mandar email.

Tutorial testado em joomla 1.0.8 a 1.0.11

1 - Verifique seu servidor

Seu servidor php pode ser por modulo, ou por cgi. Este exemplo funciona para mim para CGI, mas note que a maioria dos servidores são módulo php

2 - .htaccess

Muito importante!. Ainda estou melhorando os htaccess do mesu sites, mas esse costuma funcionar. Salve um arquivo com o código abaixo com no nome .htacess na raiz de seu site. Se seu site ficar fora do ar, ou é porque não customizou esse arquivo, ou porque seu servidor não é CGI

//EDITADO

Veja o código a ser inserido no .htaccess no tópico http://forum.joomla.org/index.php/topic,124708.0.html

//EDITADO


3. Abilite o SEO

Vá na àrea Administrativa, e então configurações globais > SEO > Search Engine Friendly URLs: SIM. Como você já já colocou o .haccess no paso 2 na raiz do seu site com o código certo, essa opção pode ser habilidada.

4. Instale um gerenciador de urls amigaveis decente.

O melhor que achei até hoje é o OpenSEF. Demorei, e muito pra customizar, mas depois é muito bom. Tem uma briga do cara que fez ele, o do Core do joomla, pq não quisera, agregar o OpenSEF no core. de Qualquer forma, baixe-o.

http://projects.j-prosolution.com/en/pr ... ensef.html

5. Ative o OpenSEF

Vá em Components > OpenSEF > Configuração > Ligar o OpenSEF? SIM
Teoricamente nessa altura deve dar certo e você vai estar feliz. Se não der, vai ter que remar mais um pouco. Uma das poucas mudanças que faço é em Codificação Opensef > Estrutura de URLs de Conteúdo: Category/Title


6. Considerações finais

Estou sem tempo para fazer algo decente, e, sinceramente, acho mais pratico escrevcer tutoriais e deixálos em locais bem visíveis em um site do que ficar repitindo a mesma coisa dezenas de vezes em um fórum.

Se tudo ou mais fallhar, delete ou altere o .htaccess, e ao menos sua area administrativa deve estar disponível. então, entre em seusite.com.be/administrator, logue-se como admin, e altere nas configurações globais o SEO ativado.

O OpenSEF não se dá muito bem com pluguins externos MUITO avançados, como o Fórum SMF, mas para o joomla em si, ele é excelente.

7. Exemplos de como ficaria

Seu site, em vez de ficar com uma URL tosca como essa http://www.arquivoti.com.br/portal/inde ... iew&id=117, ficaria com algo como http://www.arquivoti.com.br/portal/Comp ... Windows-XP.

Não é preciso ser muito inteligente para ver qual URL agrada mais os visitantes, e, claro, o google e seu pagerank!
Last edited by fititnt on Mon Feb 26, 2007 10:51 pm, edited 1 time in total.
Emerson da Rocha Luiz
Moderador aposentado, 2008-2014 | Membro do JUGRS
http://www.fititnt.org

ArquivoTI
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Nov 18, 2006 4:22 am

Re: URLs amigáveis causando erro estranho!

Post by ArquivoTI » Sat Dec 02, 2006 9:43 pm

Caro,

Agradeço muito o seu esforço, mais depois que segui sua dica, meu site apresentou  vários erros, INCLUSIVE NA ÁREA DE ADMINISTRAÇÃO! Resultado... Tentei voltar pro que era antes, não consegui.

Resultado final: Perdi todo meu trabalho!!!  :(

User avatar
ronildo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4022
Joined: Thu Aug 18, 2005 12:39 pm
Location: São Paulo - Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by ronildo » Sat Dec 02, 2006 9:49 pm

Amigo nunca, nunca mesmo faça testes no site de produção sempre (sempre) crie uma uma instalação para fazer testes.
E outra coisa, mesmo tendo certeza quando for mexer em alguma coisa um pouco mais séria faça um backup antes não leva 5min pra vc fazer isso.

Acredito que vc trocando apenas trocando o nome do arquivo .htaccess para htaccess.txt vc resolverá o seu problema. (Ou então pegue-o de alguma instalação nova e substitua, esse procedimento é o mais indicado.)
E indo na administração desabilitando o sef tanto nas configurações globais como no próprio componente.

Como assim erro??? O que seriam esses erros na administração??

ArquivoTI wrote: Caro,

Agradeço muito o seu esforço, mais depois que segui sua dica, meu site apresentou  vários erros, INCLUSIVE NA ÁREA DE ADMINISTRAÇÃO! Resultado... Tentei voltar pro que era antes, não consegui.

Resultado final: Perdi todo meu trabalho!!!  :(
http://www.ronildo.com.br/blog/ pt-br | twitter: twitter.com/ronildo
http://forum.joomla.org/viewtopic.php?f=23&t=144443 - FAQ Joomla [pt]
Pessoal por favor não tiro dúvidas por e-mail nem mensagem privada, por favor não insistam.

User avatar
fititnt
Joomla! Hero
Joomla! Hero
Posts: 2350
Joined: Sat Jul 15, 2006 1:41 am
Location: Porto Alegre - RS - Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by fititnt » Sat Dec 02, 2006 10:04 pm

Humm, olha, no começo, quando comecei a lidar com joomla, também sofri. Não comecei como muitos aqui desde o m4mbo, vim direto do xoops, por isso tive que me adaptar um pouco ás mudanças. No começo parece caótico e ilógico, mas depois vc aprende que na verdade é o cara só que tem que saber lidar com ele.
Last edited by fititnt on Sat Dec 02, 2006 10:07 pm, edited 1 time in total.
Emerson da Rocha Luiz
Moderador aposentado, 2008-2014 | Membro do JUGRS
http://www.fititnt.org

ArquivoTI
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Nov 18, 2006 4:22 am

Re: URLs amigáveis causando erro estranho!

Post by ArquivoTI » Sat Dec 02, 2006 10:05 pm

Tentei voltar o htacess.txt original (ao menos disso eu havia feito backup), mesmo assim, o erro continua, na parte onde se modifica os temas, na área de administração, agora aparecem linhas mostrando erros...

User avatar
fititnt
Joomla! Hero
Joomla! Hero
Posts: 2350
Joined: Sat Jul 15, 2006 1:41 am
Location: Porto Alegre - RS - Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by fititnt » Sat Dec 02, 2006 10:14 pm

na verdade, se você não ter usar o .htacess, não te serve de nada ter o htacess.txt . Ele não muda nada no joomla. Se der merda, apague o htaccess.txt. Com isso, a area administrativa vai voltar a funcionar. o site talvez não funcione, mas na area administrativa funciona sim pq não é feito alterações de SEO dela. Entre na area administrativa e, altere nas configurações e desabilite o SEO do joomla.

Só da erros alem disso se você fez mais alterações do que devia. Editar arquivos php no braço, por exemplo, ainda que por engano.
Emerson da Rocha Luiz
Moderador aposentado, 2008-2014 | Membro do JUGRS
http://www.fititnt.org

User avatar
pchardnet
Joomla! Ace
Joomla! Ace
Posts: 1888
Joined: Thu Aug 18, 2005 5:34 pm
Location: BH/MG - Brasil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by pchardnet » Sat Dec 02, 2006 11:28 pm

A explicação do fititnt é correta, mas mesmo assim há algumas "frescuras" que ainda não descobri que impedem o SEF de funcionar corretamente.

Este tópico - http://forum.joomla.org/index.php/topic,70608.0.html - foi bem sucedido. Sugiro que leiam, pois quem sabe pode ajudá-los.

User avatar
fititnt
Joomla! Hero
Joomla! Hero
Posts: 2350
Joined: Sat Jul 15, 2006 1:41 am
Location: Porto Alegre - RS - Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by fititnt » Sun Dec 03, 2006 6:22 am

ArquivoTI wrote: Tentei voltar o htacess.txt original (ao menos disso eu havia feito backup), mesmo assim, o erro continua, na parte onde se modifica os temas, na área de administração, agora aparecem linhas mostrando erros...
Seu site roda como módulo ou como CGI?
Emerson da Rocha Luiz
Moderador aposentado, 2008-2014 | Membro do JUGRS
http://www.fititnt.org

User avatar
pchardnet
Joomla! Ace
Joomla! Ace
Posts: 1888
Joined: Thu Aug 18, 2005 5:34 pm
Location: BH/MG - Brasil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by pchardnet » Sun Dec 03, 2006 9:26 pm

não

User avatar
FaBMak
Joomla! Guru
Joomla! Guru
Posts: 611
Joined: Fri Aug 19, 2005 1:59 am
Location: Brasil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by FaBMak » Mon Dec 04, 2006 3:08 am

pchardnet wrote: não
Hein ?

FaBMak
Fabricio Elias Costa - Moderador do Joomla.org e Coordenador da Tradução Brasileira do Joomla!
Katipsoi Zunontee - http://ka-tips-oi-zu-non-tee.com/

User avatar
fititnt
Joomla! Hero
Joomla! Hero
Posts: 2350
Joined: Sat Jul 15, 2006 1:41 am
Location: Porto Alegre - RS - Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by fititnt » Mon Dec 04, 2006 5:11 am

Veja ao certo qual o seu caso, que podemos ver se lhe ajudamos. Se alguém mais não se dispor, espere alguns dias e assim que eu estiver livre te dou uma ajuda. Um dos meus servidores é por módulo, e, embora eu não tenha instalado o opensef nele, acho que posso ver se quebro seu galho.

Mas parece que tem mais gente que conseguiu fazer isso em server rodando módulo. Qualquer hora dessas também vou ver se texto no J! 1.5 beta, mas não tive tempo ainda para brincar mais a sério com essa versão.
Emerson da Rocha Luiz
Moderador aposentado, 2008-2014 | Membro do JUGRS
http://www.fititnt.org

User avatar
pchardnet
Joomla! Ace
Joomla! Ace
Posts: 1888
Joined: Thu Aug 18, 2005 5:34 pm
Location: BH/MG - Brasil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by pchardnet » Mon Dec 04, 2006 12:20 pm

FaBMak wrote:
pchardnet wrote: não
Hein ?

FaBMak
Haha...
é a pressa na leitura.

Roda com Módulo e não com CGI.

Sorry!

Giovani

Re: URLs amigáveis causando erro estranho!

Post by Giovani » Mon Dec 04, 2006 12:42 pm

"Desculpe-nos o transtorno Estamos passando por sérias modificações em nosso Servidor. AGUARDE!"  :(

User avatar
fititnt
Joomla! Hero
Joomla! Hero
Posts: 2350
Joined: Sat Jul 15, 2006 1:41 am
Location: Porto Alegre - RS - Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by fititnt » Mon Dec 04, 2006 9:39 pm

Giovani wrote: "Desculpe-nos o transtorno Estamos passando por sérias modificações em nosso Servidor. AGUARDE!"  :(

Uhum. Se quiser alguma ajuda, dá um berro que o pessoal te dá uma força. A gente sabe que é chato ficar com um site funcional fora do ar.
Emerson da Rocha Luiz
Moderador aposentado, 2008-2014 | Membro do JUGRS
http://www.fititnt.org

User avatar
fititnt
Joomla! Hero
Joomla! Hero
Posts: 2350
Joined: Sat Jul 15, 2006 1:41 am
Location: Porto Alegre - RS - Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by fititnt » Fri Dec 08, 2006 4:57 pm

Code: Select all

<meta name="generator" content="WordPress 2.0.5" />
o.Ô

Eita. Pelo jeito até largou o joomla. Por isso que DEVE-SE fazer back up. O pessoal aqui não se importa de dar uma força, ou até ajduar a recuperar a base de dados, ou o site. Bastava uma ou duas horas no máximo de conversas pelo msn.
Emerson da Rocha Luiz
Moderador aposentado, 2008-2014 | Membro do JUGRS
http://www.fititnt.org

User avatar
rodrigo_virgilio
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Thu Dec 07, 2006 9:50 am
Contact:

Re: URLs amigáveis causando erro estranho!

Post by rodrigo_virgilio » Sun Jun 10, 2007 10:18 pm

favor acertar o link para download do OpenSEF para este http://projects.j-prosolution.com/proje ... ensef.html

User avatar
pedrorenan
Joomla! Guru
Joomla! Guru
Posts: 557
Joined: Wed Feb 22, 2006 7:52 pm
Location: Goiânia - GO - BR

Re: URLs amigáveis causando erro estranho!

Post by pedrorenan » Wed Jun 13, 2007 4:57 pm

galera só pra constar, to usando opensef do jeito que esse tuto esta ensinando e deu muito certo. Em um outro topico eu já havia discutido esse assunto e o pc me ajudou, parou de dar erro mas nao ficou 100% e aqui na UFT nem sempre eu posso trabalhar no que eu quero. Agora ta dando certo, to achando otimo :D parabens pelo tuto
Pedro Renan
Grupo de Usuários Joomla! - TO

User avatar
marcelobragatf
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Sat Sep 08, 2007 1:58 pm
Location: Tefé
Contact:

Re: URLs amigáveis causando erro estranho!

Post by marcelobragatf » Sat Sep 08, 2007 2:02 pm

:oSou iniciante no Joomla e PHP. Meu site está ainda em desenvolvimento, mas não consegui habilitar corretamente o opensef pois quando ligo no SEO as url amigaveis e ativo o opensef os links do menu param de funcionar. Vi no forum que temos que identificar se o PHP esta em modulo ou CGI pois o opensef só funciona em CGI, mas não sei como identificar aqui no meu servidor como o PHP está funcionando.

Vocês poderiam me dar uma ajuda?

User avatar
fititnt
Joomla! Hero
Joomla! Hero
Posts: 2350
Joined: Sat Jul 15, 2006 1:41 am
Location: Porto Alegre - RS - Brazil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by fititnt » Sat Sep 08, 2007 2:52 pm

Olá marcelobragatf,

Antes de qualquer coisa seja bem vindo ao fórum.

A informação que de o opensef funciona só com servidor em CGI não procede. Roda muito bem em servidor php rodando como módulo também.

Dê uma olhada na FAQ que de lá tem alguns links bem interessantes de serem vistos, inclusive alguns falando de erros comuns na instalação do opensef.

Esta extenção não é só do tipo instalar via administração e sair usando. Todas as melhorias de SEO não so com joomla são complicadas mesmo, e isso vai exigir um pouco paciência.

Uma coisa eu digo, agora vai ser mais fácil pra você usar ele, porque agora tem muitos foruns e FAQs em protugues, nao só nesse site, falando dele, e certamente sua dúvida já foi tirada. Por isso vale a pena investir algum tempo e buscar que certramente vai ser mais rápido do que esperar que os outros dêem auxílio, até porque vão partir do princípio que você já procurou antes.

Complicado éra a váaaarios meses atrás que não tinha quase nada explicando como instalar essa extenção, e que até mesmo em inglês não era dito muito claro no próprio site do deseolvovedor como resolver alguns erros que acontecem com servidores específicos, como aconteceu comigo.

De qualquer forma, se estiver ainda assim muito complicado, dai sim dá uma postada aqui. E caso consiga, pelo menos diga qual foi seu erro.

[]'s
Emerson da Rocha Luiz
Moderador aposentado, 2008-2014 | Membro do JUGRS
http://www.fititnt.org

User avatar
marcelobragatf
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Sat Sep 08, 2007 1:58 pm
Location: Tefé
Contact:

Re: URLs amigáveis causando erro estranho!

Post by marcelobragatf » Sat Sep 08, 2007 3:14 pm

valeu mano! um abraço

User avatar
marcelobragatf
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Sat Sep 08, 2007 1:58 pm
Location: Tefé
Contact:

Re: URLs amigáveis causando erro estranho!

Post by marcelobragatf » Sat Sep 08, 2007 3:28 pm

Na verdade acredito q o problema está no arquivo .htaccess. Renomeei normalmente e até utilizei um que vc postou aqui no forum, mas não deu certo. Quando eu ativo o SEF no menu já indica uma url amigável para os links, mas na hora em que clico dá como se o artigo tivesse sido deletado dá uma olhada

Image

Eu nunca usei o opensef e não sei se tenho que fazer mais alguma coisa após ativa-lo

User avatar
FaBMak
Joomla! Guru
Joomla! Guru
Posts: 611
Joined: Fri Aug 19, 2005 1:59 am
Location: Brasil
Contact:

Re: URLs amigáveis causando erro estranho!

Post by FaBMak » Mon Sep 10, 2007 2:27 am

marcelobragatf wrote: Eu nunca usei o opensef e não sei se tenho que fazer mais alguma coisa após ativa-lo
Esse erro é típico do módulo Rewrite não ativado pelo Apache. Verifique no phpinfo se em "Loaded Modules" aparece "mod_rewrite".

Também pode ser a diretiva "AllowOverride" no Apache, que em instalações padrões pode estar como "AllowOverride None" sendo que para ativar o .htaccess deve ficar como ""AllowOverride All".

FaBMak
Fabricio Elias Costa - Moderador do Joomla.org e Coordenador da Tradução Brasileira do Joomla!
Katipsoi Zunontee - http://ka-tips-oi-zu-non-tee.com/

jweber
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Jun 02, 2006 7:45 pm

Re: URLs amigáveis causando erro estranho!

Post by jweber » Mon Sep 24, 2007 10:20 pm

Pessoal, para quem não conseguiu resolver este problema. Veja a solução:

http://www.joomlabrasil.org/component/o ... c,12718.0/


Locked

Return to “Portuguese Forum”