Community Builder patch for Joomla 1.0.13

Discuss the development and implementation of Joomla! components here.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19006
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Community Builder patch for Joomla 1.0.13

Post by infograf768 » Sun Jul 22, 2007 6:20 pm

Thanks to Sam and while we wait for Beat to upgrade CB, find here a patch to CB correcting the login issues.
These are due to the hardening of security in Joomla 1.0.13.

The patch has also been provided on their forums.

EDIT: new file as provided by Sam today (see below)

http://forum.joomla.org/index.php?actio ... tach=35761
Last edited by infograf768 on Tue Jul 24, 2007 5:49 am, edited 1 time in total.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

 
nipnip
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Jul 12, 2007 11:07 pm

Re: Community Builder patch for Joomla 1.0.13

Post by nipnip » Mon Jul 23, 2007 4:35 pm

how should i use that? just replace using ftp? where?

User avatar
rawkey
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Fri Aug 18, 2006 12:07 pm

Re: Community Builder patch for Joomla 1.0.13

Post by rawkey » Mon Jul 23, 2007 6:39 pm

i get "I like pie11f041ea80cf1fa0fc212d5b2e1af365" when I try and login, totally locked out of my site at the moment  :(

Any help appreciated!!!

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19006
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Community Builder patch for Joomla 1.0.13

Post by infograf768 » Tue Jul 24, 2007 5:00 am

nipnip wrote: how should i use that? just replace using ftp? where?
The zip contains the file com_profiler.php
Replace your old one with this new one by ftp.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

pasamio
Joomla! Ace
Joomla! Ace
Posts: 1318
Joined: Thu Aug 18, 2005 9:27 am
Location: San Jose, CA, USA
Contact:

Re: Community Builder patch for Joomla 1.0.13

Post by pasamio » Tue Jul 24, 2007 5:06 am

Removes the pie check to return a auth fail message
You do not have the required permissions to view the files attached to this post.
Sam Moffatt
Updater, Installer and Authentication Systems
JoomlaCode Backend Systems
Pie.

User avatar
tresan
Joomla! Ace
Joomla! Ace
Posts: 1010
Joined: Thu Feb 09, 2006 3:00 pm
Location: Odense - DK
Contact:

Re: Community Builder patch for Joomla 1.0.13

Post by tresan » Tue Jul 24, 2007 10:12 am

HTTP 403 error when trying to login from frontend after using the comprofiler update.
Ronni K. G. Christiansen (@redwebdk)
http://www.redcomponent.com/ - One big family of Joomla extentions & templates
http://redweb.dk - Joomla Webdesign & Development
redHOST.dk - 100% Joomla Webhotel - Dansk support med Joomla viden!

User avatar
tresan
Joomla! Ace
Joomla! Ace
Posts: 1010
Joined: Thu Feb 09, 2006 3:00 pm
Location: Odense - DK
Contact:

Re: Community Builder patch for Joomla 1.0.13

Post by tresan » Tue Jul 24, 2007 10:25 am

I updated from 12 to 13 on 2 different sites running on the same host.

1 site has comprofiler and has the problems, other works fine.

I updated the new file from the attactment in the top and then after that didnt work i tried the one posted by pasamio - same thing happens for both i.e says http 403 and the pages requires me to login to show the content.
Ronni K. G. Christiansen (@redwebdk)
http://www.redcomponent.com/ - One big family of Joomla extentions & templates
http://redweb.dk - Joomla Webdesign & Development
redHOST.dk - 100% Joomla Webhotel - Dansk support med Joomla viden!

User avatar
tresan
Joomla! Ace
Joomla! Ace
Posts: 1010
Joined: Thu Feb 09, 2006 3:00 pm
Location: Odense - DK
Contact:

Re: Community Builder patch for Joomla 1.0.13

Post by tresan » Thu Jul 26, 2007 6:13 pm

help?
Ronni K. G. Christiansen (@redwebdk)
http://www.redcomponent.com/ - One big family of Joomla extentions & templates
http://redweb.dk - Joomla Webdesign & Development
redHOST.dk - 100% Joomla Webhotel - Dansk support med Joomla viden!

Spyder_Snyper
Joomla! Apprentice
Joomla! Apprentice
Posts: 42
Joined: Wed Jan 25, 2006 1:24 am

Re: Community Builder patch for Joomla 1.0.13

Post by Spyder_Snyper » Tue Oct 09, 2007 6:18 pm

i tried installing the patch, and I got an error, something about being unable to redeclare IsAdmin (or something similar) on line 15xx.  I changed it back to the old com_profiler, but if need be, I can change it to the new one to get the EXACT error message...

 

Locked

Return to “Components”