Error: The XML response that was returned from the server cannot be processed

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
luisB
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Aug 22, 2007 5:58 pm

Error: The XML response that was returned from the server cannot be processed

Post by luisB » Wed Aug 22, 2007 6:11 pm

:o Pleaseeee.... Help.
Every time I try to install joomla 1.5  in the root directory of my site using the installation wizard.  The following error is generated at the FTP configuration    when click in the Autofind FTP path  or Verify FTP Settings Bottons.

"Error: The XML response that was returned from the server cannot be processed"

If I just skip to the next step,  I got the same error.

Please tell me what should I do.

In the FTP user ID:  I'm entering the correct ID
I'm also typing the correct password.
in the FTP Root Path the following info is entered: public_html

please help.
Last edited by luisB on Sun Sep 09, 2007 4:40 am, edited 1 time in total.

theasylum
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Aug 22, 2007 6:22 pm
Contact:

Re: Error: The XML response that was returned from the server cannot be processe

Post by theasylum » Wed Aug 22, 2007 6:45 pm

I have seen several people have problems with this same problem.  I keep reading people saying that it is fixed, and to download the nightly build to resolve the problem.  I have tried several times the past few days with the nightly build for that day and still get this error.  I am installing in a subdomain on my VPS which has Whm and Cpanel.  I used pure-ftp and tried pro-ftp also,  I even re-compiled my apache with every option except for a few experimental and beta modules to make sure I have all the modules joomla needs to work correctly.

The error I get when verifying ftp and when I try to install sample data is
The XML Response From Server Was Invalid

I skipped the ftp and the sample data and got joomla working, but I need the sample data, so that all the modules will get setup.   

We either have server problems or joomla has problems with our servers.

xoph
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Fri May 26, 2006 9:10 am

Re: Error: The XML response that was returned from the server cannot be processe

Post by xoph » Wed Aug 22, 2007 7:31 pm

I also got that error message. PHP and other settings were validated as fine in the installation process. The front page looks depracated. Hope for help too.

kallussed
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Aug 22, 2007 8:10 pm

Re: Error: The XML response that was returned from the server cannot be processed

Post by kallussed » Wed Aug 22, 2007 8:13 pm

I get the same error.  Is there anything I can do to assist on troubelshooting this issue?

theasylum
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Aug 22, 2007 6:22 pm
Contact:

Re: Error: The XML response that was returned from the server cannot be processed

Post by theasylum » Wed Aug 22, 2007 8:39 pm

I don't understand how people can get it to work and us others can not.  Can someone that has gotten the ftp and sample data to work during install on their server could you please post your Apache, PHP and ftp server details of all modules and versions etc...  Then us users that can not get it to work, can compare our settings to see if there is a problems with our server configs or if there is a certain version of software on our servers that causes joomla to throw this error.  I'm no expert, but when some people don't have a single problem with it and us others are having tons of problems, it makes me think that there could be somthing in joomla that causes it to not work with certain server configs and versions whille letting it work with other configs etc...  So if someone could please post all their server configs and versions maybe we can get somewhere with this issue. 

tronmcp
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Aug 25, 2007 10:09 pm

Re: Error: The XML response that was returned from the server cannot be processed

Post by tronmcp » Sat Aug 25, 2007 10:15 pm

I am having the same issue has this been resolved? I have looked on the forum but I can not see any solution, perhaps I have missed it. :(

tronmcp
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Aug 25, 2007 10:09 pm

Re: Error: The XML response that was returned from the server cannot be processed

Post by tronmcp » Sat Aug 25, 2007 11:25 pm

tronmcp wrote: I am having the same issue has this been resolved? I have looked on the forum but I can not see any solution, perhaps I have missed it. :(

I was able to get this to work by doing the following steps:

Select "No" for the FTP Layer Installation
Skipping the "Install Sample Data" selection

Then I  completed the installation and I was able to copy the configuration to my configuration file and the home page showed up with no data.

I accessed phpMyAdmin
I opened the Joomla dB and uploaded the SQL for the sample data from my pc:
/installation/sql/mysql/sample_data.sql

I accessed the admin page and went to Global Configuration->Server
Here I updated the FTP settings
In order to save the data you might have to make the configuration.php file writable first

After saving, Joomla was able to use the FTP access (it seems). I changed the configuration.php back to unwritable, and I was still able to update my configuration.

At first I tried to install the 1.0.12 version of Joomla and had lots of issues with file permissions but now even though directories are unwritable it seems that this version works better, I was able to install it!! :)

Hope this helps!

Gorescore
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Aug 26, 2007 10:28 am

Re: Error: The XML response that was returned from the server cannot be processe

Post by Gorescore » Sun Aug 26, 2007 10:35 am

Same problem here ...

Centos 4.4, xampp for Linux ... embedded Proftpd in xampp disabled and additional Deamon vsftpd with FTP over TLS only running.

>> Error: The XML response that was returned from the server cannot be processed

It is not a right problem,for testing i made a chmod -R 777 on the Joomla dir.

But what about the people like me who disabled "normal" FTP (cause it is extremly unsecure !) and only have FTP over TLS running ?

@Developers
If you need logs let me know it ...

Marcus ...
Last edited by Gorescore on Mon Aug 27, 2007 8:42 am, edited 1 time in total.

buzybonnie
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Thu Jun 14, 2007 3:21 am

Re: Error: The XML response that was returned from the server cannot be processed

Post by buzybonnie » Sun Aug 26, 2007 11:20 pm

I have the same problems.  Got it to install without the sample data, but can't get phpmyadmin to install to try that as a means of uploading the sample data.  If I simply follow the instructions to delete the installation file at this point, I get an error....

Fatal error: Cannot instantiate non-existent class: jconfig in D:\inetpub\inmysparetime\includes\framework.php on line 47

I am on an IIS server.  Is this why i'm having so many problems?  I was able to install 1.12 and patch just fine on my other domain with a couple of work arounds on the "rights" issue, which is supposedly addressed in 1.5.

Help:(  I've spent two days now on this.  Maybe I'll just have to start and stay with 1.13. I hate to do that with a brand new site when I know there are a ton of changes and new features in 1.5 and would rather start right out of the gate.

18ck
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Jan 28, 2007 9:11 am
Contact:

Re: Error: The XML response that was returned from the server cannot be processed

Post by 18ck » Mon Aug 27, 2007 5:36 pm

I've been getting this too. Coincidentally I also installed net2php on another sit and that bombed too because it couldn't find the php ftp module. Since that mod is installed (according to phpinfo(); I'm going on the assumption that it's som sort of hsoting issue - maybe they have some sort of block on scripts doing certain things - so I've written to them to ask. Still waiting for a reply. Thought I'd mention it in case it was a factor in any of your cases too...?

johanl
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Aug 27, 2007 8:01 pm

Re: Error: The XML response that was returned from the server cannot be processe

Post by johanl » Mon Aug 27, 2007 8:27 pm

Hi!
Here's probably a solution for you guys from an absolute joomla beginner!

This is what I did after I got the same errors on an Ubuntu Linux installation using Apache2, MySQL5 and PHP5

Before loading the installation/index.php wizard
1. Install your web server, mysql and php components correctly! I won't cover this here... it was pretty easy in ubuntu linux with the apt-get utility

2. Make sure all files are owned by the user that runs the webserver process

Go to the web server root and chmod all files recursively
cd /var/www/htdocs
chown -R user:group joomla
  'user' is the webserver user: www-data on ubuntu, normally apache on other linuxes
  'group' is the primary group for the webserver user: www-data on ubuntu, apache on others

The example assumes your web server root is in /var/www/htdocs and the joomla root directory for your site is in the sub directory joomla

3. Do NOT rename the sample configuration.php-dist file to configuration.php, start without a configuration file in you joomla root

4. Create a database and user in MySQL using the console
    create database joomla;
    grant all on joomla.* to 'joomla'@'localhost' identified by 'secretpassword';
    flush privileges;


Start the installation wizard. Hopefully it works without the errors.

If you're running windows... my guess is that you need to make all files and directories readable and writable for "Everyone" or something...

Best regards Johan

Ron22
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Aug 27, 2007 11:49 pm

Re: Error: The XML response that was returned from the server cannot be processe

Post by Ron22 » Tue Aug 28, 2007 12:09 am

Check out these pages, where it is discussed as a known bug. Toward the end, on page 2, some workarounds are offered.

http://forum.joomla.org/index.php/topic,193052.0.html
http://forum.joomla.org/index.php/topic,193052.30.html

theasylum
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Aug 22, 2007 6:22 pm
Contact:

Re: Error: The XML response that was returned from the server cannot be processed

Post by theasylum » Tue Aug 28, 2007 2:58 am

Hey all if you haven't figured this one out already, all you have to do is to leave your configuration.php.dist named as is, and install like you normaly do.  In Joomla 1.0 you used to have to change the name of it, but Joomla 1.5 will error out with the XML Error.  So when you get the error that your configuration.php.dist is non writable on the install screen just continue with your installation, and joomla will create one for you. ;D

luisB
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Aug 22, 2007 5:58 pm

Re: Error: The XML response that was returned from the server cannot be processed

Post by luisB » Wed Aug 29, 2007 3:24 pm

luisB wrote: :o Pleaseeee.... Help.
Every time I try to install joomla 1.5  in the root directory of my site using the installation wizard.  The following error is generated at the FTP configuration    when click in the Autofind FTP path  or Verify FTP Settings Bottons.

"Error: The XML response that was returned from the server cannot be processed"

If I just skip to the next step,  I got the same error.

Please tell me what should I do.

In the FTP user ID:  I'm entering the correct ID
I'm also typing the correct password.
in the FTP Root Path the following info is entered: public_html

please help.
Thank all of you for the quick respose.  Thank you again to Mr. djhunlimited for the info.  As DJ said you get the error when the configuration.php.dist gets renamed to configuration.php which I did.  Just ignore the configuration.php-dist not readable and click next.  I was able to install joomla and it is working fine now. Joomla does creates a configuration.php file when the installation finishes.  Once again thank you all for you help.

Umesh.Shastry
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jul 30, 2007 4:42 pm

Re: Error: The XML response that was returned from the server cannot be processe

Post by Umesh.Shastry » Thu Aug 30, 2007 3:53 pm

Hi,

It seems you have changed the prefix for table names, by default joomla assumes that it is 'jos_'.
Change the prefix in the sample_data.sql file (should be in /joomla/installation/sql/mysql/).


Thanks,
Umesh

SusieSA
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Aug 30, 2007 5:07 pm

Re: Error: The XML response that was returned from the server cannot be processe

Post by SusieSA » Thu Aug 30, 2007 7:32 pm

Hi Everybody

I was having the same problem and, by using the simplest help above, I seem to have got it working. 

I had previously renamed configuration.php-dist to configuration.php in order the sort out the file not writeable warning that I got earlier on in the process.  So I undid this and left it named with the -dist ending. 

Also, I made sure that the prefix for the table names was jos as the default was.  I had previously changed this.

I kept the advanced settings in the FTP Configuration step as default. 

And then it worked.  I hope this helps somebody...

ramblinfox
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Sep 05, 2007 9:46 pm

Re: Error: The XML response that was returned from the server cannot be processed

Post by ramblinfox » Sun Sep 16, 2007 6:07 pm

I'm doing a clean installed of 1.5... I've never used Joomla! before.  I did not rename the configuration.php-dist fiel, because there wasn't a file for me to rename.... Nor did I change the table name for jos_, I accepted the default....

Please help, or give me the name of another CMS that may be easier to install and get running...  I've been trying to get this installed and running for weeks, still no luck... I've deleted the DB and all of the Joomla! files several times, in an attempt to start over.  I promised my organization that I would have had this up by Labor day.....  I missed that target....

Any guidance would be greatly appreciated.....

User avatar
circumpunct
Joomla! Intern
Joomla! Intern
Posts: 97
Joined: Mon Aug 27, 2007 7:30 am
Location: 54°58'47.86"N 2°15'49.28"W

Re: Error: The XML response that was returned from the server cannot be processed

Post by circumpunct » Tue Sep 18, 2007 11:06 am

Yes, I've got the same problem with the latest nightly build.

Did not really try to find the cause as yet, BUT

1) This hosted on a shared server with no shell access.

2) Between builds I "nuke from orbit" (delete ALL files. Delete msql db and recreate) so it's totally clean.

3) Nothing has changed on the server.

4) No, I havn't missed any hidden files.

5) I've installed all previous builds without any issues. Has installed faultlessly every time. First time I've seen this. Looks like a new bug.

Hmm!! I know it's not a release copy, but it's frustrating when things seem to get worse rather than better - now I just know I'm going to get flamed for that :)
Circumpunct
(Still a few of us Brianists around.)

User avatar
circumpunct
Joomla! Intern
Joomla! Intern
Posts: 97
Joined: Mon Aug 27, 2007 7:30 am
Location: 54°58'47.86"N 2°15'49.28"W

Re: Error: The XML response that was returned from the server cannot be processed

Post by circumpunct » Tue Sep 18, 2007 12:24 pm

Ok, have nuked from orbit again and installed an earlier build.

No problems.

Pretty confident it's a bug in the current build.
Circumpunct
(Still a few of us Brianists around.)

User avatar
circumpunct
Joomla! Intern
Joomla! Intern
Posts: 97
Joined: Mon Aug 27, 2007 7:30 am
Location: 54°58'47.86"N 2°15'49.28"W

Re: Error: The XML response that was returned from the server cannot be processed

Post by circumpunct » Tue Sep 18, 2007 1:00 pm

ramblinfox wrote: Please help, or give me the name of another CMS that may be easier to install and get running... 
You may want to have a look at Joomla ver 1.0. It's pretty stable, well-documented, and there are lots of plug-ins and templates.

I know 1.5 is a lot 'sexier', but to be quite honest it's not really finished. I'm not using it for production sites yet - just playing around with it.

I think it's going to be great, but it's got a way to go yet.
Circumpunct
(Still a few of us Brianists around.)

VinylJunky
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue Oct 02, 2007 9:18 am

Re: Error: The XML response that was returned from the server cannot be processe

Post by VinylJunky » Tue Oct 02, 2007 10:11 am

SusieSA wrote: Hi Everybody

I was having the same problem and, by using the simplest help above, I seem to have got it working. 

I had previously renamed configuration.php-dist to configuration.php in order the sort out the file not writeable warning that I got earlier on in the process.  So I undid this and left it named with the -dist ending. 

Also, I made sure that the prefix for the table names was jos as the default was.  I had previously changed this.

I kept the advanced settings in the FTP Configuration step as default. 

And then it worked.  I hope this helps somebody...
Not renaming the configuration.php.dist worked for me  ;D

Thanks

VinylJunky

huggyb
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Oct 01, 2007 2:59 pm

Re: Error: The XML response that was returned from the server cannot be processe

Post by huggyb » Tue Oct 02, 2007 10:41 am

Ah, yes, that must have been what fixed it for me too. I 'forgot' to rename the configuration file and just carried on and it worked correctly.

Does this mean that if configuration.php is present the variables are loaded from this and they over-rule the ones in the form, hence giving the error?

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Error: The XML response that was returned from the server cannot be processe

Post by humvee » Thu Oct 04, 2007 2:14 pm

configuration.php-dist is there as a back-up only and in the normal course of events should not be needed to be touched.

If for whatever reason when you start the installation there are errors in the Pre-installation check it is likely that the automatic creation of the configuration.php by the Web Browser Installation process will not take place.

When you get to Step 7 - Finish of the installation process there should be a list of variables that are actually the contents of the configuration.php file. You have two choices the first of which is the recommended route:

1. create a new file and do a straight forward copy and paste of the displayed list of the variables from the Step 7 Browser display and save these as configuration.php in the root directory of your Joomla! installation.
2. manually edit all the variables within the configuration.php-dist file so they match exactly the variables displayed on the Step 7 Browser display, then save as configuration.php in the root directory of your Joomla! installation.

Note it does not matter if you changed the prefix of the database during Step 4 - Database Installation just make sure that the entry you make within the configuration.php is exactly the same otherwise it will break the connection to the database tables which now have the prefix assigned to them. This should always have the "_" underscore following the letters/numbers you choose as the prefix for the database tables, otherwise it could make for problems at a later time.

hth

Andy

morton
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Jan 19, 2007 7:04 pm

Re: Error: The XML response that was returned from the server cannot be processed

Post by morton » Sat Oct 06, 2007 9:55 pm

OK I got this same error, but was able  to work around it. I was installing version 1.5RC3 and using the Web Install page. I first changed the name of configuration.php-dist to just php and attempted the install by changing the permission on the file to make it writeable. Bad idea after getting the error and reading some of these post. I then went back and deleted the renamed it back and change the permissions back. Then again ran the web install. Same error when imputing the FTP information. I then stopped the installation and reopened the browser to the web install, this time skipping the ftp information. Completed the install, created the configuration.php file from the data and uploaded it. Deleted the installation folder, which by the way you must do or it will think it is not installed. Joomla ran just fine until I attempted to change the configuration.php file with the admin. Could not do it even by changing the file permissions to writeable. Went back into my offline editor and added the ftp information to the configuration.php file manually and uploaded. Wha La!! Everything works like a charm. I can now edit and change my Global configurations without having the configuration.php writeable and it will save an/or apply just fine.

Here is what I think is going on (remember I'm not a programmer) is that the Web Install page is the one which is having trouble interperting the data being sent back and forth to the ftp server and not Joomla. So if you skip that section of the Web Install and just enter the data (provided the ftp information is correct) to the configuration.php when you create it after the installation everything will work just great. Here is what I was installing on. I am on a shared webserver and created a subdomain with my on ftp user name and password (that is not my primary system ftp username and password). I do have WebShell, but not a direct command line to the server.
Hope this helps some of you who are frustrated with the new version install, but hang in there it will install and looks great so far.
Cheers,
Morton

cpetrauskas
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Dec 27, 2006 12:06 am

Re: Error: The XML response that was returned from the server cannot be processe

Post by cpetrauskas » Tue Oct 09, 2007 11:14 pm

Hello,

My successful workaround to this bug (it is a bug, right?) was of the "ignore the auto-writing configuration.php" variety.

My environment:

Rackspace LAMP box
RedHat ES4
php 5.2.0
mySQL 4.1.2

When attempting a fresh install:

When using the automated installer I get errors at the FTP config and loading sample data stage. It is the same in both cases: "The XML response that was returned..."

If I blow those off I can get a successful (but sample-date free) install.

Long story short:

I was allowing the installer to write it's own configuration.php and that seemed to trigger this failure. (Yes, I had proper write permissions set on the config file.)

When ever I switched tactics to bypasssing the self-writing config file and then pasting and uploading the results from the final page, I had no problem.

Anyhoo, them's the $.02 that made it work for me.

Chris

morton
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Jan 19, 2007 7:04 pm

Re: Error: The XML response that was returned from the server cannot be processed

Post by morton » Wed Oct 10, 2007 7:43 pm

Chris: Did you try to change your Global Configurations. I believe you will find that the Configuration.php file is not writeable even if you change the file permissions. This is what the ftp is doing now I think. At least that is what happend to my install. It was not until I manually edited the Configuration file with my ftp information and uploaded it was I then able to change my configurations within Joomla Administration.

Cheers,
Morton
Last edited by morton on Wed Oct 10, 2007 7:45 pm, edited 1 time in total.

cpetrauskas
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Dec 27, 2006 12:06 am

Re: Error: The XML response that was returned from the server cannot be processe

Post by cpetrauskas » Wed Oct 10, 2007 11:42 pm

Morton,

Do you mean after I manually created the configuration.php file at the end of install?

After installing that way I *am* able to use the Joomla admin to apply changes to that file. I don't have my Joomla FTP user sorted yet so I'm sure that, in my case, it's not updating that way.

Thanks,
Chris

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Error: The XML response that was returned from the server cannot be processe

Post by humvee » Thu Oct 11, 2007 9:56 am

Web Browser installation will fail if you put a configuration.php file into the joomla_root directory before you start the process.

Please follow the steps in the Installation Manual. You can skip the FTP Step altogether and amend this in Global Configuration after the installation is complete if it is required.

FTP Layer is not required on Localhost installations (i.e. on your own machine at home etc)

hth

Andy

Ankabout
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 143
Joined: Wed Mar 15, 2006 12:05 pm
Contact:

Re: Error: The XML response that was returned from the server cannot be processe

Post by Ankabout » Sat Nov 03, 2007 4:24 pm

I had the same problem, but deleting the configuration.php file helped.

Maybe it's a good idea to change the message you get during install. Instead of making it an error, put a small message that says "If this is the first time you are installing Joomla! on this server, this can be 'no'" or something. I was confused when it said configuration.php is not writable...
Last edited by Ankabout on Sat Nov 03, 2007 4:47 pm, edited 1 time in total.

User avatar
ripplegraphics
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Sun Jan 13, 2008 1:33 am

Re: Error: The XML response that was returned from the server cannot be processe

Post by ripplegraphics » Mon Jan 14, 2008 9:00 am

Hey all if you haven't figured this one out already, all you have to do is to leave your configuration.php.dist named as is, and install like you normaly do.  In Joomla 1.0 you used to have to change the name of it, but Joomla 1.5 will error out with the XML Error.  So when you get the error that your configuration.php.dist is non writable on the install screen just continue with your installation, and joomla will create one for you.
WOW...as the newest newbie of all, the response from djhunlimited just neeeds to be in red for all of us having this problem!! I searched through A LOT of posts to finally find this oh-so-very simple-quick-and-easy solution.

;D Thanks djhunlimited!


Locked

Return to “Installation 1.5”