TinyMCE and joomla template styles in the WYSIWYG editor style formats

Discuss the development and implementation of Joomla! 1.0.x templates here.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Locked
User avatar
hbmarar
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Mon Oct 10, 2005 7:09 am
Location: Payyannur, Kannur, Kerala,India
Contact:

TinyMCE and joomla template styles in the WYSIWYG editor style formats

Post by hbmarar » Fri Nov 23, 2007 9:40 am

Hi,


        I do think that the styles need to be available in the editor styles format drop down. But in my backend editor, i do not find it so... How can i get it in the editor so that i could apply styles to the content.

Regards

harish
Technology to Solutions ( Skype : holy.geek_saffrongeek )
Given enough eyeballs , All bugs are shallow.
Collecting data is only the first step toward wisdom. But sharing data is the first step toward community

User avatar
hbmarar
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Mon Oct 10, 2005 7:09 am
Location: Payyannur, Kannur, Kerala,India
Contact:

Re: TinyMCE and joomla template styles in the WYSIWYG editor style formats

Post by hbmarar » Mon Nov 26, 2007 5:32 am

Hi,


  I tried my best to make our what exactly is the reason for this trouble... I tried to hard code the style path and this bloech the editor to load any of the editor tool set... only text area appears even though the javascript seems to load and initialize...

  I do not know why this is not taking the style... I also tried to give path to rhuk_solarflare_ii css but same is the result..

  I am stuck here and this is no way a editor could compromise with since he / she would need to appy the style and formatting to the content...

Thanks in advance for the pointer and request for the same..

Happy week ahead wishes!

Hari
Technology to Solutions ( Skype : holy.geek_saffrongeek )
Given enough eyeballs , All bugs are shallow.
Collecting data is only the first step toward wisdom. But sharing data is the first step toward community

User avatar
hbmarar
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Mon Oct 10, 2005 7:09 am
Location: Payyannur, Kannur, Kerala,India
Contact:

Re: TinyMCE and joomla template styles in the WYSIWYG editor style formats

Post by hbmarar » Mon Nov 26, 2007 9:23 am

I dont know... i tried to get the JCE but even it got the same problem... I just need this badly and dont know where to start from...
Hope some experts here comments and i get some pointers , tips or suggestions.

thanks again!
Technology to Solutions ( Skype : holy.geek_saffrongeek )
Given enough eyeballs , All bugs are shallow.
Collecting data is only the first step toward wisdom. But sharing data is the first step toward community

greatwitenorth
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Nov 14, 2007 5:50 am

Re: TinyMCE and joomla template styles in the WYSIWYG editor style formats

Post by greatwitenorth » Wed Nov 28, 2007 6:47 am

With TinyMCE you can make a file called editor.css and put this in your default template css folder. For example if your using rhuk_solarflare_ii it would look like this:

templates>rhuk_solarflare_ii>css>editor.css

TinyMCE will look for this file by default and load it. Make sure the setting 'Template CSS classes' is set to yes under:

mambots>site mambots>TinyMCE WYSIWYG Editor

To get the styles working I beleive you have to code it in your template (at least that's the only way I got it to work). So you  would add a line like this to your template index.php file in the header:

template ?>/css/editor.css" type="text/css" />

OK hope this helps.

Nick

User avatar
hbmarar
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Mon Oct 10, 2005 7:09 am
Location: Payyannur, Kannur, Kerala,India
Contact:

Re: TinyMCE and joomla template styles in the WYSIWYG editor style formats

Post by hbmarar » Wed Nov 28, 2007 6:50 am

Hi greatwitenorth,

                Thanks for the reply. I tried all, but of no use. in the templates , I got the style working and all fine but to the content , i need to apply and for that i do not why the mentioned is not taking. I did as u mentioned ..but nopes.. editor seems least bothered :(

Regards,

Hari
Technology to Solutions ( Skype : holy.geek_saffrongeek )
Given enough eyeballs , All bugs are shallow.
Collecting data is only the first step toward wisdom. But sharing data is the first step toward community


Locked

Return to “Templates & CSS - 1.0.x”