Strange Errors involving index.php after clean Joomla install

Joomla version 1.0 is end-of-life and are no longer supported. Please use Joomla 3.x instead.
Locked
jbarnes
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Nov 09, 2005 9:19 pm

Strange Errors involving index.php after clean Joomla install

Post by jbarnes » Sat Mar 25, 2006 9:49 pm

Ok.  First, I installed 1.0.8.  The website is http://snellvillepd.com  I completed the web browser installation and received a success message.  I first forgot to delete the install directory and got the "Install_Warn" message.  I went back and deleted the installation directory expecting everything to run great and then got the following:

Warning: main(language/english.php): failed to open stream: Permission denied in /home/snellvil/public_html/index.php on line 135

Warning: main(): Failed opening 'language/english.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/snellvil/public_html/index.php on line 135

Warning: Cannot modify header information - headers already sent by (output started at /home/snellvil/public_html/index.php:135) in /home/snellvil/public_html/index.php on line 224

Warning: Cannot modify header information - headers already sent by (output started at /home/snellvil/public_html/index.php:135) in /home/snellvil/public_html/index.php on line 225

Warning: Cannot modify header information - headers already sent by (output started at /home/snellvil/public_html/index.php:135) in /home/snellvil/public_html/index.php on line 226

Warning: Cannot modify header information - headers already sent by (output started at /home/snellvil/public_html/index.php:135) in /home/snellvil/public_html/index.php on line 227

Warning: Cannot modify header information - headers already sent by (output started at /home/snellvil/public_html/index.php:135) in /home/snellvil/public_html/index.php on line 228
_TEMPLATE_WARNrhuk_solarflare_ii



Since then, I went back and installed 1.0.7 thinking that might fix my problem.  No luck.  I get the same message. 

jbarnes
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Nov 09, 2005 9:19 pm

Re: Strange Errors involving index.php after clean Joomla install

Post by jbarnes » Sat Mar 25, 2006 10:02 pm

Nevermind.  It was a problem with directory permissions.  Problem solved.

SHIELD
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Aug 16, 2006 6:47 pm

Re: Strange Errors involving index.php after clean Joomla install

Post by SHIELD » Wed Aug 16, 2006 7:07 pm

I've run into the same problem.  Any thoughts on what permissions you would have changed to correct this (folders and what settings)?

My gut reaction was that it had to deal with permissions as well.

SHIELD
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Aug 16, 2006 6:47 pm

Re: Strange Errors involving index.php after clean Joomla install

Post by SHIELD » Thu Aug 17, 2006 4:39 am

I have adjusted many folders to have "777" access, and this seems to have fixed my installation.  Is this a bad thing?  Does it leave my site vulnerable?


Locked

Return to “Installation - 1.0.x”