Error in using search engine friendly url

Moderator: joomlalearn

mohsen791
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Aug 15, 2008 7:39 am
Contact:

Error in using search engine friendly url

Post by mohsen791 » Sun Sep 28, 2008 7:50 pm

Hi, when I use joomla on my local host I can use search engine friendly url ( set it in global configuration ), but when I try to active this option on my host, it give me a 404 error. Can anybody help me?

سلام. وقتی من جوملا را بر روی لوکال نصب می کنم می توانم از قابلیت لینکهای کوتاه استفاده کنم( Search Engine friendly Url ) اما وقتی آن را روی هاستم نصب می کنم ایراد 404 می گیرد. آیا می توانید من را کمک کنید؟

User avatar
davetanguay
Joomla! Hero
Joomla! Hero
Posts: 2511
Joined: Fri Sep 22, 2006 6:21 pm
Location: Orlando, FL
Contact:

Re: Error in using search engine friendly url

Post by davetanguay » Mon Sep 29, 2008 3:21 am

Turn on "Use Apache mod_rewrite" within the Joomla Global Config. Then rename the htaccess.txt file in your web directory to .htaccess
CPanel Web Hosting Services http://interactiveonline.com/shared-web-hosting
Follow us on Twitter @interactiveo

sharzeh
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Mon Feb 11, 2008 11:23 am

Re: Error in using search engine friendly url

Post by sharzeh » Fri Oct 03, 2008 6:38 am

davetanguay wrote:Turn on "Use Apache mod_rewrite" within the Joomla Global Config. Then rename the htaccess.txt file in your web directory to .htaccess
Problem Description:
Hi,
I have a similar problem. To tell you briefly the history: I have installed the sh404SEF component, and it started working fine... but after a while I started seeing more and more not found urls and finally I got my web pages layout disordered having normally the mainmenu in up-right of the pages put then down after all page contents...

Trying to open the mainmenu in the back-end I get the below error.

Are these two linked together? Have I omitted doing something to deserve this punitive feedback of my Joomla? What is the cause and what is the remedy?


Log/Error Message:
[quote]Fatal error: Out of memory (allocated 13631488) (tried to allocate 7680 bytes) in /home/sharzeh/public_html/administrator/includes/menubar.html.php on line 160[/quote]
Actions Taken To Resolve:

I don\'t see \"Use Apache mod_rewrite\" within the Joomla Global Configurations... could you be more precise or may it be due to Joomla version (mine is: Joomla! 1.0.13).

For information:
-memory_limit is 128M
-post_max_size is 8M
-upload_max_filesize is 4M

Thank you in advance for your help...

Diagnostic Information
Joomla! Version: Joomla! 1.0.13 Stable [ Sunglow ] 21 July 2007 16:00 UTC
configuration.php: Writable (Mode: 644 ) | RG_EMULATION: Disabled
Architecture/Platform: Linux 2.6.18-92.1.1.el5.028stab057.2 ( x86_64) | Web Server: Apache ( 020.ir ) | PHP Version: 5.2.5
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Not Writable[color] | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 5.0.51a-community ( Localhost via UNIX socket )

sharzeh
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Mon Feb 11, 2008 11:23 am

Re: Error in using search engine friendly url

Post by sharzeh » Fri Oct 03, 2008 7:19 am

By the way the concerned site is : http://020.ir

laplatakid
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Nov 19, 2006 8:53 pm
Location: Northwest Florida
Contact:

Re: Error in using search engine friendly url

Post by laplatakid » Sat Oct 18, 2008 4:31 pm

Did you resolve this issue? I've had the same problem In Joomla 1.5 but was able to resolve it by turning on apache mod_rewrite parameter in the global configuration / site dialog. Not sure if this is available in Joomla 1.0.x.

In any case, I strongly recommend that you upgrade to the current version of Joomla (1.5.7 now, I think). This can be quite an effort, especially if you have a lot of content and / or users.

Anyway, good luck!
Technology Lighthouse, Inc.
http://techlighthouse.com

webone
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Sep 23, 2008 5:16 am

Re: Error in using search engine friendly url

Post by webone » Sun Nov 09, 2008 12:52 pm

Thanks davetanguay. I stumbled across your post and it worked perfectly.

zeesheonline
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Sat Jun 06, 2009 8:28 pm
Location: Islamabad, Pakistan
Contact:

Re: Error in using search engine friendly url

Post by zeesheonline » Sun Jun 07, 2009 12:36 pm

Hi

Even i have installed the component for Search Engine Friendly URL but its still not working its open the link but template don't work except for main page.

www.zeesheonline.net

Plz Help

Regards

Hilfiger
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Jun 14, 2009 12:07 am
Contact:

Re: Error in using search engine friendly url

Post by Hilfiger » Sun Jun 14, 2009 12:17 am

davetanguay wrote:Turn on "Use Apache mod_rewrite" within the Joomla Global Config. Then rename the htaccess.txt file in your web directory to .htaccess
As i use as host ur servers, had same problem as the guy above.

Ur solution worked just fine. thx

Hilfiger
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Jun 14, 2009 12:07 am
Contact:

Re: Error in using search engine friendly url

Post by Hilfiger » Sun Jun 14, 2009 12:17 am

zeesheonline wrote:Hi

Even i have installed the component for Search Engine Friendly URL but its still not working its open the link but template don't work except for main page.

http://www.zeesheonline.net

Plz Help

Regards
davetanguay wrote:Turn on "Use Apache mod_rewrite" within the Joomla Global Config. Then rename the htaccess.txt file in your web directory to .htaccess
do as it says there, and will be ok

zeesheonline
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Sat Jun 06, 2009 8:28 pm
Location: Islamabad, Pakistan
Contact:

Re: Error in using search engine friendly url

Post by zeesheonline » Sun Jun 14, 2009 12:11 pm

Wow its working now really thanks

its greattttttttt

;)

swangler
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue Jul 14, 2009 9:28 pm

Re: Error in using search engine friendly url

Post by swangler » Fri Jul 31, 2009 2:41 am

I have done all that you say in this thread and only the main page works. I am running apache 2.2 on solaris 10 x86. My httpd.conf looks like this:


#
# Dynamic Shared Object (DSO) Support
#
# To be able to use the functionality of a module which was built as a DSO you
# have to place corresponding `LoadModule' lines within the appropriate
# (32-bit or 64-bit module) /etc/opt/webstack/apache2/2.2/conf.d/modules-*.load
file so that
# the directives contained in it are actually available _before_ they are used.
#
<IfDefine 64bit>
Include /etc/opt/webstack/apache2/2.2/conf.d/modules-64.load
</IfDefine>
<IfDefine !64bit>
Include /etc/opt/webstack/apache2/2.2/conf.d/modules-32.load
</IfDefine>

My /etc/opt/webstack/apache2/2.2/conf.d/modules-32.load file looks like this:
LoadModule actions_module libexec/mod_actions.so
LoadModule speling_module libexec/mod_speling.so
LoadModule userdir_module libexec/mod_userdir.so
LoadModule alias_module libexec/mod_alias.so
LoadModule rewrite_module libexec/mod_rewrite.so

I have renamed the htaccess.txt to .htaccess also. I am stuck....

pradyumn
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Sep 25, 2009 11:55 am

Re: Error in using search engine friendly url

Post by pradyumn » Fri Sep 25, 2009 12:10 pm

Hi i am facing problem in joomla

search engine friendly url option is on in admin.
index.php/groups/viewgroup/9-Testing

when i am trying to get id (with $_GET[])it is giving me 9:testing

Kindly give me appropiate solution.

Optimizers
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Dec 01, 2009 12:27 am
Contact:

Re: Error in using search engine friendly url

Post by Optimizers » Tue Dec 01, 2009 12:40 am

This worked for me, did have a little trouble untill I stumbled across this post.

#mod_rewrite ON (in apache config)

# .htaccess file in root

# sef url's & mod rewrite in joomla config panel

Regards

unmann
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jul 12, 2006 10:38 am

Re: Error in using search engine friendly url

Post by unmann » Thu Feb 11, 2010 12:41 pm

Thanks davetanguay - That did the trick!

User avatar
jjspelman
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 187
Joined: Tue Apr 07, 2009 6:27 am
Location: Tampa, FL
Contact:

Re: Error in using search engine friendly url

Post by jjspelman » Thu Apr 08, 2010 4:00 am

Thanks @davetanguay, outstanding because it worked for me!!!

User avatar
dharmony
Joomla! Intern
Joomla! Intern
Posts: 53
Joined: Tue May 29, 2007 12:24 pm

Re: Error in using search engine friendly url

Post by dharmony » Fri May 21, 2010 1:50 pm

I've read all the other post and followed directions.

I turned on Apache mod_rewrite and changed the file name. Now I receive an error stating 500 Internal Server Error

dark_passages
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat May 22, 2010 11:23 am
Location: The Hague
Contact:

Re: Error in using search engine friendly url

Post by dark_passages » Sat May 22, 2010 11:30 am

I had the same problem.

For some reason it does not work when I have the Joomla website stored in a subfolder.
(www.mysite.com/joomla/index.php)

I moved the website to the root folder of my domain and now it works perfect.
(www.mysite.com/index.php)

Looks like the SEF code in Joomla does not handle the subfolder propperly?

SUPERSEALWEB
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Jun 03, 2010 3:27 pm

Re: Error in using search engine friendly url

Post by SUPERSEALWEB » Thu Jun 03, 2010 3:38 pm

I am starting with a fresh install of Joomla 1.57 with the sample content added however the search engine friendly URL's are still not working. I have done the following.

changed the htaccess.txt file to htaccess.htaccess
turned on both the Search Engine Friendly URLs and Apache mod_rewrite

www.walldrainage.com

When i go to any of the default articles installed i am getting- page not found

The home page is fine but any article is not... is there something i have missed or do not know?

dark_passages
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat May 22, 2010 11:23 am
Location: The Hague
Contact:

Re: Error in using search engine friendly url

Post by dark_passages » Sat Jun 05, 2010 8:28 am

SUPERSEALWEB wrote:...changed the htaccess.txt file to htaccess.htaccess
...
To my knowledge the file should be named .htaccess
This is a little tricky, renaming the file to this name is not allowed on all systems.
I created a new file with this name and copied the content.

Hope this helps.

bashmentyard
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jun 07, 2010 8:23 pm

Re: Error in using search engine friendly url

Post by bashmentyard » Tue Jun 08, 2010 4:26 am

this htaccess.txt code below worked for me, just copy and paste, save as htaccess.txt, upload to server, rename to .htaccess, THEN go into global config in Joomla and turn the THREE SEO settings on. hope it provides an option for someone.





##
# @version $Id: htaccess.txt 423 2005-10-09 18:23:50Z stingrey $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

#
# mod_rewrite in use
#

RewriteEngine On

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update YourJoomlaDirectory (just / for root)

RewriteBase /

#
# Rules
#

RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php

astralfire
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat May 23, 2009 1:42 pm

Re: Error in using search engine friendly url

Post by astralfire » Wed Jun 16, 2010 2:21 pm

I already followed the tips on this post and they worked. I started a new website already with this working. No more css problems, no more Internal Server Errors,...

Now for an already existing website I will also need to have the urls search engine friendly.
- my question is if I can do it now that the website is already buit? Just don't want to make something wrong and irreversible... Thanks for a good advice

The website is this one: www.marisqueiraterramar.com

dark_passages
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat May 22, 2010 11:23 am
Location: The Hague
Contact:

Re: Error in using search engine friendly url

Post by dark_passages » Wed Jun 16, 2010 4:08 pm

astralfire wrote:I already followed the tips on this post and they worked. I started a new website already with this working. No more css problems, no more Internal Server Errors,...

Now for an already existing website I will also need to have the urls search engine friendly.
- my question is if I can do it now that the website is already buit? Just don't want to make something wrong and irreversible... Thanks for a good advice

The website is this one: http://www.marisqueiraterramar.com
Yes you can, you can tun it on and off at any time. Does not change the working of the website.

elintxy
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Jul 23, 2010 1:53 am

Re: Error in using search engine friendly url

Post by elintxy » Fri Jul 23, 2010 2:04 am

Based on the post by "dark_passages" on Sat May 22, 2010.

I have the same problem there which i installed my joomla in a subfolder.
(www.mysite.com/joomla/index.php).

Once i ticked the seo urls check-box, my about us page's template is missing except the home page (index.php).

Is this because i installed joomla in subfolder?
Will is be solve after i move to root folder (www.mysite.com/index.php)

TerriKarp
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Aug 27, 2009 5:56 pm

Re: Error in using search engine friendly url

Post by TerriKarp » Wed Jul 28, 2010 2:44 pm

I was getting this on a site I picked up from another developer. I had the parms set correctly in the Global Configuration. There was an .htaccess file in the root and also an htaccess.txt.

In desperation I renamed the existing .htaccess to .htaccess-old and renamed the .txt file (presumably again). This worked.

elintxy
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Jul 23, 2010 1:53 am

Re: Error in using search engine friendly url

Post by elintxy » Thu Jul 29, 2010 2:43 am

For now, your have ".htaccess-old" and ".htaccess", and it worked?

elintxy
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Jul 23, 2010 1:53 am

Re: Error in using search engine friendly url

Post by elintxy » Thu Jul 29, 2010 7:05 am

I use joomla 1.5 for my website. The problem now is when I changed the file name from "htaccess.txt" to ".htaccess", my website template was dissapear except the index.php mean home page, other pages all without the template? May i know what is the mistake?

Kinldy assist, thanks.

TerriKarp
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Aug 27, 2009 5:56 pm

Re: Error in using search engine friendly url

Post by TerriKarp » Thu Jul 29, 2010 3:17 pm

elintxy wrote:For now, your have ".htaccess-old" and ".htaccess", and it worked?
Yes exactly, I have ".htaccess" and ".htaccess-old" in the root, but no longer htaccess.txt and it's now working.

The original .htaccess is almost double the size of what was htaccess.txt. I didn't go through it line-by-line to see what the old developer was thinking, but it was seriously modified. I guess renaming it from the .txt removed the stuff he tried, but got wrong. That would explain things for me, but not for you if your installation is fresh.

(Or the existence of htaccess.txt could also be problematic based on above? That sounds unlikely and I don't want to mess with it now that it's working!)

boggis
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Dec 11, 2007 3:39 am

Re: Error in using search engine friendly url

Post by boggis » Mon Aug 16, 2010 3:50 pm

Has anyone been able to make this work when the site is hosted in a sub folder (i.e. www.mysite.com/joomla/index.php)?

Any page beyond my home page returns a page not found error. So far I've changed htaccess.txt to htaccess and changed "Use Apache mod_rewrite" to "yes"

Thanks for any help!

Zaxxen
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Sun Nov 15, 2009 9:14 pm

Re: Error in using search engine friendly url

Post by Zaxxen » Mon Aug 23, 2010 2:48 pm

Also try adding av "#" infront of:

" Options +FollowSymLinks "

In the htaccess file.. :)

Tips, put the marker just after the "O" and press left arrow key to make sure you are at the same row as the actual code... ;)

boggis
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Dec 11, 2007 3:39 am

Re: Error in using search engine friendly url

Post by boggis » Mon Aug 23, 2010 3:32 pm

I tried adding the "#" but am still getting a a few "link appears to be broken" errors. Can anyone confirm if this is workable for a site based in a subfolder?
Thanks.


Locked

Return to “Persian Forum”