Page 1 of 1

en-IE

Posted: Tue Nov 21, 2017 9:59 pm
by garly01
A bit of a shot in the dark but would anyone know where I might find a language pack for English but for the region Ireland which is en-ie. Joomla only comes with ga-ie installed but that is the Irish Language and not what I need. I'm doing a multi-region site and I want people to be able to choose between Ireland and the UK. The only en-ie I can find online is for joomla 1.5 which I found here https://sourceforge.net/projects/en-ie-irl/files/.

But I can't find one anywhere for joomla 3. Would it take much work to edit the 1.5 en-IE language pack to make it compatible with the current joomla version?

Thanks

Re: en-IE

Posted: Wed Nov 22, 2017 3:17 am
by imanickam
There is no English language pack for Ireland. You could create one from one of the English language packs available. I believe that you are aware that en-GB is native to Joomla!

As for as the en-IE for Joomla, there was never an accredited language pack. The one you are referring to SourceForge may have been created by a user who has not published the language pack in Joomla! (https://community.joomla.org/translatio ... tions.html).

There are several language string changes between Joomla! 1.5 and Joomla! 3.8.x. In fact, the variable names' naming convention has changed. So, unless one could compare the language string values between 1.5 and 3.8, it would be difficult to take the language pack developed in Joomla! 1.5 and improve upon that.

One extension that could be of help would be Localise (https://extensions.joomla.org/extension ... /localise/). This approach could be used if it is a kind of one of exercise.

If you want a long-term approach the I would suggest using the online translation tool named Crowdin (https://crowdin.com/project/joomla-cms). You could get in touch with either Rune or Thomas to include en-IE in Crowdin.

Let us know your thoughts.

Note:
When Joomla! 1.6/1.7 was released, approximately 40% of the language string values were the same.

You could review the post viewtopic.php?p=2614929#p2614929 and make use of the extension com_langconv to convert the existing 1.5 language strings to 1.7. After this is done, you could create a language pack for Joomla! 3.8.x.

Re: en-IE

Posted: Wed Nov 22, 2017 6:37 am
by infograf768
If en-IE should be exactly as en-GB, you can use com_localise
https://github.com/joomla-projects/com_ ... e/releases

Install last Joomla version, then com_localise.
Once you have created both a site and admin en-IE.xml, a simple click will let you create all other files.
Screen Shot 2017-11-22 at 07.35.03.png
Then use the Packages page and copy the last master core 3.8.0, edit and download package.

Re: en-IE

Posted: Wed Nov 22, 2017 12:49 pm
by rvbgnu
I supposed it would be easy to maintain a language pack en-IE on Crowdin. We moved on Crowdin last month and it is much easier and quicker to update and maintain now. Plus hopefully we will get more contributions for the admin pack, that is not completed yet.

@MIG, what will it take for an existing team like us (ga-IE) to get it officially listed?
I am thinking of the same as Australia
https://community.joomla.org/translatio ... html#en-au
Note: This variant of en-GB is provided to help some search engines recognize the site's country (Bing for example). Otherwise, its contents are exactly the same as the default en-GB files.
@garly01, just to make sure, would it be the exact same language strings than en-GB?
Please note it would be very easy to add some variants, and to keep them maintained for each release. So feel free to make suggestions to have the most relevant en-IE package!

Re: en-IE

Posted: Wed Nov 22, 2017 1:23 pm
by imanickam
rvbgnu wrote:@MIG, what will it take for an existing team like us (ga-IE) to get it officially listed?
I mus t admit that I do not understand the question. If you are talking about Irish language, it is already listed in the "Joomla! 3.x Translations" page (https://community.joomla.org/translatio ... html#ga-ie).

If you are referring to the future Irish flavor of English (en-IE) once the installation and the language packs are ready we can list the language pack. It is not an issue at all. As you know, we want to validate the package the first time for any issues and after that the Translation Coordinator can start publishing the language packs in the Accredited Language's Repository.

Hope this answers the question.

Re: en-IE

Posted: Wed Nov 22, 2017 1:37 pm
by rvbgnu
Sorry MIG, it was a bit confusing. I was talking about the Irish flavor of English, but maintain by an existing team: the same maintaining ga-IE. I don't think there is the need to create a specific team for that.

I am contacting Rune on Crowdin to add en-IE, and to make the necessary changes for the package. I will then PM you with the package.

Re: en-IE

Posted: Wed Nov 22, 2017 2:09 pm
by imanickam
Sure, no problem...

Re: en-IE

Posted: Wed Nov 22, 2017 2:34 pm
by rvbgnu
Thanks Ilagnayeru for your always quick and helpful replies ;-)

Re: en-IE

Posted: Sun Nov 26, 2017 9:56 pm
by rvbgnu
Work done on Crowdin now. I will test the files tomorrow, after the nightly "project built".