Page 1 of 1

Problemi con componenti che usano Javascript

Posted: Fri Nov 16, 2012 2:14 pm
by alccad
Ciao, vorrei chiedere il vostro aiuto per un problema che ho un sitarello locale (Joomla 2.5.7), basato sull'ambiente EasyPHP (niente di super... quindi).

Purtroppo quando installo qualche modulo che fa usa di javascript (almeno così mi pare di capire, non sono un programmatore :'( ) ottengo sempre dei messaggi d'errore e non capisco dove sta l'inghippo.

La cosa mi capita per esempio con 2 componenti abbastanza diffusi.

Il primo è Jevents, installato nella versione 2.2.8: è configurato per avere la parte pubblica editabile da tutti e infatti chiunque può aggiungere un evento, ma il problema è che non lo può modificare.
Se accede al dettaglio e preme il tasto "Edit", non succede nulla.
In basso a sinistra nel browser compare la scritta

"Javascript:Void(0)".

E se provo a vedere il dettaglio, ottengo:

Uncaught TypeError: Cannot read property 'style' of null

Che per me è arabo.

Nel secondo caso, il componente SWFree crea egregiamente i moduli, ma non i sottolivelli.
Se provo a cliccare sul menu di primo livello, non succede nulla e anche qui, entrando nel dettaglio dell'errore, ottengo:

Transmenu non definito

(sempre arabo!)

Siccome entrambi mi pare facciano parte di qualcosa di comune, mi chiedo se qualcuno non può aiutarmi indicandomi da che parte girarmi per provare a risolvere il problema!

Grazie in anticipo.

Re: Problemi con componenti che usano Javascript

Posted: Fri Nov 16, 2012 7:42 pm
by alikon
non conosco i componenti che hai menzionato
trattandosi di javascript potrebbe essere un conflitto tra mootools e jquery
no so se per caso caricano entrambi jquery eo mootools
comuque potrebbe dipendere anche dal template