Error 500

Moderators: el_libre, General Support Moderators

Locked
Dracco
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Nov 02, 2005 8:41 am

Error 500

Post by Dracco » Wed Nov 02, 2005 9:09 am

Bon dia.

Tinc quasi acabat un portalet personal (http://www.ladragonera.com) i porto ja una setmana que estic patint errors 500 al afegir contingut. Estic localitzant l'error i he descobert que no depén de comilles simples, dobles, ni caràcters no estàndars. També tinc clar que el fet d'afegir texte al quadre de texte d'introducció tampoc dóna cap problema, però quan afegeixo texte al quadre de texte principal (el que és opcional però que conforma el cos principal de l'article) a vegades em retorna un error 500 i no m'afegeix l'article.

He estat navegant i googlejant molt i hi ha moltes qüestions sobre aquest famós error 500. En la inmensa majoria de casos parla dels permisos dels directoris i dels arxius. En aquests moments tinc tot l'arbre de directoris repassat, deixant els directoris amb drets 755 i els arxius amb 644. A més, he revisat els directoris que a la instalació demana drets d'escriptura i els he posat.

He verificat que la direcció arrel de la site estigui ben escrita i que l'arxiu de configuració sigui correcte.

Segons tots els fòrums que he visitat, el problema té el seu origen als drets i permisos dels arxius. He trobat una web que explica que el PHP, al funcionar com un mòdul de l'apache, aplica una configuració de seguretat que prohibeix la execució de scripts que tinguin dret d'execució, així que en aquests moments no tinc cap arxiu que es pugui executar. També parlen del propietari dels arxius. Això té la seva lògica ja que l'apache accedeix amb l'usuari nobody, però els arxius pujats al servidor via FTP tenen l'usuari de la conta del FTP (és a dir, si entres amb usuari "pepe" via FTP, els arxius que pujis seràn propietat d'aquest usuari "pepe"), així que quan l'apache prova de modificar algun arxiu d'en "pepe" se li denega el permís.

Per evitar això he instalat el MamboXplorer i m'he dedicat a copiar els arxius per modificar el propietari (és a dir, agafes un arxiu/directori, el copies amb un altre nom, borres l'original del usuari "pepe" i renombres el nou al nom original, quedant l'usuari "nobody"). És una tasca feixuga i encara no l'he acabat, però encara no m'ha donat cap resultat satisfactori.

En aquests moments segueixo sense poder afegir massa contingut. No sé si realment és problema de permisos, ja que a vegades si que em deixa afegir contingut (de fet, ara hi han varis articles amb cos principal). He pensat que potser depén de l'editor (Mambot) que utilitzi, però  n'he instalat 4 i segueix donant problemes, inclús amb els d'origen. També he pensat que no sigui algun estil aplicat al texte, com negretes o links, però amb textes sense format tampoc funciona. Per últim estic plantejant-me que l'error 500 sigui causat per un texte massa llarg. No hauria de passar ja que el consum de memòria d'un texte de mitja pantalla no hauria de superar cap límit de memòria al servidor.

Tinc el Joomla allotjat a http://www.intermty.com, recomanat per soportar perfectament sites en Mambo, i de veritat estic content amb el reste (cap problema amb biblioteques gràfiques), però aquest tema em preocupa.

Vaig crear una pàgina d'error 500 per evitar la pantalla d'error típica, però aquesta última tampoc em donava massa informació (ni línia, ni arxiu, ni descripció de l'error).

He descobert que també salta un error 500 quan finalitza la sessió mentre s'està editant un article. Per això també he provat de crear l'article fora de Joomla i enganxar-lo i guardant en menys de 10 segons, però tampoc...

La pregunta, després d'aques super-totxo és:

- Algú ha pogut solucionar aquest tema? Algú sap per on tirar? Què més es pot probar?

Perdoneu la parrafada, però porto ja dues setmanes quasi intensivament amb això però no hi ha forma. Potser aquest no és el lloc correcte per aquest tipus de qüestions. Prego disculpeu-me si he ficat la pota.

Salut!

Xavier Arnaus.

User avatar
blues
Joomla! Explorer
Joomla! Explorer
Posts: 490
Joined: Fri Aug 19, 2005 3:14 pm
Location: Palafrugell (Girona)

Re: Error 500

Post by blues » Wed Nov 02, 2005 11:31 am

Hola Xavier,
Sembla que totes les passes que has fet són les correctes. No tinc ni idea de perque te passa això... Uses la versió Joomla 1.0.3 de Joomla en català???
Josep M.

Dracco
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Nov 02, 2005 8:41 am

Re: Error 500

Post by Dracco » Wed Nov 02, 2005 11:33 am

No, uso la 1.0.2

User avatar
blues
Joomla! Explorer
Joomla! Explorer
Posts: 490
Joined: Fri Aug 19, 2005 3:14 pm
Location: Palafrugell (Girona)

Re: Error 500

Post by blues » Wed Nov 02, 2005 5:23 pm

Doncs no sé... igual no se soluciona el problema però jo te recomanaria primer passar-te la versió 1.0.3 o esperar-te a la versió definitiva 1.1 que durant aquest mes sortiva una versió estable, no obstant, no crec que l'error vingui d'aquí.

A vegades depen de quins servidors els permisos chmod dels directoris són 777 prova-ho si de cas...
Josep M.

Dracco
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Nov 02, 2005 8:41 am

Re: Error 500

Post by Dracco » Thu Nov 03, 2005 9:05 am

Aprofito per registrar els últims canvis i descobriments sobre aquest tema.

Segueixo pensant que alguna cosa extranya hi ha. Amb tothom amb qui he parlat m'asseguren que en principi ho tinc tot bé. De fet, vaig estar fent proves d'afegir articles... i funcionava!

Llavors, quin és el problema? Resulta que em vaig guardar l'article que em donava problemes (n'hi han varis articles que fallen) i ho vaig tornar a provar. Resulta que alguna cosa deu tenir aquest article per provocar la falla d'error 500. He anat enganxant paràgraf a paràgraf fins que he trobat el paràgraf que fèia fallar el sistema. He vist el codi font i no hi ha res d'extrany, però no deixa de ser curiós.

I el més curiós de tot és que a la web d'un company (Mambo 4.5.2 -> Joomla 1.0.2) no li dóna cap problema. Llavors m'he instal.lat el mateix Mambot per editar texte (HTMLArea / TMEdit) però segueix donant-me problemes.

Al final he agafat l'article i he picat de nou el paràgraf que donava problemes.

Si descobreixo alguna cosa més ho afegiré, però si algú té alguna pista, per petita que sigui, li agrairia que fes el mateix.

Merci i Salut!

User avatar
davidbe
Joomla! Explorer
Joomla! Explorer
Posts: 308
Joined: Fri Aug 19, 2005 1:43 pm
Location: Barna City
Contact:

Re: Error 500

Post by davidbe » Thu Nov 03, 2005 9:27 pm

I nomes et falla un paragraf??? has probat a borrarli el format abans de guardar? hi ha un botó als editor que eliminen el format que porta el text. Proba a veure si aixi funciona...pero sona molt raro

Dracco
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Nov 02, 2005 8:41 am

Re: Error 500

Post by Dracco » Fri Nov 04, 2005 8:11 am

El paràgraf en si era un texte pur, amb un parell de links i un tag de subratllat que, al no afectar cap caràcter, s'obria i es tancava. Vaig netejar-lo de tot i també fallava. El problema el donava al principi del paràgraf, com si fallès el
inical... curiós.

Tinc un parell d'articles esperant per ser penjats que també dónen problemes. Quan els provi de penjar us postejo el seguiment. Realment val la pena identificar el problema, ja que si no al escriure una bona parrafada d'article et quedes amb la sensació de que "perquè escriure si petarà".

Salut!

User avatar
blues
Joomla! Explorer
Joomla! Explorer
Posts: 490
Joined: Fri Aug 19, 2005 3:14 pm
Location: Palafrugell (Girona)

Re: Error 500

Post by blues » Fri Nov 04, 2005 4:37 pm

No sé jo sóc més partidari de desactivar tots els editors aquest de joomla/$ambo i usar per exemple el dreamweaver o frontpage i després copiar i enganxar el codi html a joomla i fore problemes... a més de ser més ràpid, generalment més net de codi basura...
Josep M.

Dracco
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Nov 02, 2005 8:41 am

Re: Error 500

Post by Dracco » Fri Nov 04, 2005 4:43 pm

Tens tota la raó, però no li demanis a un usuari que t'obri el dreamweaver i et fabriqui l'article allà per enganxar-ho després al portal  :laugh: Ja saps com és la gent  ;)

User avatar
blues
Joomla! Explorer
Joomla! Explorer
Posts: 490
Joined: Fri Aug 19, 2005 3:14 pm
Location: Palafrugell (Girona)

Re: Error 500

Post by blues » Fri Nov 04, 2005 6:52 pm

jejejje si que ho sé... però per molt fàcil que sigui un editor molt més encara l'editor per exemple frontpage que ja és el summum de fàcil... no sé, de totes formes els editors no tenen perque donar-te el problemes que menciones... Jo te recomanaria la versió en català 1.0.3 ja que l'editor també hi està traduit...

No sé... com a darrera cosa has provat amb diferents navegadors? O dic, ja que hi estàs, posat ho provem tot :) :) :)

També prova el  FCKeditor (Si no ho has fet)
Last edited by blues on Fri Nov 04, 2005 7:04 pm, edited 1 time in total.
Josep M.


Locked

Return to “Temes sobre l'administració”