SMF Fatal Error: How to repair it?

Discuss the integration of SMF here.
Locked
User avatar
InF3RNo
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Jun 14, 2007 6:24 pm

SMF Fatal Error: How to repair it?

Post by InF3RNo » Tue Nov 27, 2007 3:42 pm

Fatal error: Call to undefined function tportal_version() in /home/inf3rnal/public_html/foros/Sources/Load.php(1726) : eval()'d code on line 644

I use Joomla 1.x and SMF 1.1.4. The database of the forum and joomla are different, what can I do to repair this? Thanks!

 
motokochan
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Tue Aug 14, 2007 5:14 pm

Re: SMF Fatal Error: How to repair it?

Post by motokochan » Tue Nov 27, 2007 7:53 pm

It looks like you had TinyPortal installed but either manually removed it, or the removal failed. You either need to clean up the removal, or put up a fresh copy of the SMF files to clean them up. Note that this will remove any mods you installed (you just need to re-install them - you shouldn't lose any data).

I recommend making a backup of the database and files as a precaution.
Motoko-chan
Marketing Agent / Assistant Project Manager
Simple Machines

User avatar
InF3RNo
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Jun 14, 2007 6:24 pm

Re: SMF Fatal Error: How to repair it?

Post by InF3RNo » Tue Nov 27, 2007 8:09 pm

motokochan wrote: It looks like you had TinyPortal installed but either manually removed it, or the removal failed. You either need to clean up the removal, or put up a fresh copy of the SMF files to clean them up. Note that this will remove any mods you installed (you just need to re-install them - you shouldn't lose any data).

I recommend making a backup of the database and files as a precaution.
Ok, I'll reinstall SMF. Thanks for the help.

User avatar
InF3RNo
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Jun 14, 2007 6:24 pm

Re: SMF Fatal Error: How to repair it?

Post by InF3RNo » Wed Nov 28, 2007 2:43 pm

I did what you said but nothing, the same error, all I do is insert spanish translation to forum and a template, but that doesn't touch anything, no idea why this happen...

Fatal error: Call to undefined function tportal_version() in /home/inf3rnal/public_html/foros/Sources/Load.php(1726) : eval()'d code on line 644

(This time the double-post was necesary or nobody could know if I already tried again)

Edit: Oh, I got it it's the theme, but how can it fail? It's ApolloTB theme and it was the nicer one that I found, what can be the error, should I reinstall the template?

ReEdit: Well, I already solved the problem, seams I installed ApolloTB and that was for tinyportal, and wasn't 100% compatible for the SMF Forum without Tiny Portal. So I got ApolloBB and works perfectly.

Thanks for the help anyways!
Last edited by InF3RNo on Wed Nov 28, 2007 3:20 pm, edited 1 time in total.

User avatar
chiko
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sun Dec 09, 2007 6:00 am

Re: SMF Fatal Error: How to repair it?

Post by chiko » Sat Jun 07, 2008 9:44 am

hi guys think I just did the same thing here. I installed and applied the yp template before the yap portal and now my website is reaturning this error:

Fatal error: Call to undefined function template_menu() in /home/octopa/public_html/bod/Sources/Load.php(1726) : eval()'d code on line 184

I think I only need to change the forum's template to maybe the default at the backend. Which file do I edit if that is the solution?

Thank you ;)

 

Locked

Return to “SMF - Simplemachines.org Forum”