SMF Bridge Install issues in Mambo/Joomla - Step 2 errors

Discuss the integration of SMF here.
Locked
pinaygeek
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Sep 19, 2005 10:51 am

SMF Bridge Install issues in Mambo/Joomla - Step 2 errors

Post by pinaygeek » Mon Sep 19, 2005 11:12 am

I have managed to install the SMF package (step 1 on SMF 1.0.5, ) but I am unable to get through Step 2. I am still trying to install the component via uploading the com_smf.zip file or via install from directory. Both ways, I still get errors:

When installing via upload of the zip file I get:
Warning: chmod(): Operation not permitted in /home/geek/public_html/mambo/administrator/includes/installer_common.php on line 289
Upload new component - error
Could not copy administrator files

When installing via the directory (../administrator/components/com_smf), I get the error:
Failed with error Could not copy administrator files

I have traversed the whole directory and made sure that even the administrator directory has 0777 file permission.

Am I missing something?
Btw, my installation/server info are:
PHP built On: Linux  2.4.21-32.0.1.EL #1 Wed May 25 14:36:20 EDT 2005 i686
Database Version: 4.0.24-standard 
PHP Version: 4.3.11
Web Server: Apache/1.3.33 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.3.11 FrontPage/5.0.2.2635 mod_ssl/2.8.22 OpenSSL/0.9.7a
WebServer to PHP interface: apache
Mambo Open Source Version: 4.5 Stable-1.0.9 [Spider] 28/06/2004 16:51 GMT
User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Relevent PHP Settings: Safe Mode: OFF
Open basedir: none
Display Errors: ON
Short Open Tags: ON
File Uploads: ON
Magic Quotes: ON
Register Globals: ON
Output Buffering: OFF
Session save path: /tmp
Session auto start: 0
XML enabled: Yes
Zlib enabled: Yes
Disabled Functions: none
WYSIWYG Editor: htmlarea2

Btw, I am trying to install MOS_SMF_BRIDGEv3.19a_stable which is supposedly the compatible bridge for SMF 1.0.5 and Mambo 4.5.1

Any ideas?

yellow
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Sat Sep 17, 2005 9:46 am

Re: SMF Bridge Install issues in Mambo/Joomla - Step 2 errors

Post by yellow » Mon Sep 19, 2005 12:35 pm

Im not really sure, but you may want to check the component folder also.

pinaygeek
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Sep 19, 2005 10:51 am

Re: SMF Bridge Install issues in Mambo/Joomla - Step 2 errors

Post by pinaygeek » Tue Sep 20, 2005 12:36 am

../administrator/components folder and ../administrator/includes directory has 0777 permissions set already. i still have the error.  :'(

Orstio
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 162
Joined: Thu Aug 18, 2005 2:10 am
Location: Canada
Contact:

Re: SMF Bridge Install issues in Mambo/Joomla - Step 2 errors

Post by Orstio » Tue Sep 20, 2005 12:49 am

../administrator/components/com_smf

This directory must not exist before installation of the component.
"Freedom is not merely the opportunity to do as one pleases; neither is it merely the opportunity to choose between set alternatives. Freedom is, first of all, the chance to formulate the available choices, to argue over them -- and then, the opportunity to choose." - C. Wright Mills

pinaygeek
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Sep 19, 2005 10:51 am

Re: SMF Bridge Install issues in Mambo/Joomla - Step 2 errors

Post by pinaygeek » Tue Sep 20, 2005 3:50 am

figured that one out earlier. thanks for confirming orstio  ;D

now my problem is:
Failed with error SQL Error DB function failed with error number 1064You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \' while installing the package. looked at the url address and it seems that what it is doing is:
INSERT INTO mos_menu (menutype,name,link,type,published,parent,componentid,sublevel,
ordering,checked_out,checked_out_time,pollid,browserNav,access,utaccess) VALUES
("mainmenu", "Forum", "index.php?option=com_smf", "components", 1, 0, 19, 0, 8, 0,
"0000-00-00 00:00:00", 0, 0, 0, 3)



i'm stumped...  :(  :-\
Last edited by pinaygeek on Tue Sep 20, 2005 3:52 am, edited 1 time in total.

yellow
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Sat Sep 17, 2005 9:46 am

Re: SMF Bridge Install issues in Mambo/Joomla - Step 2 errors

Post by yellow » Tue Sep 20, 2005 7:24 pm

Im not sure, but if you install joomla! from fresh (not migrate from mambo), ur database prefix should be jos:
INSERT INTO jos_menu

Orstio
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 162
Joined: Thu Aug 18, 2005 2:10 am
Location: Canada
Contact:

Re: SMF Bridge Install issues in Mambo/Joomla - Step 2 errors

Post by Orstio » Tue Sep 20, 2005 7:32 pm

Failed with error SQL Error DB function failed with error number 1064You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \'
Can you post the complete error, with the line number in which the error is occurring?  You can leave out paths if you feel that is a security issue, but complete errors, filenames and line numbers would be a great help.
"Freedom is not merely the opportunity to do as one pleases; neither is it merely the opportunity to choose between set alternatives. Freedom is, first of all, the chance to formulate the available choices, to argue over them -- and then, the opportunity to choose." - C. Wright Mills

robbievk
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Fri Sep 16, 2005 6:58 am
Location: Texel
Contact:

Re: SMF Bridge Install issues in Mambo/Joomla - Step 2 errors

Post by robbievk » Wed Sep 21, 2005 9:06 am

pinaygeek wrote: ../administrator/components folder and ../administrator/includes directory has 0777 permissions set already. i still have the error.  :'(
When safe mode is off your folder should be set to 0755 and your files to 0644 imo... anyway that works for me...


Locked

Return to “SMF - Simplemachines.org Forum”