Error opening Joomla administartion and site

Moderator: imanickam

Locked
leenark
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Wed Jul 11, 2007 4:56 am

Error opening Joomla administartion and site

Post by leenark » Mon Aug 06, 2007 5:20 am

Hi Guys,

I need help urgently on Joomla. My site is at http://www.content-commons.in... was working till now and suddenly when I try logging into administration screen getting following error: Please help. Do I need to stall Joomla again? what is the error about?
also site is not showing.

I am getting following error:

Warning: main(/includes/version.php) [function.main]: failed to open stream: No such file or directory in /hsphere/local/home/techtren/content-commons.in/includes/joomla.php on line 71

Fatal error: main() [function.require]: Failed opening required '/includes/version.php' (include_path='.:/usr/local/lib/php') in /hsphere/local/home/techtren/content-commons.in/includes/joomla.php on line 71
Last edited by leenark on Thu Aug 09, 2007 7:35 am, edited 1 time in total.

User avatar
romit
Joomla! Explorer
Joomla! Explorer
Posts: 413
Joined: Tue Nov 22, 2005 5:39 pm
Location: Calcutta - India
Contact:

Re: Error opening Joomla administartion and site

Post by romit » Tue Aug 07, 2007 5:22 am

Well if you look at the error carefully,

You will see that it says

Code: Select all

Failed opening required '/includes/version.php
That means that PHP could not find the version.php file inside the /includes directory inside your joomla installation ..

So if you FTP the version.php file to your site .. It should be working again.
Romit Chatterjee
× Joomla! Web Developer - http://www.RomitChat.com
× IndicJoomla! Translation Coordinator - http://www.JoomlaIndia.org/bengali/

leenark
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Wed Jul 11, 2007 4:56 am

Re: Error opening Joomla administartion and site

Post by leenark » Tue Aug 07, 2007 5:39 am

Thanks Vish for your reply,

All those files (includes/vesion.php) are very much there.
While looking at server folders I noticed that file size for configuration.php is (0kb). I have no clue why this would happen, but I guess that is where problem lies.
I had backed up files which I tried to FTP but could not go thr'. Now I have no idea whether I will have to reinstall and rework on site again? OR can I request host's for putting last backup on site and see if it works.
Can somebody help me tell what I can do if configuraion.php has messed up.


Thanks and regards,
Leena

leenark
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Wed Jul 11, 2007 4:56 am

Re: Error opening Joomla administartion and site

Post by leenark » Thu Aug 09, 2007 7:34 am

Hi Guys,

The error problem is solved. Apparently configuration.php file got wiped out. That is what was generating that error.
I replaced backed up Joomla files on server as well as database back up, and it worked.

Thanks for your support,
Leena


Locked

Return to “Indic Languages Forum”