Absolute Path

Discuss the universal connector for forums and other applications. (including vBridge )
Locked
User avatar
qbonoguy
Joomla! Intern
Joomla! Intern
Posts: 51
Joined: Sun Aug 28, 2005 9:07 pm
Location: St. Charles, Missouri USA
Contact:

Absolute Path

Post by qbonoguy » Wed Nov 16, 2005 12:44 am

If my forum installation is simply in a subdirectory called /forum which is located in the root of the Joomla install, what do I need to set my Absolute Path to?

The Absolute Path of my Joomla install is:
/home/httpd/vhosts//httpdocs

Therefore, I would think that the Absolute Path of my vBulletin install would be:
/home/httpd/vhosts//httpdocs/forum

When I put that in for my Absolute Path it still says it is incorrect path and it messes up the formatting of the Configuration page.
--> Brian Robertson

User avatar
kenmcd
Joomla! Champion
Joomla! Champion
Posts: 5672
Joined: Thu Aug 18, 2005 2:09 am
Location: California
Contact:

Re: Absolute Path

Post by kenmcd » Wed Nov 16, 2005 12:56 am

That should be correct.

Put this code in a PHP file, put it in the forum directory, and run it (point to it with browser).

serverroot.php

Code: Select all

<?php
echo $_SERVER['DOCUMENT_ROOT'];
?>
That should show the correct path.

Also be sure you do not have a trailing slash on your site URL setting.

Where are you putting this?
Are you making manual changes to the vB config file?
██ LibreTraining

User avatar
qbonoguy
Joomla! Intern
Joomla! Intern
Posts: 51
Joined: Sun Aug 28, 2005 9:07 pm
Location: St. Charles, Missouri USA
Contact:

Re: Absolute Path

Post by qbonoguy » Wed Nov 16, 2005 1:29 am

From the Joomla Admin area I'm going to... Components > vbridge > configuration

I created the file as you suggested... then uploaded it to my forum directory... when I run it it shows the same path as my Joomla Root... very strange...

For example...

http://www.domain.com (the location of my joomla site)
/home/httpd/vhosts/domain.com/httpdocs

http://www.domain.com/forum
/home/httpd/vhosts/domain.com/httpdocs

So, I added "/home/httpd/vhosts/domain.com/httpdocs" to the vbridge config area for Absolute path and it still says incorrect path...

Any other ideas? I really need to get this thing working and I'm totally stumped...

Thank you for your input!
--> Brian Robertson

LordRayden
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Nov 16, 2005 2:51 pm

Re: Absolute Path

Post by LordRayden » Wed Nov 16, 2005 3:16 pm

Same with me,

he also keeps telling me that he not write config.bak.php, where can I find this file?
and now I get

Datenbankfehler in vBulletin 3.5.1:

mysql_connect(): Unknown MySQL Server Host 'MOS_HOST' (1) /home/httpd/vhosts/zwickl.net/subdomains/www2/httpdocs/forum/includes/class_core.php on line 273

MySQL-Fehler :
Fehler-Nr.   : 0
Datum        : Wednesday, November 16th 2005 @ 03:45:16 PM
Skript       : http://www2.zwickl.net/forum/admincp/user.php
Referrer     : http://www2.zwickl.net/forum/admincp/us ... o=edit&u=2
IP-Adresse   : *********
Benutzername : Administrator
Klassenname  : vb_database

Even if I uninstall the vbridge component I get the same error.
And uninstall isl not droping vb_userid and vb_threadid

What can I do?

Thanks LordRayden
Last edited by LordRayden on Wed Nov 16, 2005 4:17 pm, edited 1 time in total.

User avatar
kenmcd
Joomla! Champion
Joomla! Champion
Posts: 5672
Joined: Thu Aug 18, 2005 2:09 am
Location: California
Contact:

Re: Absolute Path

Post by kenmcd » Wed Nov 16, 2005 10:12 pm

qbonoguy wrote: I created the file as you suggested... then uploaded it to my forum directory... when I run it it shows the same path as my Joomla Root... very strange...

For example...

http://www.domain.com (the location of my joomla site)
/home/httpd/vhosts/domain.com/httpdocs

http://www.domain.com/forum
/home/httpd/vhosts/domain.com/httpdocs
That's because that script only determines the server root, not the complete path.
Have others for full path to the document. Sorry.
Regardless - you can still determine the correct path to the forum.
So, I added "/home/httpd/vhosts/domain.com/httpdocs" to the vbridge config area for Absolute path and it still says incorrect path...
Should be:  /home/httpd/vhosts/domain.com/httpdocs/forum
You had it right to begin with.
Sure it is "/forum" and not "/forums"?
The vB install instructions suggest "forums" and you may have used that. ? ? ?

What do you have in the vBulletin config.php file for "FULL PATH TO FORUMS DIRECTORY"?
Line 95:  $config['Misc']['forumpath'] = '';
vB instructions state most should leave it blank (as above), but some may need to fill it in.
██ LibreTraining

User avatar
pompeyjohn
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Sun Sep 18, 2005 9:26 pm
Location: Southampton, England
Contact:

Re: Absolute Path

Post by pompeyjohn » Wed Dec 07, 2005 12:06 pm

I have the same problem as above with an incorrect absolute path. I have created the serverroot.php file and now I have a value for the path field which I hope will work.

/home/user/public_html/forum

The problem being that I cant update the path in the vbridge configuration page. Opening that page brings up a page without any joomla admin header or buttons.

There are two errors on the configuration page. The first is the above mentioned path error, the second is an incorrect path for the vbulletin cookies - which is currently set to bb

on the installation tab

I have an error because I have not installed the module yet - I am guessing this will resolve itself when I do install the module.

More worryingly though there is also the following

Code: Select all

Warning: filesize(): Stat failed for http://www.opensourcemusic.info/forum/includes/config.php (errno=2 - No such file or directory) in /home/openuser/public_html/administrator/components/com_vbridge/functions.vbridge.php on line 145

Warning: fread(): Length parameter must be greater than 0. in /home/openuser/public_html/administrator/components/com_vbridge/functions.vbridge.php on line 145

Warning: filesize(): Stat failed for http://www.opensourcemusic.info/forum/includes/config.php (errno=2 - No such file or directory) in /home/openuser/public_html/administrator/components/com_vbridge/functions.vbridge.php on line 169

Warning: fread(): Length parameter must be greater than 0. in /home/openuser/public_html/administrator/components/com_vbridge/functions.vbridge.php on line 169

Warning: copy(http://www.opensourcemusic.info/forum/includes/config.bak.php): failed to open stream: HTTP wrapper does not support writeable connections. in /home/openuser/public_html/administrator/components/com_vbridge/functions.vbridge.php on line 188
ERROR: Could not write config.bak.php
john
opensourcemusic.info


Locked

Return to “com_connector - Multi Joomla Bridge”