constant database error

Discuss the universal connector for forums and other applications. (including vBridge )
Locked
osirus35
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Dec 05, 2005 5:27 am

constant database error

Post by osirus35 » Mon Dec 05, 2005 5:32 am

I keep on getting this database error when members try to register and even when i try to log into the admin panel. Im not sure what is causing this but I am assuming its vbridge since I did not have this issue before. All I do is refresh the page and things seem to work but it is an annoying error, and my members cant seem to register because this error seems to stop the server from sending them their activation emails

"Database error in vBulletin 3.5.1:

mysql_connect(): Unknown MySQL Server Host 'MOS_HOST' (1)
/home/wartorns/public_html/vbulletin/includes/class_core.php on line 271

MySQL Error  :
Error Number : 0
Date        : Monday, December 5th 2005 @ 12:13:17 AM
Script      : http://www.wartornsoldiers.us/vbulletin/login.php
Referrer    : http://www.wartornsoldiers.us/vbulletin ... /index.php
IP Address  : **.**.***.***
Username    : osirus35
Classname    : vb_database"

leonsio
Joomla! Explorer
Joomla! Explorer
Posts: 355
Joined: Wed Nov 02, 2005 11:20 am
Contact:

Re: constant database error

Post by leonsio » Mon Dec 05, 2005 7:27 am

look at your config.php in /includes/ folder

it must be patched by vbridge
an conains some constanzs like MOS_HOST

User avatar
joomlamoves
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 111
Joined: Fri Sep 02, 2005 4:29 pm

Re: constant database error

Post by joomlamoves » Mon Dec 05, 2005 10:34 am

i couldn't fix this until i gave up and put all the vbulletin files in the same DB as joomla was in... the configs were ok but there were permission issues with connecting to the mysql host, etc....
dreary query begone

osirus35
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Dec 05, 2005 5:27 am

Re: constant database error

Post by osirus35 » Mon Dec 05, 2005 3:52 pm

how would i go about patching vbridge? I knew that was the one thing that i missed but couldnt figure out.

*edit* I tried the code that i found in the forums and uploaded the updated config and still no luck.

My vbulletin data tables are on its own database rather then installing it on the joomla database (i dont like to mix things up). Also my vbulletin folder is located outside of the joomla folder (again i dont like to mix things up if u dont have to)

ie: this is what my public_html folder looks like

folder: joomla
folder: vbulletin
folder: sin
folder: ipb
Last edited by osirus35 on Mon Dec 05, 2005 4:21 pm, edited 1 time in total.

clenard
Joomla! Intern
Joomla! Intern
Posts: 89
Joined: Mon Aug 22, 2005 7:32 pm
Location: California, USA

Re: constant database error

Post by clenard » Tue Dec 06, 2005 12:51 am

I'm not sure what the Problem is -- I haven't used the Multi-Database setup and don't plan to. I guess I just don't see what's wrong with using the Same DB  :-\

When Marko gets better I believe he'll have a working version for this, which has delayed the Process of vBridge all in all.


Locked

Return to “com_connector - Multi Joomla Bridge”