Register Link screwing up!!!

Your code modifications and patches you want to share with others.
Locked
whazupwidu
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Mon Jul 27, 2009 1:30 am

Register Link screwing up!!!

Post by whazupwidu » Tue Nov 24, 2009 8:50 pm

Please, someone, help me understand why Joomla places an extension on the end of my register link based on the page the module is on. I have a login module on the home page (left module position)...which works fine when someone clicks on "Register". The same module on other pages has the same link after clicking on "Register", but adds the page category and page title .html after the appropriate link!!!

Here is the direct link...
Home Page where is works fine... http://www.knoxvilletnwebdesign.com/nin ... entre.com/

Another page where it doesn't... http://www.knoxvilletnwebdesign.com/nin ... endar.html

Please advise. Anyone got the resolution for this one??? Thanks in advance.

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 14802
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: Register Link screwing up!!!

Post by mandville » Wed Nov 25, 2009 1:30 am

is the sef urls switched on, just switch on the top2 , sef urls and mod rewrite, not the add suffix and try that
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

whazupwidu
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Mon Jul 27, 2009 1:30 am

Re: Register Link screwing up!!!

Post by whazupwidu » Wed Nov 25, 2009 1:53 am

No worky! It messes up more links...from menu items as well, if I have mod_rewrite on. I currently have yes, no, yes. Any other ideas?

whazupwidu
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Mon Jul 27, 2009 1:30 am

Re: Register Link screwing up!!!

Post by whazupwidu » Wed Nov 25, 2009 1:55 am

I don't suppose you can recommend a plugin that would replace the Joomla system Login either?

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 14802
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: Register Link screwing up!!!

Post by mandville » Wed Nov 25, 2009 2:38 am

ok the sequence should be (most people find) Y/Y/N and they have their htaccess.txt renamed as .htaccess == notice the " . ".. what server are you running on etc
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

whazupwidu
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Mon Jul 27, 2009 1:30 am

Re: Register Link screwing up!!!

Post by whazupwidu » Wed Nov 25, 2009 2:51 am

Yeah, I know. I have updated the htaccess file. The site works fine with the YYN selections, other than some links I would have to redo...but the "Register" link still has an extension added for the particular page it's on! I think I may have inadvertently changed something in the mod_login file default. I have other Joomla sites that don't have this issue with the same SEF settings. I was trying to redirect the "register" link to a paticular page, but apparently I'm going to have to revert back to the standard index.php?option=com_user&view=register???

whazupwidu
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Mon Jul 27, 2009 1:30 am

Re: Register Link screwing up!!!

Post by whazupwidu » Wed Nov 25, 2009 3:01 am

I figured it out. I had to replace the "index.php?option=com_user&view=register" with the full URL of the redirect. Some things are sooo touchy! Thank you for your help!

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 14802
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: Register Link screwing up!!!

Post by mandville » Wed Nov 25, 2009 3:03 am

Np = sorry i couldnt do more
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

jkm
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Nov 26, 2009 8:02 am

Re: Register Link screwing up!!!

Post by jkm » Thu Nov 26, 2009 8:31 am

Hi,

I seem to have same problem. I am not sure what you replaced and where...

Can You help me?

Thanks in advance

whazupwidu
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Mon Jul 27, 2009 1:30 am

Re: Register Link screwing up!!!

Post by whazupwidu » Thu Nov 26, 2009 5:29 pm

Sure. I was trying to attempt to change the "Register" link on the login module so that it pointed to an information page instead of the standard register form page. When I did that, I replaced index.php?option=com_user&view=register with the new link only I didn't put in the full URL in so it caused the extension error. This is located in the following location on the server... /templates/template name/html/mod_login/default.php. If you haven't changed this file, you probably don't have the same problem.

jkm
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Nov 26, 2009 8:02 am

Re: Register Link screwing up!!!

Post by jkm » Fri Nov 27, 2009 7:54 am

No - this is not related issues then.

I only try to use the login feature(mod_login) as is.

When I select Register or Logon or forgot password I get information like this (here for register index.php?option=com_user&view=register#content):

Component not found

Call stack
# Function Location
1 JSite->dispatch() /home/www/herlevishockey.dk/cup/index.php:68
2 JComponentHelper->renderComponent() /home/www/herlevishockey.dk/cup/includes/application.php:124
3 JError->raiseError() /home/www/herlevishockey.dk/cup/libraries/joomla/application/component/helper.php:120
4 JError->raise() /home/www/herlevishockey.dk/cup/libraries/joomla/error/error.php:171
5 JException->__construct() /home/www/herlevishockey.dk/cup/libraries/joomla/error/error.php:136

Maybe I should open another thread...


Locked

Return to “Core Hacks and Patches”