Manual data migration 1.0.12 to 1.5 seems to fail

erkemeder
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jul 11, 2007 11:53 am
Location: Amersfoort, NL

Manual data migration 1.0.12 to 1.5 seems to fail

Postby erkemeder » Wed Jul 11, 2007 2:21 pm

Hello:

I have only recently begun using Joomla (in the last two weeks). I was interested in taking a look at how the coming 1.5 version might differ from the current 1.0.12. To make the comparison, I decided to install Joomla 1.5 and try to make use of the possibility of migrating current data in the 1.0.12 site to a new 1.5 version of the site as outlined on the page mentioned in the following Description:

Description:
I wanted to migrate database data from a local development site from Joomla 1.0.12 to 1.5. To do so, I began by following instructions provided at the following location:
http://www.joomla.org/component/option, ... 105/p,107/

Since I could not find where I could download the com_migrator component (the two links provided on the page mentioned above which refer to http://forge.joomla.org/sf/frs/do/listR ... m_migrator result in a 404 Page not found), I decided to follow the instructions for Step 2: Manual Migration:

I then did the following:

1. Dumped 1.0.12 MySQL db; INSERTS (complete) only, no table structure. Encoding/collation for project is utf-8/utf8_general_ci.
2. Opened resulting dump in editor (Zend Studio, project encoding id utf-8), made changes to the two column names mentioned in the instructions. Removed non core table INSERTS, meaning any INSERTS regarding tables not listed in the instructions under "Which tables to import?".

I then downloaded the Joomla 1.5 nightly build (http://dev.joomla.org/content/view/17/60/#nightly), and began the installation process. Everything seemd to go fine. At step 6. (Main) Configuration, I selected "Load Migration Script" option, filled in the necessary info, i.e. old table prefix, old site encoding. I then browsed for the migration script (mysql dump) and pressed the upload/execute button.

I then received the following response: "Migration succeeded. press next to continue."

When I pressed the green next button in the upper-right hand corner of this page, I found myself back on the "6. (Main) Configuration" page, which is where I had just come from. ??? The migration/import appears to be fine at this point (the database has indeed been populated, for example the #__content table contains the data from the 1.0.12 site), but there seems to be no way forward to the site, no way to complete the installation. When I load the site at the homepage location by typing the URL in the browser directly of the site root, I get the "1. Choose Language" page once again from the installer.

Reported on:
nightly build, donwloaded 11/7/2007
(http://dev.joomla.org/content/view/17/60/#nightly)

Affected functions:
Manual migration of 1.0.12 data to 1.5 using Joomla 1.5 installer script

Steps to replicate:
Described above.
No live URL available.

System info:
System Linux 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686
PHP Version 5.2.3-0.dotdeb.1
Apache Version Apache/2.2.3 (Ubuntu) PHP/5.2.3-0.dotdeb.1 with Suhosin-Patch
(MySQL) Server version: 5.0.41-Dotdeb_1.dotdeb.2-log

I repeated the install, with a new (empty) database, new installation of Joomla, and recieved the same results.

Thanks,
Cal Smith
cal@dop.nu

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18570
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Manual data migration 1.0.12 to 1.5 seems to fail

Postby infograf768 » Wed Jul 11, 2007 2:34 pm

The article you refer to is more than a year old.
I guess some has changed since.

The new Migrator component is almost finished and goes through test atm.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group


Return to “Quality and Testing - Locked and Archived”

Who is online

Users browsing this forum: No registered users and 2 guests