Safe Mode problemer :(

Generelle spørsmål vedrørende Joomla

Moderators: Per Yngve Berg, sone12

Locked
User avatar
Spider1
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Oct 15, 2005 5:19 pm

Safe Mode problemer :(

Post by Spider1 » Sat Oct 15, 2005 5:34 pm

Jeg sliter med å lste opp komponenter og moduler ettersom webserveren jeg har domene på har satt Safe Mode til "ON"  >:(
Er det ikke mulig og laste disse opp manuellt via FTP?
I så fall, hvor laster jeg dem opp og hvordan installerer jeg dem?

Prøvde å installere "Safe Mode" Patchen for Mambo men da krasjet siden :(


På forhånd takk for alle svar!

User avatar
magentait
I've been banned!
Posts: 519
Joined: Tue Aug 30, 2005 11:53 am
Location: Norway
Contact:

Re: Safe Mode problemer :(

Post by magentait » Sun Oct 16, 2005 8:14 am

Det beste rådet er å skifte til et hosting selskap som har safe mode off.

Jeg driver mitt eget hosting selskap, og mine servere har safe mode off. Jeg har flere Joomla og Mambo kunder på mine servere, helt uten problemer.

User avatar
august
Joomla! Explorer
Joomla! Explorer
Posts: 332
Joined: Thu Aug 18, 2005 7:00 pm
Location: Olso, Norway
Contact:

Re: Safe Mode problemer :(

Post by august » Sat Oct 22, 2005 1:12 pm

Et lite dikt om safemode

Safemode kan gjøre at alt går i dass
og hosten har helt sikkert bare på trass
satt på safe mode på din server.

Safemode er ikke en ting man vil ha
for safemode kan ødelegge ting som en bra
når du har safemode på din server

Safemode er greit når man er CIA,
men for folk flest er safemode en ting man blir lei,
så ikke ha safemode på din server.

Så om du kan telefonere din host,
og si skru av "safemode eller bli til en ost"
så har du ikke safemode på din server

En tegneserie
You do not have the required permissions to view the files attached to this post.
Last edited by august on Sat Oct 22, 2005 1:15 pm, edited 1 time in total.
August Lilleaas
http://august.lilleaas.net.
<3

frbliks
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Oct 21, 2005 11:10 pm

Re: Safe Mode problemer :(

Post by frbliks » Sat Oct 22, 2005 4:41 pm

magentait wrote: Det beste rådet er å skifte til et hosting selskap som har safe mode off.

Jeg driver mitt eget hosting selskap, og mine servere har safe mode off. Jeg har flere Joomla og Mambo kunder på mine servere, helt uten problemer.
Jeg tittet litt på siden din, men fant ikke noe prisliste på hosting. Kanskje jeg ikke så nøye nok etter?
Er interessert i bytte hosting til server uten safe mode problemer.

-frbliks

User avatar
norsegod
Joomla! Intern
Joomla! Intern
Posts: 62
Joined: Wed Aug 24, 2005 11:38 am
Location: Kongsvinger, Norway
Contact:

Re: Safe Mode problemer :(

Post by norsegod » Sat Oct 29, 2005 6:42 pm

Det som er skikkelig fint med safe_mode off er at man kan lage seg en liten PHP snutt på 2 min som henter ut andre brukeres configuration.php med bl.a. brukernavn og passord til mysql databasen  :o

User avatar
magentait
I've been banned!
Posts: 519
Joined: Tue Aug 30, 2005 11:53 am
Location: Norway
Contact:

Re: Safe Mode problemer :(

Post by magentait » Sun Oct 30, 2005 7:38 am

Ja vel ... gi oss litt mer info. om dette

Et PHP-skript kan ikke kjøres uten å tilgang til serveren?
Last edited by magentait on Sun Oct 30, 2005 9:18 am, edited 1 time in total.

User avatar
norsegod
Joomla! Intern
Joomla! Intern
Posts: 62
Joined: Wed Aug 24, 2005 11:38 am
Location: Kongsvinger, Norway
Contact:

Re: Safe Mode problemer :(

Post by norsegod » Sun Oct 30, 2005 10:29 am

Beklager, men jeg burde ha nevnt at dette selvfølgelig gjelder "shared hosts" (type flere virtualhosts på samme server) og du må ha en konto på samme maskinen. Jeg har testet ut dette hos ganske mange webhotell og det har fungert hos samtlige.

1. Finn ut hvor brukermappene ligger og hvor "public_html"-mappen er i disse (dette bør du vite hvis du har en konto der)
2. Velg en "public_html" mappe hos en vilkårlig bruker og les inn filene

Eks:


Men dette er jo egentlig et ganske kjent problem med "shared enviroments".

User avatar
magentait
I've been banned!
Posts: 519
Joined: Tue Aug 30, 2005 11:53 am
Location: Norway
Contact:

Re: Safe Mode problemer :(

Post by magentait » Sun Oct 30, 2005 6:10 pm

...det spør hvor seriøs hosting selskapet er. Min leverandør er fullstendig klar over dette, og har lagt på en sperre slik at man ikke får tilgang til andre sine nettsteder (kun sine egne). Jeg har mitt eget hosting selskap, og ble litt bekymret - men har fått bekreftet at dette ikke er mulig å "snoke" i andres filer.  ;)

User avatar
august
Joomla! Explorer
Joomla! Explorer
Posts: 332
Joined: Thu Aug 18, 2005 7:00 pm
Location: Olso, Norway
Contact:

Re: Safe Mode problemer :(

Post by august » Tue Nov 01, 2005 2:04 am

Servere hvor dette er ett problem er som regel plassert under kjøkkenbenken til hostingselskapet med 56 kbps-linje. Slike ting er ikke et problem hos store selskaper nå til dags.
August Lilleaas
http://august.lilleaas.net.
<3


Locked

Return to “Generelt”