MMS blog!

Spørsmål vedrøredne tredjepartsutvidelser som komponenter, moduler etc.

Moderators: Per Yngve Berg, sone12

Locked
User avatar
jenscski
Joomla! Ace
Joomla! Ace
Posts: 1468
Joined: Thu Aug 18, 2005 6:58 am
Location: Tønsberg, Norway

Re: MMS blog!

Post by jenscski » Wed Mar 01, 2006 9:39 pm

Har alleredet endret koden slik at det i neste versjon blir støtte for MySQL 3 også.
Jens-Christian Skibakk
MMS Blog - http://mms.pipp.no/
Joomla! i Norge / Joomla! in Norway - http://www.joomlainorge.no/

User avatar
perandre
Joomla! Explorer
Joomla! Explorer
Posts: 350
Joined: Thu Feb 23, 2006 2:17 am
Location: Norway
Contact:

Re: MMS blog!

Post by perandre » Thu Mar 02, 2006 1:46 pm

Ønsker for senere utgave av den geniale Mms Blog:

-Mulighet for å gå utenom godkjennings-prosedyren
-Mulighet for å kjøre uten teksten over bildene
-Mulighet for å vise 2 rekker ved siden av hverandre

:)

comtjfnon
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Fri Oct 21, 2005 6:30 am
Location: Norway
Contact:

Re: MMS blog!

Post by comtjfnon » Thu Mar 02, 2006 1:58 pm

Finnes det noen overskrifts tagger jeg kan bruke i mms meldingen som gjør at komponenten kan skille overskrift / brødtekst?
**************************
*********Joomlafan*********
**************************

User avatar
jenscski
Joomla! Ace
Joomla! Ace
Posts: 1468
Joined: Thu Aug 18, 2005 6:58 am
Location: Tønsberg, Norway

Re: MMS blog!

Post by jenscski » Thu Mar 02, 2006 3:01 pm

comtjfnon wrote: Finnes det noen overskrifts tagger jeg kan bruke i mms meldingen som gjør at komponenten kan skille overskrift / brødtekst?
Nei, jeg har ikke lagt til det. Men kanskje jeg skulle implementere noe BBcode til neste versjon?
Jens-Christian Skibakk
MMS Blog - http://mms.pipp.no/
Joomla! i Norge / Joomla! in Norway - http://www.joomlainorge.no/

comtjfnon
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Fri Oct 21, 2005 6:30 am
Location: Norway
Contact:

Re: MMS blog!

Post by comtjfnon » Thu Mar 02, 2006 3:09 pm

Det kunne vært smart for de "avanserte" brukerne, eller administratorer.Nå er det jo ikke noe problem å ordne dette via web, men når man f.eks. er ute og reiser har man jo ikke alltid webtilgang. Det blir heller ikke pent i modulen "siste mms melding", når den tar X antall bokstaver fra teksten.

Ellers er jeg veldig fornøyd. Men har ikke helt forstått oppdateringen mot popserver. Skjer dette ved et gitt intervall, eller først når siden blir trykket på i Joomla?
**************************
*********Joomlafan*********
**************************

User avatar
jenscski
Joomla! Ace
Joomla! Ace
Posts: 1468
Joined: Thu Aug 18, 2005 6:58 am
Location: Tønsberg, Norway

Re: MMS blog!

Post by jenscski » Thu Mar 02, 2006 3:20 pm

comtjfnon wrote: Det kunne vært smart for de "avanserte" brukerne, eller administratorer.Nå er det jo ikke noe problem å ordne dette via web, men når man f.eks. er ute og reiser har man jo ikke alltid webtilgang. Det blir heller ikke pent i modulen "siste mms melding", når den tar X antall bokstaver fra teksten.
Skal se på saken når jeg får tid. Er nok å gjøre med Joomla! i Norge for tiden :D
Ellers er jeg veldig fornøyd. Men har ikke helt forstått oppdateringen mot popserver. Skjer dette ved et gitt intervall, eller først når siden blir trykket på i Joomla?
Hver gang noen besøker siden din så vil komponenten sjekke om den skal hente meldinger fra popserver. Om den skal hente meldinger bestemmes av et fast tidsinterval, som nå er satt på to minutter.

Så hvis du i løpet av 3 minutter har et treff hvert 10 sekund, så er det bare to ganger som komponenten kobler seg opp mot serveren.

Hvis du har et besøk si 14:00, og dette besøket sjekker popserveren, for så at neste besøk er 10 minutter senere, vil det ikke være noe sjekking av meldinger på serveren før kl 14:10, selv om intervallet er satt til 2 minutter.
Jens-Christian Skibakk
MMS Blog - http://mms.pipp.no/
Joomla! i Norge / Joomla! in Norway - http://www.joomlainorge.no/

hawthorne
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Jan 21, 2006 9:44 pm

Re: MMS blog!

Post by hawthorne » Thu Mar 02, 2006 9:24 pm

jenscski wrote: Hver gang noen besøker siden din så vil komponenten sjekke om den skal hente meldinger fra popserver. Om den skal hente meldinger bestemmes av et fast tidsinterval, som nå er satt på to minutter.
Er det mulig å debugge? Har et par meldingen liggende på pop3 serveren, men det virker som om komponenten ikke sjekker.


-Jørn
(http://www.nrfk.org)

User avatar
jenscski
Joomla! Ace
Joomla! Ace
Posts: 1468
Joined: Thu Aug 18, 2005 6:58 am
Location: Tønsberg, Norway

Re: MMS blog!

Post by jenscski » Fri Mar 03, 2006 7:12 am

hawthorne wrote:
jenscski wrote: Hver gang noen besøker siden din så vil komponenten sjekke om den skal hente meldinger fra popserver. Om den skal hente meldinger bestemmes av et fast tidsinterval, som nå er satt på to minutter.
Er det mulig å debugge? Har et par meldingen liggende på pop3 serveren, men det virker som om komponenten ikke sjekker.
Jeg har ikke lagt inn noe debugging i koden. Så hvis du vil debugge og kan php så se på filen update.php.

Skal se om jeg kan få laget en form for debugging i komponenten etterhvert.
Jens-Christian Skibakk
MMS Blog - http://mms.pipp.no/
Joomla! i Norge / Joomla! in Norway - http://www.joomlainorge.no/

Lager Hagen
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Thu Feb 23, 2006 2:30 pm

Re: MMS blog!

Post by Lager Hagen » Mon Mar 06, 2006 2:39 pm

hei hei,
Sliter med å få denne MMS bloggen til å virke gitt.

har opprettet en gmail konto, installert Componentet,modulen og bot'en.

Hos gmail har jeg funnet denne infoen:

pop.googlemail.com
Use SSL: Yes
Port: 995

Gmail har støtte for pop3 men ikke IMAP.

Da ville jeg tro at min config bør se slik ut:

{pop.googlemail.com:995/pop3/SSL}INBOX

Ellers er bruker navn det samme som epost adresse.

eller tar jeg feil her?  :( Får denne feilmeldingen:
Connection failed to pop.googelmail.com,995: Connection refused


Bruker forresten joomla version Joomla! 1.0.7 Stable

Skjønner ikke dette... hjeeeelp!  ;)
Last edited by Lager Hagen on Mon Mar 06, 2006 2:44 pm, edited 1 time in total.

User avatar
Stinus
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 210
Joined: Thu Feb 02, 2006 9:25 pm
Location: Stavanger / Tananger
Contact:

Re: MMS blog!

Post by Stinus » Mon Mar 06, 2006 3:27 pm

Hei

Bare til info:
Posted by: perandre
Insert Quote
Hurra! Fungerer!
Av ukjente grunner ble det bare tull med gmail og runbox. Forsøkte en tredje, og det bare funket. Jeg trenger ikke vite hvorfor, er bare fornøyd:)
Stian Magnussen
Veteranbrannbiler - https://veteranbrannbiler.com/ - En side om gamle brannbiler
1. Tananger Sjøspeidergruppe - https://1tanangersjo.no/

Lager Hagen
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Thu Feb 23, 2006 2:30 pm

Re: MMS blog!

Post by Lager Hagen » Mon Mar 06, 2006 3:35 pm

ja, så det men gir meg ikke så lett. Ser ingen grunn til at gmail ikke skal funke så lenge det er support for pop3 begge veier.

:D

olem
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 135
Joined: Mon Nov 28, 2005 12:05 am
Location: Oslo
Contact:

Re: MMS blog!

Post by olem » Sat Mar 11, 2006 10:22 am

har installert det, men hvordan bruker man programmet. Får opp fire valg:
Content
Users
configuration
About

hvor legger man inn eventuelle nr. etc.
Skal meldingen sendes som e-mail eller vanlig melding.  På en vanlig melding får geg bare tall og ikke bokstaver på telefonen.
Er jeg helt på jordet nå??

Ole Martin

User avatar
Stinus
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 210
Joined: Thu Feb 02, 2006 9:25 pm
Location: Stavanger / Tananger
Contact:

Re: MMS blog!

Post by Stinus » Sat Mar 11, 2006 10:30 am

Hei
Content = meldinger som er sendt inn, må godkjennes for å kunne vises
User = brukere som har sendt inn melding, må godkjennes en gang - her vises for eks mobiltelefon nr, e-post konto
configuration = her konfigrueres oppsettet.
about = hvem som har laget det og litt info.

Man sender det som e-post.

Håper at du får det til.
Stian Magnussen
Veteranbrannbiler - https://veteranbrannbiler.com/ - En side om gamle brannbiler
1. Tananger Sjøspeidergruppe - https://1tanangersjo.no/

olem
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 135
Joined: Mon Nov 28, 2005 12:05 am
Location: Oslo
Contact:

Re: MMS blog!

Post by olem » Sat Mar 11, 2006 9:16 pm

Hei og takk for svar.
Sitter her og prøver. laget en ny e-postadresse til dette formål. Men når jeg sender får jen denne meldingvia Evolution;
Connection failed to pop.mail.renseri.net.netbox.no,110: Connection timed out

hvilken kode er det snakk om?
"Edit: du må ha med hele epostadressen din:  dittnavn@din-epostlevernadør.com  + koden til e-postadressen"

Er det nok å lage en link til siden MMs skal vises på, eller skal man ha en modul på førstesiden?

Laget enMeny link og når jeg klikker på denne får jeg opp (etter Lang tid)
"Warning: imap_open(): Couldn't open stream {pop.mail.renseri.net:110/pop3/notls}INBOX in /hsphere/local/home/renseri/renseri.net/FlexiService/components/com_mmsblog/update.php on line 112"
Last edited by olem on Sat Mar 11, 2006 9:27 pm, edited 1 time in total.

User avatar
lavo
Joomla! Apprentice
Joomla! Apprentice
Posts: 44
Joined: Fri Nov 04, 2005 8:19 pm
Location: Norway
Contact:

Re: MMS blog!

Post by lavo » Sun Mar 12, 2006 10:38 am

Dette er ikke mindre enn et FANTASTISK komponent, hadde jeg bare fått det til å fungere.  Jeg kjører to like sider, men på hver sin server, en i norge og en i danmark(testside) - begge Linux.  Komponenten fungerer helt prikkfritt på min testserver i danmark, men nekter å fungere på vår server i norge.  Jeg har prøvd flere epostkontoer og disse fungerer utmerket på testsiden som ligger på den danske server, men ikke på nettsiden som ligger på den norske serveren.

Komponenten er innstallert riktig, tabellene er opprettet og ser helt like ut i begge databasene, bare med den forskjell at i databasen til vår testside i danmark ligger alle bilder og tekster som de skal, mens på den norske kommer ingenting inn i databasen(tabellene er tomme). Sender jeg en mms til både den norske nettsiden og den danske testsiden, med samme epostoppsett - kommer bildet rett inn i den danske testsiden vår, men det skjer ingenting på vår norske nettside. Edit:  dvs jeg får følgende melding på epost:  Blog error:  Connection failed to imap-a.start.no,110: Connection timed out

Konfig på dansk server:
PHP versjon  4.3.10-16
MySql: 4.0.24_Debian-10sarge1-log

Konfig på norsk server:
PHP versjon  4.4.1
MySql: 4.1.11-standard-log

Begge sitene kjører: Joomla 1.0.8.

Er det noen som har en fornuftig på forklaring på hvorfor dette ikke virker.
Last edited by lavo on Sun Mar 12, 2006 11:52 am, edited 1 time in total.

olem
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 135
Joined: Mon Nov 28, 2005 12:05 am
Location: Oslo
Contact:

Re: MMS blog!

Post by olem » Sun Mar 12, 2006 7:53 pm

hei.
sitter her bog prøver med flere forsøk,
når jeg klikker på menylinken til siden det skulle vært vist på for jeg denne meldingen:

Warning: imap_open(): Couldn't open stream {pop.mail.renseri.net:110/pop3/notls}INBOX in /hsphere/local/home/renseri/renseri.net/FlexiService/components/com_mmsblog/update.php on line 112

Skulle så gjerne  ha fått det til.
Warning: imap_open(): Couldn't open stream {pop.mail.renseri.net:110/pop3/notls}INBOX in /hsphere/local/home/renseri/renseri.net/FlexiService/components/com_mmsblog/update.php on line 112

Her er et bilde av oppsettet:
http://renseri.net/FlexiService/index.p ... &Itemid=54

User avatar
lavo
Joomla! Apprentice
Joomla! Apprentice
Posts: 44
Joined: Fri Nov 04, 2005 8:19 pm
Location: Norway
Contact:

Re: MMS blog!

Post by lavo » Sun Mar 12, 2006 8:37 pm

Har du prøvd uten  "mail"  altså bare: pop:renseri.net:110/osv.  og kun "post" uten @renseri.net i feltet for user? Den foreslåtte løsningen fungere fint på min danske server, men ikke den norske.  Jeg har selv prøvd de fleste kombinasjoner uten hell,  men kan jo hende det virker for deg  :)

olem
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 135
Joined: Mon Nov 28, 2005 12:05 am
Location: Oslo
Contact:

Re: MMS blog!

Post by olem » Sun Mar 12, 2006 8:58 pm

nå fkk jeg det til .
sender deg en link av oppsettet.
http://renseri.net/FlexiService/index.p ... &Itemid=54

Det var supporten på Netbox som kom med ideen i å ta vekk "pop" og du ga meg en ny ide i tillegg.
Takk

Edit: men hvorfor kommer samme melding flere ganger. bildemeldingen som jeg også sendte er ike kommet enda.
http://renseri.net/FlexiService/index.p ... &Itemid=52
Last edited by olem on Sun Mar 12, 2006 9:18 pm, edited 1 time in total.

User avatar
lavo
Joomla! Apprentice
Joomla! Apprentice
Posts: 44
Joined: Fri Nov 04, 2005 8:19 pm
Location: Norway
Contact:

Re: MMS blog!

Post by lavo » Sun Mar 12, 2006 9:34 pm

TAKK!!  Det var oppsettet som også passet meg.  Gud vet hvor mange timer jeg har fundert på dette, og trodde selvfølgelig jeg hadde vært gjennom alle kombinasjoner - sto på planen og kontakte webhosten i morgen, men det slapp jeg takket være din hjelp.

Samme melding kommer bare en gang hos meg, i hvertfall foreløpig.  Motivet på bildet så veldig fristende ut :D
Last edited by lavo on Sun Mar 12, 2006 10:34 pm, edited 1 time in total.

Floranett
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 160
Joined: Sun Mar 12, 2006 7:11 pm

Re: MMS blog!

Post by Floranett » Mon Mar 13, 2006 1:43 am

Hvor kan eg laste ned denne MMS blog?

Url til siden er fint  :)

User avatar
Stinus
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 210
Joined: Thu Feb 02, 2006 9:25 pm
Location: Stavanger / Tananger
Contact:

Re: MMS blog!

Post by Stinus » Mon Mar 13, 2006 6:02 am

Stian Magnussen
Veteranbrannbiler - https://veteranbrannbiler.com/ - En side om gamle brannbiler
1. Tananger Sjøspeidergruppe - https://1tanangersjo.no/

Floranett
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 160
Joined: Sun Mar 12, 2006 7:11 pm

Re: MMS blog!

Post by Floranett » Mon Mar 13, 2006 11:23 am

Takk Stian, skal teste denne i løpet av dagen/kvelden :)

Torehs
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Jan 30, 2006 7:53 pm

Re: MMS blog!

Post by Torehs » Thu Mar 16, 2006 6:05 pm

Hei!

Dette viker som en veldig bra plugins! Men jeg får den ikke til å fungere...

Jeg har laget en link til komponentet og når jeg går inn på denne siden, kommer denne feilmeldingen opp:

Code: Select all

Fatal error: Call to undefined function: imap_open() in /home/egersund/1egersund.speidergruppe.org/components/com_mmsblog/update.php on line 112
Noen som vet hva dette skyldes og hvodan jeg kan fikse det? Jeg kjører PHP-versjon 4.3.10-16 og MySQL-versjon 4.0.24.

E-postadressen jeg benytter er en online.no-adresse som har støtte for pop3 i alle fall. Jeg bruker adressen: {pop.online.no:110/pop3/notls}INBOX i innstillingene.

Mvh. Tore
Last edited by Torehs on Thu Mar 16, 2006 6:07 pm, edited 1 time in total.

Floranett
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 160
Joined: Sun Mar 12, 2006 7:11 pm

Re: MMS blog!

Post by Floranett » Thu Mar 16, 2006 6:16 pm

Hei Tore.

Har du en lenke til siden hvor feilmeldingen kommer frem?

Prøv å bytte ut pop med mail.

Mvh,
Frank

User avatar
jenscski
Joomla! Ace
Joomla! Ace
Posts: 1468
Joined: Thu Aug 18, 2005 6:58 am
Location: Tønsberg, Norway

Re: MMS blog!

Post by jenscski » Thu Mar 16, 2006 6:55 pm

Torehs wrote: Hei!

Dette viker som en veldig bra plugins! Men jeg får den ikke til å fungere...

Jeg har laget en link til komponentet og når jeg går inn på denne siden, kommer denne feilmeldingen opp:

Code: Select all

Fatal error: Call to undefined function: imap_open() in /home/egersund/1egersund.speidergruppe.org/components/com_mmsblog/update.php on line 112
Noen som vet hva dette skyldes og hvodan jeg kan fikse det? Jeg kjører PHP-versjon 4.3.10-16 og MySQL-versjon 4.0.24.

E-postadressen jeg benytter er en online.no-adresse som har støtte for pop3 i alle fall. Jeg bruker adressen: {pop.online.no:110/pop3/notls}INBOX i innstillingene.

Mvh. Tore
Hvis du kjører på din egen maskin, så må du endre php.ini til å inkludere imap. Det er et extension som ikke er skrudd på automatisk ved installasjon.

Er dette på et webhotell, send en mail til dem og spør pent om de kan skru på støtte for imap.
Jens-Christian Skibakk
MMS Blog - http://mms.pipp.no/
Joomla! i Norge / Joomla! in Norway - http://www.joomlainorge.no/

Torehs
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Jan 30, 2006 7:53 pm

Re: MMS blog!

Post by Torehs » Fri Mar 17, 2006 8:57 am

Takk jenscski!

Jeg har nå snakket med "hosten" og de har aktivert imap_open() så nå fungerer komponetet ypperlig! Veldig bra og genial måte å gjøre dette på.

latle
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Mar 17, 2006 8:49 am
Contact:

Re: MMS blog!

Post by latle » Fri Mar 17, 2006 9:00 am

Først må gi mine honørord for super komponent! Hipp,hipp!
Er det mulig å få f.eks akocomment til å funke sammens med denne? Hadde jo vært greit om folk kunne fått kommentere bilder og sånt da... Er det bare noe jeg ikke får til, eller støtter iikke komponenten comments?

User avatar
jenscski
Joomla! Ace
Joomla! Ace
Posts: 1468
Joined: Thu Aug 18, 2005 6:58 am
Location: Tønsberg, Norway

Re: MMS blog!

Post by jenscski » Fri Mar 17, 2006 9:10 am

latle wrote: Først må gi mine honørord for super komponent! Hipp,hipp!
Er det mulig å få f.eks akocomment til å funke sammens med denne? Hadde jo vært greit om folk kunne fått kommentere bilder og sånt da... Er det bare noe jeg ikke får til, eller støtter iikke komponenten comments?
Nei, den støtter ikke kommentarer. Skal tenke litt på om det er mulig å få til det også for denne komponenten. Problemet ligger i at akocomment fungerer på nyheter. Og vil trolig aldri fungere med f.eks. MMS blog, så det er mulig at jeg må lage min egen kommenteringsting. Dessuten så tror jeg det er en svenske hadde tenkt å lage en slik funksjonalitet til komponenten, og hvis han gjøre det så håper jeg at jeg kan benytte meg av den.
Jens-Christian Skibakk
MMS Blog - http://mms.pipp.no/
Joomla! i Norge / Joomla! in Norway - http://www.joomlainorge.no/

latle
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Mar 17, 2006 8:49 am
Contact:

Re: MMS blog!

Post by latle » Fri Mar 17, 2006 9:21 am

Ok, den er grei. Vi får satse på svensken da  :)

Torehs
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Jan 30, 2006 7:53 pm

Re: MMS blog!

Post by Torehs » Fri Mar 17, 2006 9:31 am

Bare litt informasjon til alle som prøver å bruke Gmail på dette komponetet: det er mulig! Bruk denne innstillingen:
Mailbox: {pop.gmail.com:995/pop3/ssl/novalidate-cert}INBOX


Locked

Return to “Komponenter/moduler/mambots”