PHP sikkerhetsadvarsler etter oppdatering til 1.0.11

Sikkerhet i Joomla - og tilhørende elementer som server etc.

Moderators: sone12, Per Yngve Berg

Locked
Tarrant
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Thu May 11, 2006 7:38 am

PHP sikkerhetsadvarsler etter oppdatering til 1.0.11

Post by Tarrant » Fri Dec 22, 2006 9:18 am

Fikk to sikkerhetsmeldinger ved innlogging til admin-konsollet etter oppgradering fra 1.0.8 => 1.0.11

• PHP register_globals setting is `ON` instead of `OFF`
• Joomla! RG_EMULATION setting is `ON` instead of `OFF` in file globals.php

Jeg forstår ikke hva de betyr, eller om jeg bør gjøre noe med det....

Håper noen kan oppklare, + evt fortelle meg hvordan jeg endrer fra ON til OFF hvis jeg bør gjøre det.

User avatar
rued
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4778
Joined: Fri Sep 16, 2005 10:23 pm
Location: Finland / Norway
Contact:

Re: PHP sikkerhetsadvarsler etter oppdatering til 1.0.11

Post by rued » Fri Dec 22, 2006 11:22 am

Merk! Dobbelpostinger er veldig dumt..  ;)
rued wrote: Hei Thomas,

register_globals kan du som regel overstyre i din .htaccess-fil ved å legge til:

Code: Select all

php_value register_globals 0
(Omdøp htaccess.txt til .htaccess om du ikke allerede har gjort det, og legg til linjen på slutten)

Åpne globals.php og endre linje 17 fra:

Code: Select all

define( 'RG_EMULATION', 1 );
til:

Code: Select all

define( 'RG_EMULATION', 0 );
Og ha en god jul, og et godt nytt år!  :)
Rune Rasmussen - http://www.syntaxerror.no
Norske nettløsninger og integrasjoner, CONSIGNOR EDI, Mamut ordreimport og produkteksport, kortbetaling og faktura m.m.

Norsk Joomla! - Norwegian Translation Team - http://www.norskjoomla.no


Locked

Return to “Sikkerhet”