[Probleme]Les tables ne se crée pas automatiquement dans mySql

Moderators: sarki, Aidan38

Forum rules
Règles du forum
Asari
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jun 20, 2017 9:33 am

[Probleme]Les tables ne se crée pas automatiquement dans mySql

Postby Asari » Tue Jun 20, 2017 9:40 am

Bonjour,

J'esseye de crée le hello word comme indique a la page suivante
https://docs.joomla.org/J3.x:Creating_a_simple_module/Using_the_Database/fr

cependant la table ne se crée jamais à l’installation du module. Y a t'il une manipulation a faire?

(et j'ai bien dans mon fichier xml les balises )

Code: Select all

<files>
        <filename>mod_helloworld.xml</filename>
        <filename module="mod_helloworld">mod_helloworld.php</filename>
        <filename>index.html</filename>
        <filename>helper.php</filename>
        <filename>tmpl/default.php</filename>
        <filename>tmpl/index.html</filename>
      <folder>sql</folder>
    </files>
    <config>
    </config>
   <install>
     <sql>
         <file driver="mysql" charset="utf8">sql/mysql/install.mysql.utf8.sql</file>
         
     </sql>
   </install>
 
   <uninstall>
     <sql>
         <file driver="mysql" charset="utf8">sql/mysql/uninstall.mysql.utf8.sql</file>
         
     </sql>
   </uninstall>



Merci d'avance

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18501
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: [Probleme]Les tables ne se crée pas automatiquement dans mySql

Postby infograf768 » Tue Jun 20, 2017 10:04 am

Qu'y a-t'il dans install.mysql.utf8.sql
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group


Return to “French Forum”

Who is online

Users browsing this forum: No registered users and 3 guests