Fel/Avvikelser vid installation på webbhotellserver

Diskutera frågor rörande installation, backup och säkerhet avseende Joomla! 1.0.

Moderators: Zello, chrille

Forum rules
Forumregler
Locked
aliwin
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Dec 18, 2006 9:01 am

Fel/Avvikelser vid installation på webbhotellserver

Post by aliwin » Sun Jan 21, 2007 11:39 am

Använder Joomla(.11) på min lokala dator och ansåg mig ha kommit så långt så att jag skulle testa på webbhotellserver.
Men då börjar det inträffa en del konstigheter

A När jag ska ladda upp ett nytt template "Site/Template Manager/Site Template/New"

Grunduppgifter
- "Bläddra"  C:\Download\Joomla\Skins\jo_beetle.zip    "Upload&Install"
- "Install from directory"  /home/medialine.nu/a/ac/ac2045/public_html/dacrema1/administrator/components/com_installer/template/  "Install"

media/ Writeable
administrator/templates/ Writeable
templates/ Writeable
images/stories/ Writeable


Resultat
Upload template - Upload Failed 
ERROR: Could not find an XML setup file in the package. 
[ Continue ... ] 

Installation file not found:
/home/medialine.nu/a/ac/ac2045/public_html/dacrema1/media/install_45b34c5029863/ 
[ Continue ... ] 

Samma resultat får jag om jag går via "Installers"

B.  När jag ska ladda upp bilder med "Media Manager", så får jag "upload failed"

C.  När jag vill ta bort("Delete") en bild från en mapp, så försvinner inte bilden, trots att deletekommandot inte ger några felindikationer

Är det någon som har några tips, förutom att använda FTP(för det fungerar), så är jag tacksam

User avatar
Zello
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3869
Joined: Wed Jan 10, 2007 11:23 am
Location: Västerås - Sweden

Re: Fel/Avvikelser vid installation på webbhotellserver

Post by Zello » Thu Feb 01, 2007 10:56 pm

Hej!

Jar ger mig bara på A-frågan:

Kan vara så att template-zippen är felgjord. Om du zippar up den lokalt på din dator så ska den inte ligga i ytterligare en zip eller i en ytterligare katalog. Är du med?

Om inte:

Om du zippar upp filen till en mapp som heter som zip-filen så ska det i denna mapp finnas de mappar och filer som hör till templatet.

Det brukar vara följande:
En    .xml
några .php
en    .png
en    image mapp
en    css mapp

Det ska INTE finnas en mapp som heter som templatet. Om det gör det så hittas inte .xml-filen vid installation eftersom den ligger på fel ställe.

Återkom ifall det blev lite rörigt.

Titta på bilden så kanske det klarnar med detta med två likadanna mappar under varandra.

// Olle Z
Olle Zettergren
Freelance Senior Joomla developer
Moderator Swedish forum

heltsonika
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Sat Oct 01, 2005 7:11 pm

Re: Fel/Avvikelser vid installation på webbhotellserver

Post by heltsonika » Wed Feb 07, 2007 8:53 pm

Jag har exakt samma problem efter byte av webhotell.

Kom du på någon lösning?

aliwin
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Dec 18, 2006 9:01 am

Re: Fel/Avvikelser vid installation på webbhotellserver

Post by aliwin » Wed Feb 07, 2007 11:18 pm

Hej och tack för intresset

Det är ett tag sedan det här hände och allt har löst sig, efter ett massa letande i forumen.

För mig var det i slutändan ett read/write/execute problem, alltså om hur CHMOD:en var satta för repektive mappar
Man kan helt klart säga att det stundtals var lite rörigt

Tyvärr så sparade jag inte undan artiklarna, så jag kan inte hänvisa. Det jag kommer ihåg var att artiklarna fanns på det internationella forumet.

Om felen kvarstår för Dig "heltsonika", får Du gärna återkomma, få se om jag kan hjälpa Dig


/Aliwin


Locked

Return to “Installation, backup och säkerhet”