Installationsproblem!

Diskutera frågor rörande installation, backup och säkerhet avseende Joomla! 1.0.

Moderators: Zello, chrille

Forum rules
Forumregler
Locked
jensie
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 09, 2007 11:34 am

Installationsproblem!

Post by jensie » Fri Feb 09, 2007 11:46 am

Hejsan alla!

Är ny till joomla och har nu under installation fått lite problem, har tagit ett "screenshot" för att enklare förklara problemet:

http://img508.imageshack.us/my.php?image=joomlagn5.gif

Som ni ser är två saker Unwriteable - configuration.php och Session save path.

Jag fortsatte installationen och allt funka med mysql osv. Men sen när jag kommer till slutet där man kan kopiera in texten manuellt (vilket jag också har gjort, så börjar bara installationen om).

Configuration.php heter för mig configuration.php-dist och ändrar jag den till bara "configuration.php" får jag mysql problem och sidan funkar inte alls.. Ändrar jag den till config.php så funkar det fint men problemet med "Unwriteable" kvarstår. Har sökt en massa på forumet men utan resultat.

Hur löser jag detta? Vad ska jag ändra i config.php så att den blir "Writeable".. Har även testat att CHMOD den till 777 men problemet kvarstår..

Sen över till problem nummer 2.  Session save path  Unwriteable <-- Antar att detta har ngt med .htaccess att göra? Vad ska jag ändra där egentligen? Förstår inte det alls.

Jätte tacksam om ngn kan förklara enkelt i steg hur jag ändrar så allt funkar.. Har som sagt sökt omkring och hittat engelsk fakta kring problem men har inte klurat ut hur jag ska lösa problemet/problemen.

Kan förstås ge tillgång till servern till den som är villig att hjälpa. Har förresten en egen dedikerad server som är lokaliserad i USA om detta kan hjälpa.

Tack på förhand!
Vänlig Hälsning,
Jens

User avatar
Basher52
Joomla! Explorer
Joomla! Explorer
Posts: 254
Joined: Thu Nov 02, 2006 10:43 am

Re: Installationsproblem!

Post by Basher52 » Fri Feb 09, 2007 11:58 am

1. Om jag nu har för mej rätt så skapas en configuration.php efter installationen så du behöver inte döpa om dist filen.

2. Unwriteable är att J! har ingen behörighet att ändra i filen, vilket den måste för att kunna skriva in de du angett vid installationen.
Detta ändras med chmod kommandot, tex till 755 detta görs via ftp programvara vid tex webhotel eller om du har egen server vis SSH(går även här med ftp såklart :P)
Lika med savepath
Last edited by Basher52 on Fri Feb 09, 2007 12:02 pm, edited 1 time in total.
Down with winBLOWS
Long Live Open Source

jensie
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 09, 2007 11:34 am

Re: Installationsproblem!

Post by jensie » Fri Feb 09, 2007 12:03 pm

Basher52 wrote: 1. Om jag nu har för mej rätt så skapas en configuration.php efter installationen så du behöver inte döpa om dist filen.'

2. Unwriteable är att J! har ingen behörighet att ändra i filen, vilket den måste för att kunna skriva in de du angett vid installationen.
Detta ändras med chmod kommandot, tex till 755 detta görs via ftp programvara vid tex webhotel eller om du har egen server vis SSH(går även här med ftp såklart :P)
Tack för ditt svar!

1. Felet kvarstår jo endå, eftersom det fortfarande står "unwriteable" även om jag ändrar namnet eller inte

2. Så  jag sla ändra chmod .htaccess eller? till 755?

User avatar
Mackelito
Joomla! Hero
Joomla! Hero
Posts: 2901
Joined: Tue Aug 23, 2005 12:14 pm
Location: Stockholm

Re: Installationsproblem!

Post by Mackelito » Fri Feb 09, 2007 12:07 pm

Jag har för mig att mappar vill ha 644 och filer 755.. fast är inte helt 100%
- Det bästa sättet att lära sig på är att göra det själv!
- Markus Thiel
http://www.homeofsweden.se
http://www.mittyrke.se

jensie
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 09, 2007 11:34 am

Re: Installationsproblem!

Post by jensie » Fri Feb 09, 2007 12:10 pm

Testade att ändra .htaccess men inget förändras.. Förstår faktiskt inte alls vad jag ska göra för att ändra:


configuration.php  Unwriteable
You can still continue the install as the configuration will be displayed at the end, just copy & paste this and upload.
Session save path Unwriteable

Tacksam för all info  ;)
Tack för svaren förresten!

User avatar
Mackelito
Joomla! Hero
Joomla! Hero
Posts: 2901
Joined: Tue Aug 23, 2005 12:14 pm
Location: Stockholm

Re: Installationsproblem!

Post by Mackelito » Fri Feb 09, 2007 12:11 pm

Har du testat att ändra mappen och filen till 755 och 644?
- Det bästa sättet att lära sig på är att göra det själv!
- Markus Thiel
http://www.homeofsweden.se
http://www.mittyrke.se

jensie
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 09, 2007 11:34 am

Re: Installationsproblem!

Post by jensie » Fri Feb 09, 2007 12:14 pm

Mackelito wrote: Har du testat att ändra mappen och filen till 755 och 644?
Ledsen, vilket mapp talar vi om? Och filen, menar du config.php?

Tack!

jensie
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 09, 2007 11:34 am

Re: Installationsproblem!

Post by jensie » Fri Feb 09, 2007 12:15 pm

Ändrade, hela mappen till "777" dvs installations mappen. och nu funkar den!!

configuration.php  Writeable!!
Tack!

Men fortfarande har jag kvar:

Session save path  Unwriteable <-- Bara ett litet problem kvar ;)

User avatar
Mackelito
Joomla! Hero
Joomla! Hero
Posts: 2901
Joined: Tue Aug 23, 2005 12:14 pm
Location: Stockholm

Re: Installationsproblem!

Post by Mackelito » Fri Feb 09, 2007 12:16 pm

configuration.php      Unwriteable
You can still continue the install as the configuration will be displayed at the end, just copy & paste this and upload.
Session save path    Unwriteable
filen är configuration.php
mappen kan variera men troligen så heter den tmp och ligger i rooten
- Det bästa sättet att lära sig på är att göra det själv!
- Markus Thiel
http://www.homeofsweden.se
http://www.mittyrke.se

User avatar
Mackelito
Joomla! Hero
Joomla! Hero
Posts: 2901
Joined: Tue Aug 23, 2005 12:14 pm
Location: Stockholm

Re: Installationsproblem!

Post by Mackelito » Fri Feb 09, 2007 12:17 pm

Man ska akta sig för att sätta 777 då du ger hela världen tillgång att läsa/skriva/hacka den mappen... installations mappen måste du ändå ta bort efter installationen så det är väl lugnt men tänk på det i framtiden bara :)
- Det bästa sättet att lära sig på är att göra det själv!
- Markus Thiel
http://www.homeofsweden.se
http://www.mittyrke.se

jensie
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 09, 2007 11:34 am

Re: Installationsproblem!

Post by jensie » Fri Feb 09, 2007 12:19 pm

Mackelito wrote: Man ska akta sig för att sätta 777 då du ger hela världen tillgång att läsa/skriva/hacka den mappen... installations mappen måste du ändå ta bort efter installationen så det är väl lugnt men tänk på det i framtiden bara :)
Tack, ska ändra efter installationen...
Någon aning hur jag fixar:
Session save path      Unwriteable <-- Har det ngt med .htaccess att göra eller?

User avatar
Mackelito
Joomla! Hero
Joomla! Hero
Posts: 2901
Joined: Tue Aug 23, 2005 12:14 pm
Location: Stockholm

Re: Installationsproblem!

Post by Mackelito » Fri Feb 09, 2007 12:22 pm

Leta efter den mappen och sätt den till 755... Det ska stå vilken mapp det är.. troligen "tmp"
- Det bästa sättet att lära sig på är att göra det själv!
- Markus Thiel
http://www.homeofsweden.se
http://www.mittyrke.se

jensie
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 09, 2007 11:34 am

Re: Installationsproblem!

Post by jensie » Fri Feb 09, 2007 12:29 pm

Ledsen förstår verkligen inte vad du säger där.  :-[

Vilken mapp ska jag leta efter? Som jag ser finns det ingen /tmp/ där jag lagt installationen (sitter och stirrar på ftpn)
Har även kollat under mappar men ingen /tmp/

Jens

User avatar
Mackelito
Joomla! Hero
Joomla! Hero
Posts: 2901
Joined: Tue Aug 23, 2005 12:14 pm
Location: Stockholm

Re: Installationsproblem!

Post by Mackelito » Fri Feb 09, 2007 12:32 pm

Hos mig står det "Session save path:  /tmp"

men jag tror faktiskt inte att den måste vara skrivbar för att du ska kunna göra klart installationen!  :-\
- Det bästa sättet att lära sig på är att göra det själv!
- Markus Thiel
http://www.homeofsweden.se
http://www.mittyrke.se

jensie
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 09, 2007 11:34 am

Re: Installationsproblem!

Post by jensie » Fri Feb 09, 2007 12:38 pm

Mackelito wrote: Hos mig står det "Session save path:  /tmp"

men jag tror faktiskt inte att den måste vara skrivbar för att du ska kunna göra klart installationen!  :-\

OK, http://help.joomla.org/content/view/39/132/ så här antar jag det ser ut för dig?

Vet i fassen vad som är fel.. Kan nog vara ngt man måste ändra på servern? Om du ser ovan på mitt screenshot så är det annat för mig..
Har installerat den på en under domän http://www.mindomän.com/joomla/ kanske det påverkar ngt?

Tack iaf så långt :)

jensie
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 09, 2007 11:34 am

Re: Installationsproblem!

Post by jensie » Fri Feb 09, 2007 12:41 pm

Funkar nu! Vilket bra forum! riktigt snabb response!
Tack så jätte mycket, Mackelito!

MVH,
Jens

User avatar
Mackelito
Joomla! Hero
Joomla! Hero
Posts: 2901
Joined: Tue Aug 23, 2005 12:14 pm
Location: Stockholm

Re: Installationsproblem!

Post by Mackelito » Fri Feb 09, 2007 12:42 pm

aah va skönt att det löste sig :)
- Det bästa sättet att lära sig på är att göra det själv!
- Markus Thiel
http://www.homeofsweden.se
http://www.mittyrke.se

CrazyObbe
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Wed Feb 14, 2007 3:01 pm

Re: Installationsproblem!

Post by CrazyObbe » Wed Feb 14, 2007 3:12 pm

fel sorry...
Last edited by CrazyObbe on Wed Feb 14, 2007 7:10 pm, edited 1 time in total.


Locked

Return to “Installation, backup och säkerhet”