Inloggning till admin-gränssnittet fungerar inte

Diskutera frågor rörande installation, backup och säkerhet avseende Joomla! 1.0.

Moderators: Zello, chrille

Forum rules
Forumregler
Locked
licium
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Feb 06, 2007 9:59 am

Inloggning till admin-gränssnittet fungerar inte

Post by licium » Thu May 03, 2007 10:11 am

Hej! Ny i gänget och håller på att få spader.
Har precis installerat Joomla! och fått mina inloggningsuppgifter till Admin-gränssnittet. När jag använder dessa för att logga in får jag incorrect username/password.
Har ni sett detta förut? Vad beror det på? Hur löser man detta?  ???

Mvh
Lotta

 
User avatar
jonascw
Joomla! Explorer
Joomla! Explorer
Posts: 367
Joined: Fri Dec 29, 2006 12:09 pm
Location: Norway
Contact:

Re: Inloggning till admin-gränssnittet fungerar inte

Post by jonascw » Thu May 03, 2007 10:17 am

Hej,

Hur installerade du Joomla?

Har du checkat stora/små bokstäver och om du har "caps lock" på?

licium
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Feb 06, 2007 9:59 am

Re: Inloggning till admin-gränssnittet fungerar inte

Post by licium » Thu May 03, 2007 10:21 am

Jag körde via webbläsaren, ett antal steg i en guide.

Och nej, Caps Lock är inte på - det har jag kollat  ;)

User avatar
vendelberg
Joomla! Ace
Joomla! Ace
Posts: 1662
Joined: Sat Aug 20, 2005 6:56 pm
Location: Vendel/Örbyhus
Contact:

Re: Inloggning till admin-gränssnittet fungerar inte

Post by vendelberg » Thu May 03, 2007 10:30 am

Hej
I värsta fall kan du gå in i databasen och ändra, men du gör det på egen risk!!!
i tabellen jos_users kan du sätta lösen ordet till:
200ceb26807d6bf99fd6f4f0d1ca54d4
då blir det administrator som lösenord

//Mia
Man lär så länge man har elever
* Glöm inte att markera ditt första inlägg i tråden som LÖST (den gröna bocken) när du anser att du fått tillräcklig hjälp! *

www.joomlaakuten.se

licium
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Feb 06, 2007 9:59 am

Re: Inloggning till admin-gränssnittet fungerar inte

Post by licium » Thu May 03, 2007 11:25 am

Tack Mia,
testade detta och nu får jag inget felmeddelande längre men jag lyckas ändå inte logga in. När jag klickar på Login visas en sida mycket hastigt med text och sedan visas inloggningssidan igen. Hur får man fram texten på den sida som visas så snabbt? Antar att den kan innehålla en del intressant information...

User avatar
vendelberg
Joomla! Ace
Joomla! Ace
Posts: 1662
Joined: Sat Aug 20, 2005 6:56 pm
Location: Vendel/Örbyhus
Contact:

Re: Inloggning till admin-gränssnittet fungerar inte

Post by vendelberg » Thu May 03, 2007 11:29 am

Hej
Har du kollat att session_save.path är skrivbar? detta fenomen kan uppträda då om den inte är skrivbar.
Tror att det är webbhotellet som måste fixa det isåfall, är inte 100
Du skulle egentligen installera scriptet som kollar dina förutsättningar för installation. Då ser man ifall session är skyddad eller ej.

Skriptet hittar du en länk till under min tråd /allmänna frågor /nybörjare

Annars kolla med ditt hotell direkt//mia
Man lär så länge man har elever
* Glöm inte att markera ditt första inlägg i tråden som LÖST (den gröna bocken) när du anser att du fått tillräcklig hjälp! *

www.joomlaakuten.se

licium
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Feb 06, 2007 9:59 am

Re: Inloggning till admin-gränssnittet fungerar inte

Post by licium » Thu May 03, 2007 11:34 am

Tror faktiskt inte den är skrivbar. Hur ändrar man det? Jag har möjlighet att göra det själv.

User avatar
vendelberg
Joomla! Ace
Joomla! Ace
Posts: 1662
Joined: Sat Aug 20, 2005 6:56 pm
Location: Vendel/Örbyhus
Contact:

Re: Inloggning till admin-gränssnittet fungerar inte

Post by vendelberg » Thu May 03, 2007 11:36 am

Hej igen
Sätt chmode till 644, nu ska jag iväg så du får testa lite  ;)
Jag hade iallafall det problemet när jag inte kunde logga in men då fixade webhotellet det åt mig.
Lycka till //Mia
Man lär så länge man har elever
* Glöm inte att markera ditt första inlägg i tråden som LÖST (den gröna bocken) när du anser att du fått tillräcklig hjälp! *

www.joomlaakuten.se

licium
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Feb 06, 2007 9:59 am

Re: Inloggning till admin-gränssnittet fungerar inte

Post by licium » Thu May 03, 2007 11:59 am

Har letat som en galning. Var var var sätter man chmode till 644? Har kollat med skriptet Mia tipsade om och save.session_path är mycket riktigt unwritable. Får ju en massa bra info men jag fattar inte var man ändrar för att rätta till det.

Känner mig en anings dum....  :-[

licium
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Feb 06, 2007 9:59 am

Re: Inloggning till admin-gränssnittet fungerar inte

Post by licium » Thu May 03, 2007 12:29 pm

Problemet löst! Tack för all hjälp.

//Lotta

User avatar
vendelberg
Joomla! Ace
Joomla! Ace
Posts: 1662
Joined: Sat Aug 20, 2005 6:56 pm
Location: Vendel/Örbyhus
Contact:

Re: Inloggning till admin-gränssnittet fungerar inte

Post by vendelberg » Thu May 03, 2007 2:40 pm

Hej
du behöver absolut inte känna dig dum! Alla är vi nya nångång. Du kan ju berätta för alla andra (och mig) vad som löste dina problem?
Nu är det bara att joomla på då  :laugh:
Man lär så länge man har elever
* Glöm inte att markera ditt första inlägg i tråden som LÖST (den gröna bocken) när du anser att du fått tillräcklig hjälp! *

www.joomlaakuten.se

licium
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Feb 06, 2007 9:59 am

Re: Inloggning till admin-gränssnittet fungerar inte

Post by licium » Fri May 04, 2007 8:00 am

Det som löste det hela var att jag upptäckte att save.session_path var satt till d:\Temp\php\unload och att det inte ens fanns en sån katalog på servern. Genom att skapa en sån och sätta den som writable fungerade inloggningen. Så jag har bytt lösenord nu :)

Så nu ska jag "bara" få till ett utseende som jag gillar...

User avatar
icebear
Joomla! Guru
Joomla! Guru
Posts: 662
Joined: Wed Oct 26, 2005 9:14 pm
Location: Sweden

Re: Inloggning till admin-gränssnittet fungerar inte (Löst)

Post by icebear » Sun Sep 02, 2007 4:12 pm

author=vendelberg link=topic=166237.msg798792#msg798792 date=1178188230]
I värsta fall kan du gå in i databasen och ändra, men du gör det på egen risk!!!
i tabellen jos_users kan du sätta lösen ordet till:
200ceb26807d6bf99fd6f4f0d1ca54d4
då blir det administrator som lösenord
På en äldre installation heter väl tabellen mos_users antar jag ?! (Mambo 4521)
Jag gick in där och kollade, men vart ska man lägga in dina nuffror ? (se bifogade skärmdumpar)
Hittar inget fält för password som verkar logiskt att använda...
Och funkar samma nuffror på en mambo 4521 ?

Löst! och det funkade på Mambo 4521 också :)
Se skärmdump 3
You do not have the required permissions to view the files attached to this post.
Last edited by icebear on Sun Sep 02, 2007 4:58 pm, edited 1 time in total.

 

Locked

Return to “Installation, backup och säkerhet”