Problem med installationer av modules,languages osv.

Diskutera frågor rörande installation, backup och säkerhet avseende Joomla! 1.0.

Moderators: Zello, chrille

Forum rules
Forumregler
Locked
bjarne
Joomla! Explorer
Joomla! Explorer
Posts: 269
Joined: Thu Nov 17, 2005 11:48 pm

Problem med installationer av modules,languages osv.

Post by bjarne » Fri Nov 18, 2005 7:10 pm

Hej hopp

Konverterade nyss från mambo 4.5.2.3  till joomla 1.0.3. Fick en del problem därefter med att installera språk, modules m.m. :-)

Någon idé om hur det löses?

_______
Warning: move_uploaded_file(): open_basedir restriction in effect. File(/home2/bjarne11/public_html/media/Frontend_Swedish.zip) is not within the allowed path(s): (/home/bjarne11/:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/bjarne11/public_html/administrator/components/com_installer/admin.installer.php on line 175
_______

User avatar
LorenzoG
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3010
Joined: Fri Aug 19, 2005 8:46 am
Location: Stockholm, Sweden

Re: Problem med installationer av modules,languages osv.

Post by LorenzoG » Sat Nov 19, 2005 7:24 am

Hej och välkommen!  :)

Vilket webhotell använder du? Det här låter som ett safemode problem.

bjarne
Joomla! Explorer
Joomla! Explorer
Posts: 269
Joined: Thu Nov 17, 2005 11:48 pm

Re: Problem med installationer av modules,languages osv.

Post by bjarne » Sat Nov 19, 2005 3:06 pm

Hej och tack.

Safemode är lika med off. 

Nu har jag inte sysslat alltför mycket med PHP tidigare, men jag tolkar meddelandet som att PHP-inställningarna inte tillåter att systemet flyttar filer till "../public_html/media/"  pga. att den mappen inte finns upptagen i "open_basedir".  Men jag har mailat webhotellet och bett dom fixa detta.

Ett alternativ är ju att i joomlas PHP-filer ändra samtliga hänvisningar från /media till tex. /tmp.  Men det verkar vara lite krångligt att leta efter alla hänvisningar i koden :-)

Wehotellet jag använder är inmedialis.com.
______
Relevant PHP Settings: 
Safe Mode: OFF
Open basedir: /home/bjarne11/:/usr/lib/php:/usr/local/lib/php:/tmp
______

Mvh

Bjarne

bjarne
Joomla! Explorer
Joomla! Explorer
Posts: 269
Joined: Thu Nov 17, 2005 11:48 pm

Re: Problem med installationer av modules,languages osv.

Post by bjarne » Sat Nov 19, 2005 5:20 pm

Hmm

Vänta nu?  Varför använder Joomla "/home2/.." När den skall lägga upp filen, när övriga system verkar ligga under "/home/"?

Warning: move_uploaded_file(): open_basedir restriction in effect. File(/home2/bjarne11/public_html/media/com_akocomment20.zip) is not within the allowed path(s): (/home/bjarne11/:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/bjarne11/public_html/administrator/components/com_installer/admin.installer.php on line 175

User avatar
LorenzoG
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3010
Joined: Fri Aug 19, 2005 8:46 am
Location: Stockholm, Sweden

Re: Problem med installationer av modules,languages osv.

Post by LorenzoG » Sat Nov 19, 2005 5:33 pm

Felmeddelandet, så vitt jag förstår är att den försöker komma åt/skriva/läsa i ett område där den inte har tillåtelse.

bjarne
Joomla! Explorer
Joomla! Explorer
Posts: 269
Joined: Thu Nov 17, 2005 11:48 pm

Re: Problem med installationer av modules,languages osv.

Post by bjarne » Sat Nov 19, 2005 5:42 pm

Jo, det står ju helt klart. Men frågan är varför Joomla försöker lägga upp den i ett område som inte existerar dvs. home2/...

Ta bort 2:an efter home så skall ju allt bli rätt...


Mvh
Bjarne

bjarne
Joomla! Explorer
Joomla! Explorer
Posts: 269
Joined: Thu Nov 17, 2005 11:48 pm

Re: Problem med installationer av modules,languages osv.

Post by bjarne » Sat Nov 19, 2005 5:52 pm

Tjohoo

Ändrade manuellt i "configuration.php" Raderade 2:an i sökvägen och allt löste sig. Frågan är hur den sökvägen kom dit från början?

Mvh

Bjarne

***** Manual signatures are NOT allowed *****_
$mosConfig_absolute_path = '/home/bjarne11/public_html';
$mosConfig_allowUserRegistration = '0';
$mosConfig_back_button = '1';
$mosConfig_cachepath = '/home/bjarne11/public_html/cache';


Locked

Return to “Installation, backup och säkerhet”