problem vid flytt från "lokalt" till "webhotell"

Diskutera frågor rörande installation, backup och säkerhet avseende Joomla! 1.0.

Moderators: Zello, chrille

Forum rules
Forumregler
Locked
gasko
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 11, 2006 11:37 am

problem vid flytt från "lokalt" till "webhotell"

Post by gasko » Tue Sep 26, 2006 3:39 pm

Har skaffat en webplats på "one.com" och tänkte lägga upp min joomla-sajt.

Har följt guiden på http://www.mamboinfo.com/index.php?opti ... &Itemid=50

Men när jag ska ladda upp databasfilen till webhotellets SQL-server får jag felet:
----------------------------
Fel

SQL-fråga :

CREATE TABLE `mono_banner` (
`bid` int( 11 ) NOT NULL AUTO_INCREMENT ,
`cid` int( 11 ) NOT NULL default '0',
`type` varchar( 10 ) NOT NULL default 'banner',
`name` varchar( 50 ) NOT NULL default '',
`imptotal` int( 11 ) NOT NULL default '0',
`impmade` int( 11 ) NOT NULL default '0',
`clicks` int( 11 ) NOT NULL default '0',
`imageurl` varchar( 100 ) NOT NULL default '',
`clickurl` varchar( 200 ) NOT NULL default '',
`date` datetime default NULL ,
`showBanner` tinyint( 1 ) NOT NULL default '0',
`checked_out` tinyint( 1 ) NOT NULL default '0',
`checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00',
`editor` varchar( 50 ) default NULL ,
`custombannercode` text,
PRIMARY KEY ( `bid` ) ,
KEY `viewbanner` ( `showBanner` )
)ENGINE = MYISAM DEFAULT CHARSET = latin1 AUTO_INCREMENT =3

MySQL sa:
#1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1 AUTO_INCREMENT=3' at line 19
------------------------

vad ska jag göra för att lösa detta?

User avatar
LorenzoG
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3010
Joined: Fri Aug 19, 2005 8:46 am
Location: Stockholm, Sweden

Re: problem vid flytt från "lokalt" till "webhotell"

Post by LorenzoG » Wed Sep 27, 2006 12:10 pm

Hej!

Av någon anledning så stödjer inte den versionen av phpMyAdmin som finns installerat hos one.com charset definitioner och kollationering.

Det du kan göra är att ta bort "CHARSET = latin1"  i sista raden och då kommer den att skapa tabellen.

Förövrigt så har one.com satt safemode on på sina servrar, vilket gör att joomla kan bli bökigare att använda.

gasko
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 11, 2006 11:37 am

Re: problem vid flytt från "lokalt" till "webhotell"

Post by gasko » Wed Sep 27, 2006 8:04 pm

Tack för svaret!

Ska försöka att se om det funkar imorgon då jag har tillgång till datorn som sidan ligger lokalt på.

Men du säger att det kan bli bökigare att använda joomla då one.com har safemode on. Vad är det då för problem jag kommer att stöta på. Finns det saker jag inte kan göra pga detta eller blir det helt enkelt bara som du säger lite bökigare?

User avatar
vendelberg
Joomla! Ace
Joomla! Ace
Posts: 1662
Joined: Sat Aug 20, 2005 6:56 pm
Location: Vendel/Örbyhus
Contact:

Re: problem vid flytt från "lokalt" till "webhotell"

Post by vendelberg » Sun Oct 08, 2006 1:34 pm

Hej
Här kan du läsa tidigare inlägg angående olika hotell
http://forum.joomla.org/index.php/topic,9402.0.html
//Mia
Man lär så länge man har elever
* Glöm inte att markera ditt första inlägg i tråden som LÖST (den gröna bocken) när du anser att du fått tillräcklig hjälp! *

www.joomlaakuten.se


Locked

Return to “Installation, backup och säkerhet”