Page 3 of 6

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Sun Feb 24, 2008 4:02 am
by baxao
Fishaholics wrote:My problem SOLVED
Somhow I had deleted the cgi-bin/tmp file :o
So all I needed to do was create a new cgi-bin/tmp file and that solved it
Sorry to trouble you all :'(
I will leave this post up incase it helps someone else that it as stupid as I am.
I am having the same problem after upgrading from 1.012 to 1.015. My cgi-bin folder is empty. What should be in cgi-bin beside folder temp? Thanks.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Mon Feb 25, 2008 6:04 pm
by sali40
tim carey wrote:Updated to 1.0.15 and no change, still not able to login.
Same here.
Both 1.0.12 -> 1.0.14 and 1.0.12 ->1.0.15 give the same result: no front-end login.
The more, upgrading to 1.0.15, I cannot, for example, uninstall any of the templates I don't use because I get a message saying that I don't have the permissions.
Yet joomla!xplorer says that I'm the owner of all files (664) and folders (775) in the webspace .

Rolling back to 0.12 again :-\

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Feb 26, 2008 12:05 am
by tankochan
It's really weird. I upgraded from 1.0.13 to 1.0.15 and had no problems, except for Community Builder login. Now I and the users can't login from frontend. ???

The core login works fine but I can't understand what's wrong with CB login since the upgrade wasn't supposed to affect login and components. I'm no programmer, can't figure out what's wrong. :(

Please help me if possible!

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Feb 26, 2008 12:16 am
by brad
tankochan wrote:It's really weird. I upgraded from 1.0.13 to 1.0.15 and had no problems, except for Community Builder login. Now I and the users can't login from frontend. ???

The core login works fine but I can't understand what's wrong with CB login since the upgrade wasn't supposed to affect login and components. I'm no programmer, can't figure out what's wrong. :(

Please help me if possible!
Have you asked the CB developers on their forum? Please do not take this thread off topic.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Feb 26, 2008 12:40 am
by t-readyroc

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Feb 26, 2008 7:18 am
by sali40
sali40 wrote:
tim carey wrote:Updated to 1.0.15 and no change, still not able to login.
Same here.
Both 1.0.12 -> 1.0.14 and 1.0.12 ->1.0.15 give the same result: no front-end login.
The more, upgrading to 1.0.15, I cannot, for example, uninstall any of the templates I don't use because I get a message saying that I don't have the permissions.
Yet joomla!xplorer says that I'm the owner of all files (664) and folders (775) in the webspace .

Rolling back to 0.12 again :-\
UPDATE: I've tried using a full 1.0.15 package and overwriting the whole core. No changes :(

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Feb 26, 2008 11:39 am
by acad
Dear Sali40,

Do you use CB? Version? If not upgraded too, may cause login problems as notetd above!

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Feb 26, 2008 12:40 pm
by mephistophele
i too have the same problem with deleting templates... i have the message of "no permissions" to do that...

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Feb 26, 2008 1:26 pm
by meaculpa
You can still delete/change files via FTP/SSH.
I think it's more urgent for the developers - or at the meantime anybody to give us a solution to this nasty: "No login to frontend after upgrade bug". Hasn't 1.0.15 not been tested before the release?
I'm waiting and in the meantime I think I have to downgrade my sites again, at least to have a working system.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Feb 26, 2008 2:12 pm
by opadilla85
After upgrade from 1.0.14 to 1.0.15 backend login issue persist, when i try to login get in the url next message:
http://www.deaquisoy.ws/cms/administrat ... %20Expired

And the url issue that change url from http://www.deaquisoy.ws to deaquisoy.ws havent besolved

Any ideas about solving this problem?

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Wed Feb 27, 2008 10:27 am
by boris1000
Hi Together,

i found out when this bug happens (Joomla 1.0.14). I created an account called "test" with pw "111111". No-Login Problem in frontend. My other accounts (also the super admin) are not able to login into frontend. I gave my "test" account the manager status. As long as I don't log in into backend with this account, my frontend login works. First time I logged into backend with "test" and then trying to log into frontend, I get the Message "Username or paasword are incorrect".
After that I have to re-type the password in backends' user-managemant, then it works! (but only as long as I don't log into backend with this account!!!).
I don't know why this is like this, but it seems to have something to with front- and backend login with the same account. Best solution for now is to have two different accounts, one for backend, and one for frontend.

Tell me if some of you have the same experience....

CU
Boris

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Wed Feb 27, 2008 10:04 pm
by dc41
Upgraded from 1.0.13 to 15 and VirtueMart 1.0.13 to 14. We were having sporadic frontend login problems. But only with the VirtueMart module login. I published and used the mod_login, the login problem went away. I haven't checked to see if there's a solution at virtuemart.org yet.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Sat Mar 01, 2008 8:19 pm
by iberti
Hi *,

The password with the 1.0.12 is in this format

Code: Select all

ed58988d94c721e02193393a1d622bc1
the version 1.0.13 is in this format

Code: Select all

7372ea9db13cfa1ac46c1b030a2cbc34:voqAFMsM0gId30OM
Now after upgrade when you is a new memeber the password is like in v.0.12 and then when you ask for your password from the frontend with the "Forget the password" function the passwrod change in v.0.13 format.

Now I think the problem is there.

sorry for my bad English.

Regards,
Berti

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Sun Mar 02, 2008 6:49 pm
by baxao
I could not login after upgrading. I got it fixed after following the instruction in this link:
http://forum.joomla.org/viewtopic.php?f ... 5#p1218225

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Mon Mar 03, 2008 8:40 pm
by sali40
I don't know whether this could be usefull, but everything get right overwriting joomla.php with the old one (from 1.0.12).

Weird is that every menu item which should have been reserved to registered users, gets visible to everyone. Related pages are acessible only to registered, though

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Mar 04, 2008 10:07 am
by Elephantman
For cross linking reasons and to follow the correct procedure, i've posted a bug tracker item related to this issue here http://joomlacode.org/gf/project/joomla ... m_id=10031

The description of my problem and the error I get is in the tracker item.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Mar 04, 2008 10:36 am
by masterchief
Can anyone experiencing problems turn their Error Reporting setting in Global Configuration to Maximum and see if an error is generated. If you can't login, the manually change the configuration.php, change the setting:

$mosConfig_error_reporting = 2047;

Try to log in. See if you get an error - then change it back to what it was.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Wed Mar 05, 2008 1:25 pm
by sali40
masterchief wrote:Can anyone experiencing problems turn their Error Reporting setting in Global Configuration to Maximum and see if an error is generated. If you can't login, the manually change the configuration.php, change the setting:

$mosConfig_error_reporting = 2047;

Try to log in. See if you get an error - then change it back to what it was.
Done and ... no error

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Wed Mar 05, 2008 4:30 pm
by skyliner2
Done, still get the same Error Message. Can't login. No permission to view the Page... :(

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Fri Mar 07, 2008 4:51 pm
by Elephantman
You need to also disactivate javascript to get complete error reporting on this issue as the alert blocks you from accessing the error page.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Fri Mar 07, 2008 6:11 pm
by skyliner2
Well, I'll try that. But what could the Error page tell me? How to fix the bug? Hm, I don't beleave this seriously... ???

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Mon Mar 10, 2008 1:37 pm
by p_petrelli
@skyliner: it may help the developers, iff there is still anyone around to actually investigate. Which I seriously doubt, judging from the lack of communications both here and in the bug tracker entry.

I have a site that I desparately need to update from its current 1.0.11, but I am *really* afraid to do so until someone can least provide a hypothesis on what's going on with this problem.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Mon Mar 10, 2008 7:19 pm
by jaz
I too have the problem where frontend <site>/index.php?option=com_login produces:
You are not authorised to view this resource.
You need to login.
Of two sites I recently setup last week, one was natively 1.0.15 and the other 1.0.14. The 1.0.15 doesn't show this problem.

The 1.0.14 site had this problem from the start, and still has it when clobbered by the 14->15 upgrade bundle. Problem is present both on my local Apache Friends' xampp on win32 (Apache2 w/ PHP 5.2.3), and when moved to my Linux hosted account.

In both places I have 50+ sites on 1.0.13 and below, none (or few) of which ever saw this problem.

The native 1.0.15 works fine in both places.

Still no change when I clobber the 14-upgraded-to-15 instance with a full-stable-1.0.15 package. No joy from editing joomla.php file ($validate ... (int)$my->id , jos_user/password is varchar(100), multiple browsers, have cleared cache & cookies... Still can't login on frontend.

So it seems to me that perhaps the problem exists in the database. Did 1.0.14 database creation do something wonky? or did a 14 script check the version and if <1.0.14 then do something inside the DB?

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Sat Mar 15, 2008 11:19 am
by amorosso
very strange, why are we all having this issue. I use oprea most of the time and really only use IE 7 just to see how my page looks. Then I realized that I have the log in issue only with IE, flawless login with Oprea. IE wouldn't work last night, but first thing this morning I checked it and it worked fine. Humm, I don't get it. The strange thing is that when it wont login it just returns me to the same page with no errors but shows in the back end that, that user is loged in. As soon I as I figure this out I will post it right up here. Do you think sessions could be doing this.. ??

Dominick

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Mon Mar 17, 2008 5:32 pm
by boofka_99
I found a possible solution that may hopefully will help some people:

I was having the same problem with a fresh site and fresh install of Joomla 1.0.15 (no CB): I could not log in to the front-end of the site.

After thinking this was a definitely a Joomla version issue, the clue I found was that when I turned of sef urls (3rd party and core sef) and just used the default urls, I was able to login. Then only turning on core Joomla sef caused things to bugger up.

I began checking the htaccess file for clues. Long story short, here is something that everyone should check:

If you have added the redirect htaccess code to prevent duplicate urls so that it redirects the "yourdomain.com" version of your domain to the "www.yourdomain.com" version of your domain,

Code: Select all

 RewriteEngine On
RewriteCond %{HTTP_HOST} ^yoursite\.com$ [NC]
RewriteRule ^(.*)$ http://www.yoursite.com/$1 [R=301,L]
then you will also want to check what your the value of your $mosConfig_live_site to make sure that it is also "www.yourdomain.com" and not "yourdomain.com". Surprised at myself, I had "http://yourdomain.com" in my config file when http://www.yourdomain.com is my prefered domain (I never do that). The result was that everytime I logged into the front-end of the site, the joomla script naturally would redirect to whatever $mosConfig_live_site was, and then htaccess would redirect to my preferred domain and the site would think that I never logged in.

Hope this helps.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Mon Mar 17, 2008 9:45 pm
by p_petrelli
boofka, if you undo this change, can you verify that you're really seeing the same error that's reported in the bug tracker entry (i.e. variable $my being unset)?

The reason I'm asking is that none of the solutions that people have posted (adding a cast, changing a db column, using a different browser) make sense to me as to explaining why an imporant global variable can be unset.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Mar 18, 2008 1:01 am
by boofka_99
p_petrelli, I am indeed seeing the $my variable getting unset due to the situation I described earlier. When I changed the $mosConfig_live_site in the configuration.php file back to not having the "www", the $my variable shows to be unset because of the htaccess redirection to http://www.yourdomain.com.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Mar 18, 2008 11:02 am
by p_petrelli
thanks for the verification! I'm still going to wait for a couple more days until I take the plunge, but I'm fairly certain that you've hit the spot regarding this bug.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Mar 18, 2008 11:15 am
by Elephantman
Although I have an url without www, I have no .htaccess running so I dont think there can be a redirection messup here.

Re: [UNDER REVIEW] can't login to front-end after 1.0.13 to 1.0.

Posted: Tue Mar 18, 2008 2:02 pm
by jaz
My problematic 1.0.14-->15 site doesn't use "www"**, nor am I using SEF. Problem persists with and without default .htaccess. When I turn on/off SEF, no change. No 3rd-party SEF component installed yet.

In this particular case, my site is running both on my laptop as h++p://local:3099 and on a hosted server as h++p://<actualdomain>.org, exhibiting the login problem in both places. (My many other sites get developed in the same two places.)

(Again, this is the only of my recent sites that has shown the bug, and it's also the only one I've installed as originally as 1.0.14 -- so I still kinda suspect that for 1.0.14 there's a session problem related to database creation)

I'd imagine that throughout the 1.0.x versions there have been several root causes that have caused this error when landing on the login component from the frontend.

(**I sometimes omit the www -- seems obsolete. In these cases I figure that if somebody assumes www then let DNS redirect them to non-www. Unless of course the domain/site owner is nostalgic.)

Jaz