1.0.15 invalid session at admin login

Locked
micronaut
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Tue Jul 18, 2006 12:52 pm
Location: UK

1.0.15 invalid session at admin login

Post by micronaut » Sat Apr 12, 2008 5:10 pm

Hi,

Is there a fix for the 1.0.15 administrator login screen reporting an "invalid session" error?

I have tried to follow a number of forum threads for previous versions of Joomla with this error but had not luck with 1.0.15.

Thanks for any assistance.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 21964
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: 1.0.15 invalid session at admin login

Post by pe7er » Sat Apr 12, 2008 5:34 pm

{MOD note: moved to 1.0 Q&T]
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-founder of data2.eu GDPR Tool https://data2.eu/en/gdpr-tool

daantje
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Jul 28, 2006 8:46 pm
Location: oostende
Contact:

Re: 1.0.15 invalid session at admin login

Post by daantje » Sat Jun 28, 2008 9:27 pm

I found a solution that worked for me. Go to your php.ini file (mostly it's somewhere in /etc). Make sure you have "session.auto_start = 0" (by default this value = 1).

User avatar
mcoblentz
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Mar 09, 2008 1:04 am
Location: Bay Area, California
Contact:

Re: 1.0.15 invalid session at admin login

Post by mcoblentz » Wed Jul 02, 2008 12:14 am

Where would the /etc folder be, exactly? I don't think it's in the Joomla installation and since I'm on a hosted solution, I can't see a /etc directory in my path. What would I be looking for?

Thanks.
I'll try anything once; twice if I like it.

User avatar
farmerdon
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Thu Oct 18, 2007 10:35 pm
Location: Cork
Contact:

Re: 1.0.15 invalid session at admin login

Post by farmerdon » Wed Jul 02, 2008 1:34 pm

Have a look at this thread:
http://forum.joomla.org/viewtopic.php?f ... a&start=60

It should help you.

Regards,

Donald

daantje
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Jul 28, 2006 8:46 pm
Location: oostende
Contact:

Re: 1.0.15 invalid session at admin login

Post by daantje » Wed Jul 02, 2008 4:32 pm

farmerdon wrote:Have a look at this thread:
http://forum.joomla.org/viewtopic.php?f ... a&start=60

It should help you.

Regards,

Donald
this didn't work for me.
mcoblentz wrote:Where would the /etc folder be, exactly? I don't think it's in the Joomla installation and since I'm on a hosted solution, I can't see a /etc directory in my path. What would I be looking for?

Thanks.
The /etc file is not in your root directory. It's possible that your provider doesn't grant access to it. In that case you can ask him to adapt the php.ini file.

Otherwise I would try to login to your site with an ftp program (filezilla) and click on the ".." If you have access to the other directories they should be visible now. In general the "/etc" directory is one ore two levels below the root.

for instance: your root = var/html, then then the /etc directory is in /etc (same level as the "var")

User avatar
mcoblentz
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Mar 09, 2008 1:04 am
Location: Bay Area, California
Contact:

Re: 1.0.15 invalid session at admin login

Post by mcoblentz » Thu Jul 03, 2008 1:04 am

Thanks. I opened a ticket with my provider and found:

That there is an admin screen I can use via VDeck to access the php.ini file and make changes. Very nice of them. Second, they took a look and suggested both setting for register globals and they also noticed there was no setting for php sessions. I will adjust those. Note to all: check with your provider about the php.ini file. They can probably help you - most shared hosting providers do not allow SSH access or other major access like this and they are used to these kinds of questions. I should have asked them earlier.

I was able to get the 1.01.5 invalid session error to go away, eventually. I'm not completely sure what did the trick. By the time the error went away, I had: created an entire second instance (which I will now use for testing) that captures it's own sessions locally (folder in the joomla directory based on another thread http://forum.joomla.org/viewtopic.php?f ... &sk=t&sd=a here in this forum) and reset the permissions on the original installation (production) to 777 temporarily so that I could get a valid login. I think it may have been something about loading the administration/index.php file during login that was causing some sort of problem. I had completely reinstalled joomla at a 1.0.15 level, including the installation directories, and attempted to login as clean installation. This of course bombed at the database part of the installation wizard, at which point I could simply reload the old configuration.php file and go on my merry way.

If you try this trick (permission settings), remember to set everything back to 755 and then go into administration (within Joomla), navigate to the global configurations control panel and set the configuration.php file to unwriteable. (I think that's 644 for you FTP wizards). Oh, and uninstall the Installation directories. You don't want those lying around.

At this point, I seriously need a backup and I'm working on that. But my access problem is solved, and I also have an upgraded Joomla installation and a second operation to use for testing. I never thought I would have to follow enterprise level techniques, but they sure come in handy.

Maybe I should write a backup section for the Joomla docs.
Last edited by mcoblentz on Thu Jul 03, 2008 5:27 pm, edited 1 time in total.
I'll try anything once; twice if I like it.

daantje
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Jul 28, 2006 8:46 pm
Location: oostende
Contact:

Re: 1.0.15 invalid session at admin login

Post by daantje » Thu Jul 03, 2008 7:10 am

Good that you could work it out.

The register Globals sett
daantje wrote:they took a look and suggested both setting for register globals and they also noticed there was no setting for php sessions. I will adjust those.
The register Globals should be set to "off" because of security reasons. (has notting to do with the session problem)
To me the php "session.auto_start = 0" did the trick.

I think the solution to write your sessions in a folder in your root directory is good when the /tmp directory, where sessions are stored by default, isn't writable.

In my case with my provider this was ok. The only thing I changed to make things work is the "session.auto_start" setting in php.ini.

This sessions issue is a big problem for Joomla 1.15
I have some Joomla experience (I have about 15 Joomla sites running, but this session error took me several hours to find a solution.

User avatar
mcoblentz
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Mar 09, 2008 1:04 am
Location: Bay Area, California
Contact:

Re: 1.0.15 invalid session at admin login

Post by mcoblentz » Thu Jul 03, 2008 5:14 pm

Ah, good point. Your comment,
I think the solution to write your sessions in a folder in your root directory is good when the /tmp directory, where sessions are stored by default, isn't writable.
tells me that now I should go back and take out the "self-caching" of sessions in the local directory - I have added the sessions path to the php.ini file.

Note to all: While you could leave this local caching technique in place, there is no guarantee that this would not interfere will future upgrades to Joomla. If you can, stay as close as possible to the standard Joomla! approach.

And I checked that

Code: Select all

register_globals = Off
was indeed set; Off is apparently the default value with this provider.

And I checked on

Code: Select all

session.auto_start = 0
(again, their default setting) - I guess I just had some other problem.
I'll try anything once; twice if I like it.

carlosrojas
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Mar 06, 2009 12:57 am

Re: 1.0.15 invalid session at admin login

Post by carlosrojas » Sat Mar 07, 2009 11:37 pm

Hi. I Solved the problem doing the next changes:

1. Clear the session on the database, table jos_sessions on my case.

2. Clear cookies, session, temporary files of the Browser(Firefox, Safari, IE).

3. Create a new folder in my joomla Dir "EX: /public_html/joomla/sessions" assign Permiss 777 ("Ex: chmod 777").

4. Found the configuration.php of my joomla. "EX: /public_html/joomla/configuration.php" and download and view.

4.1. found the variable $mosConfig_absolute_path = '(depend of the server)/public_html/joomla'; and copy the value of the variable.

5. Search the php.ini on youServer.

5.1. Found the variable session.save.path = ""

5.2. Change the value with the value of the $mosConfig_absolute_path.

session.save.path= "(depend of the server)/public_html/joomla/sessions"
NOTE: i added to the end the sessions folder that i create in step 3.

5.3 Save & Close

6. Try Again and Good Luck :D


Locked

Return to “Joomla! 1.0.x_Q&T”