Submenu items not showing

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Forum rules
Forum Rules
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
hamburg113
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Apr 25, 2011 1:33 am

Re: Submenu items not showing

Post by hamburg113 » Sat May 14, 2011 2:39 am

hamburg113 wrote:Hi,

Thanks very much for this comment. It help me to think about my ideals.

Tks again and pls keep posting.
If you want to get more materials that related to this topic, you can visit: Project management templates

Best regards.

whiteshadow
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Mar 19, 2011 6:56 pm

Re: Submenu items not showing

Post by whiteshadow » Sat Jun 11, 2011 1:32 am

can some one tell me where i can find the code for the main menu and the code that specifies the levels. my problem is that the template seem to only show up to 2 sub-level in menus the third becomes a parent menu. http://www.unitedprice.com

smemilyanne
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Jun 25, 2011 12:04 am

Re: Submenu items not showing

Post by smemilyanne » Sat Jun 25, 2011 12:30 am

.. moved to appropriate forum..

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Submenu items not showing

Post by mcsmom » Mon Jun 27, 2011 8:28 am

Go to the module manager and change the number of levels you are displaying. You can delete or unpublish the second copy of the menu if you don't want it.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

User avatar
AshrafSello
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 21, 2010 1:46 am
Location: Cairo, Egypt
Contact:

Re: Submenu items not showing

Post by AshrafSello » Sun Aug 14, 2011 3:26 am

Please try the solution shown in this post by me

http://forum.joomla.org/viewtopic.php?f=199&t=645412

I hope it helps.

Wish you all the best.
=============
Ashraf Hamdy Sello
Cairo, Egypt
http://www.EgyptShop.com

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 563
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: Submenu items not showing

Post by Kampp » Tue Dec 20, 2011 1:37 pm

My problem seem to have happended after migration from Joomla 1.0.x.

It works with SEF ON

My solution was the following:
Open the toplevel menuitems with submenuitems in them. "Change" the menu item type to the same as before. Also I had to make sure that there was not used a - in the alias.
If need you could change to a completly different menu item type and change it back.

I did not change the module settings so that submenu is shown all the time.

My site was:
Joomla 1.5.25 (same error at 1.5.22)
Menu type: Legasy - Vertical
Cache: No
SEF: Yes (and keept on!)
http://www.toolmaster.dk - Danish Joomla Services!

webmyrtle
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Jan 15, 2012 7:29 pm

Re: Submenu items not showing

Post by webmyrtle » Sun Jan 15, 2012 7:34 pm

I have learned that when system cache is enabled, submenu items do not apear when the top menu itme is clicked. Disabling system cache resolves the problem.

prashantb423
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Mon May 14, 2012 5:45 am

Re: Submenu items not showing

Post by prashantb423 » Mon Jul 23, 2012 6:24 am

Sub menus are showing in Main menu when Cache is disabled for the site.

zainabsb88
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Oct 28, 2012 2:06 pm

Re: Submenu items not showing

Post by zainabsb88 » Sun Oct 28, 2012 2:47 pm

i am having a website www.superwebcreators.com.
In that earlier submenu were showing but it stopped suddenly.
I tried disabling SEF, Cache and adding extended menu plugin, but no use.
Can anyone help!!!

Athinaikon
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Thu Feb 14, 2013 8:17 am
Contact:

Re: Submenu items not showing

Post by Athinaikon » Wed Mar 27, 2013 6:21 am

I managed fixing the same problem on my site which is a joomla 2.5 by going to:
Module manager > Main menu > then in basic settings towards the end it has an option
"Show Sub-menu Items" select accordingly and your done!


Locked

Return to “Joomla! 1.5 Bug Reporting”