Joomla 1.5.1. Content PDF

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Forum rules
Forum Rules
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
humorlos
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Mar 21, 2006 9:48 am

Joomla 1.5.1. Content PDF

Post by humorlos » Tue Feb 19, 2008 10:00 am

Hello,

we encounter newly on our Joomla 1.5.1 installations following problem: if one wants to create a pdf out of an content item with IE, he gets an empty page. If he right clicks the link -> open to new tab, the pdf is correctly opened in a new tab. The whole feature itself works totally right with firefox. With opera problems exists similar to the IE.

In 1.5.0 there is no such problem.

To state it once again, the pdfs itself are generated without any error (or it wouldn't work in firefox) but they are not displayed in ie7.

I have searched the forums here a little bit and seen, that same other guys from norway are encountering the same problem. Is there already a known workaround? Is it fixed in SVN (nothing corresponding found in the current SVN changelog)?

Best regards
Bernhard

humorlos
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Mar 21, 2006 9:48 am

Re: Joomla 1.5.1. Content PDF

Post by humorlos » Tue Feb 19, 2008 2:01 pm

Short addition: Under http://www.tweety-clan.com you can find a complete fresh 1.5.1 installation, with no sample data installed, and one test article for demonstration.

Some problem exists as described above.

Best regards
Bernhard

User avatar
bratanon
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 111
Joined: Wed Sep 20, 2006 8:11 pm
Location: Sweden

Re: Joomla 1.5.1. Content PDF

Post by bratanon » Wed Feb 20, 2008 12:43 pm

I have the same problem.

IE7 only show you a blank page.

IE6 open a new window, but then it will automaticly close itself almost directly and force me to download the pdf file.

mobileguy
Joomla! Intern
Joomla! Intern
Posts: 76
Joined: Sat Jan 05, 2008 3:23 am
Contact:

Re: Joomla 1.5.1. Content PDF

Post by mobileguy » Sat Feb 23, 2008 3:17 am

Thanks I thought I was going mad.

IE7 opens the pDF in new tab!!!!!!! and Opera is dead.

kayut
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Mar 25, 2008 10:36 pm

Re: Joomla 1.5.1. Content PDF

Post by kayut » Tue Mar 25, 2008 10:41 pm

Hi,

I have exactly the same problem with IE7.

Any solution??

Thanks

humorlos
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Mar 21, 2006 9:48 am

Re: Joomla 1.5.1. Content PDF

Post by humorlos » Wed Mar 26, 2008 8:52 am

Hi,

until know I have no known solution. It is posted in the bug tracker and confirmed (now under bug id 8612) but it was closed with a wrong argumentation.

So let's see what happens next.

best regards

jdespatis
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Apr 23, 2008 5:53 pm

Re: Joomla 1.5.1. Content PDF

Post by jdespatis » Wed Apr 23, 2008 6:01 pm

I've had the same problem with a fresh install of joomla 1.5.2

Very easy to test the bug: just go on http://demo.joomla.org/1.5/, and click on the first pdf icon with IE 7 => empty popup

As i couldn't wait for joomla team to correct the problem (in fact it's not a joomla bug according to them...), i've done a little patch to make it work, waiting for a deeper correction:

Just edit the file components/com_content/helpers/icon.php, then go to the pdf() function, and replace:
$attribs['onclick'] = "window.open(this.href,'win2','".$status."'); return false;";

By this:

//$attribs['onclick'] = "window.open(this.href,'win2','".$status."'); return false;";
$attribs['target'] = "_blank";

Hope this helps...

User avatar
sandy malteser
Joomla! Intern
Joomla! Intern
Posts: 87
Joined: Thu May 11, 2006 4:23 pm

Re: Joomla 1.5.1. Content PDF

Post by sandy malteser » Thu Apr 24, 2008 12:28 pm

fantastic mate ! that worked wonders on internet exploiter! :)
Programming is like sex! ...one mistake and you have to support it for the rest of your life.

4ng3l
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Apr 25, 2008 9:09 pm

Re: Joomla 1.5.1. Content PDF

Post by 4ng3l » Sat Apr 26, 2008 12:25 am

Many thanks jdespatis,
also in italy a lot of people have this problem.
I will post your solution in an italian forum about joomla.
Bye
Angelo

jojoflamingo
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jan 24, 2006 8:48 pm

Re: Joomla 1.5.1. Content PDF

Post by jojoflamingo » Wed May 07, 2008 9:44 pm

This fix works great. I just applied to 1.5.3. You should submit for 1.5.4! :laugh:

sabrown9001
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jun 10, 2008 6:36 pm

Re: Joomla 1.5.1. Content PDF

Post by sabrown9001 » Tue Jun 10, 2008 6:43 pm

It Helps!
THANKS
:)

JoomNuB
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jun 11, 2008 11:54 pm

Re: Joomla 1.5.1. Content PDF

Post by JoomNuB » Thu Jun 12, 2008 1:12 am

Many thanks jdespatis,

Applied your hack to a 1.5.3 install on the same domain (dedicated host) that has a separate 1.0x install that works just fine in IE7...it's the strangest thing. I'm leaning towards a permissions issue since many of the 1.0 directories are writeable and all of the 1.5 permissions are 755. Don't know if I'm curoius enough to open up permissions on the 1.5 install. Getting ready to delete the 1x install now since it's using 777 permissions. Don't like haveing my fly open ;)

Thanks again!

AJ

coolzero
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Apr 23, 2008 2:31 pm

Re: Joomla 1.5.1. Content PDF

Post by coolzero » Fri Jun 13, 2008 6:31 pm

Thanks jdespatis,

I was pulling my hair out trying to figure it out. You are a God send! Thanks again.
Note: it worked for the 1.5.3 Joomla release as well.

yvchen
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Sep 18, 2008 7:29 am

Re: Joomla 1.5.1. Content PDF

Post by yvchen » Thu Sep 18, 2008 7:35 am

This problem still exists in 1.5.6. Applied your fix. Thank you jdespatis!

whitecrane
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue May 01, 2007 10:12 pm

Re: Joomla 1.5.1. Content PDF

Post by whitecrane » Fri Oct 24, 2008 8:59 pm

This is truly great, however, after applying this fix, I can no longer download a PDF in IE6. IE7 works perfectly after this repair, but IE6 delivers the following error.
------
There was an error in opening this document. The file cannot be found.
-----
Any ideas on resolving this for both of the IE beasts would be greatly appreciated.

Thanks so much!

shakesbeer
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Mar 21, 2009 4:46 pm
Location: Vermont
Contact:

Re: Joomla 1.5.1. Content PDF

Post by shakesbeer » Tue Jun 16, 2009 4:39 pm

Thank you, jdespatis!!

I think that your answer fixed all THREE of my icons: PDF, email, and print. Readers can now view articles as PDFs, print 'em, or mail 'em.

Thanks a lot!

Mark

shakesbeer
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Mar 21, 2009 4:46 pm
Location: Vermont
Contact:

Re: Joomla 1.5.1. Content PDF

Post by shakesbeer » Tue Jun 16, 2009 4:45 pm

Actually, I have another issue with the icons, though.

When I set the print, pdf or email icons as "hidden" in my global article parameters, they nonetheless show up on my articles, and I have to therefore set them as hidden manually for each individual article. (i.e. the "Use Global" setting doesn't seem to work)

Any suggestions?

Thanks!

Mark

ivandeselt
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Aug 10, 2011 2:16 am

Re: Joomla 1.5.1. Content PDF

Post by ivandeselt » Wed Aug 10, 2011 2:31 am

i cant find the pdf function.....i'm using joomla 1.6...where i can find it?

User avatar
JohnDevise
Joomla! Apprentice
Joomla! Apprentice
Posts: 41
Joined: Mon Sep 24, 2012 9:34 am
Location: USA
Contact:

Re: Joomla 1.5.1. Content PDF

Post by JohnDevise » Thu Oct 25, 2012 11:55 am

ivandeselt wrote:i cant find the pdf function.....i'm using joomla 1.6...where i can find it?
Hi ivandeselt.
Hope this topic helps you . Check this - http://forum.joomla.org/viewtopic.php?f=428&t=273119 .


Locked

Return to “Joomla! 1.5 Bug Reporting”