--can't save or apply changes in articles --

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Forum rules
Forum Rules
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
edavila
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Oct 26, 2008 8:31 pm

--can't save or apply changes in articles --

Post by edavila » Thu Oct 30, 2008 6:22 pm

Hi,

I'm using joomla 1.5.7 and everytime I try to save an article (or apply a change), using the save or apply button a blank page came and changes are not made. Also if I send an article to the article trash and I try to remove it permanently from the trash, the same blank page comes and the article is not removed from the trash. I have not installed new extensions like Virtual Mart or any other.

Any idea about the cause of this problem?

In advance thank you for your help.

Edmundo J. Davila

User avatar
ircmaxell
Joomla! Ace
Joomla! Ace
Posts: 1926
Joined: Thu Nov 10, 2005 3:10 am
Location: New Jersey, USA
Contact:

Re: --can't save or apply changes in articles --

Post by ircmaxell » Fri Oct 31, 2008 11:49 am

Turn error reporting to maximum in global configuration.
Anthony Ferrara - Core Team - Development Coordinator - Bug Squad - JSST

http://moovum.com/ - The Bird is in the air! Get Mollom Anti-Spam on your Joomla! website with Moovur...
http://www.joomlaperformance.com For All Your Joomla Performance Needs

edavila
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Oct 26, 2008 8:31 pm

Re: --can't save or apply changes in articles --

Post by edavila » Fri Oct 31, 2008 2:30 pm

When I try to change an existing article the following message is showed:

Fatal error: Cannot instantiate non-existent class: tablefrontpage in /hermes/web04/b1634/blu.bdweb7298a/joomla15/administrator/components/com_content/controller.php on line 900

When I try to delete an article from the article trash the following message is showed:

Fatal error: Cannot instantiate non-existent class: tablefrontpage in /hermes/web04/b1634/blu.bdweb7298a/joomla15/administrator/components/com_trash/admin.trash.php on line 263

Are this problems joomla's bugs? In advance thank you for your help.

Edmundo J. Davila

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18812
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: --can't save or apply changes in articles --

Post by infograf768 » Fri Oct 31, 2008 2:52 pm

edavila wrote:When I try to change an existing article the following message is showed:

Fatal error: Cannot instantiate non-existent class: tablefrontpage in /hermes/web04/b1634/blu.bdweb7298a/joomla15/administrator/components/com_content/controller.php on line 900

When I try to delete an article from the article trash the following message is showed:

Fatal error: Cannot instantiate non-existent class: tablefrontpage in /hermes/web04/b1634/blu.bdweb7298a/joomla15/administrator/components/com_trash/admin.trash.php on line 263

Are this problems joomla's bugs? In advance thank you for your help.

Edmundo J. Davila
It looks like you may have corrupted or missing files in your install.
This usually happens with a bad ftp upload.
It is suggested you overwrite your install with a full 1.5.7 package, after saving your configuration.php and any custom files present.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

edavila
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Oct 26, 2008 8:31 pm

Re: --can't save or apply changes in articles --

Post by edavila » Sun Nov 02, 2008 4:36 pm

Hi,

After the installation of joomla 1.5.7 no errors were reported. I checked all the parameters and they seem to be ok. I reinstalled joomla as you suggested and the problem persists.

The problem has been reported in other forum, but the solution given doesn´t apply in my case http://forum.joomla.org/viewtopic.php?f=235&t=325524

If you have more suggestions I will appreciatte them.

Again thanks all of you for your help.

Edmundo J. Davila

nexus6
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Mon Oct 06, 2008 12:26 pm

Re: --can't save or apply changes in articles --

Post by nexus6 » Wed May 27, 2009 7:35 am

ircmaxell wrote:Turn error reporting to maximum in global configuration.
Hi

where i can set this? i didn't find any voice about this in global configuration

tks

fbc
Joomla! Intern
Joomla! Intern
Posts: 73
Joined: Tue May 02, 2006 6:43 pm
Location: guadalajara,jalisco,mexico
Contact:

Re: --can't save or apply changes in articles --

Post by fbc » Mon Jul 20, 2009 6:36 pm

I'm having this same problem with 1.5.12. Any news that might fix this?
Frank B.
Guadalajara, Jalisco, Mexico

aber
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Jul 20, 2009 8:01 pm

Re: --can't save or apply changes in articles --

Post by aber » Mon Jul 20, 2009 8:16 pm

Same here. Since I upgraded from 1.5.11 to 1.5.12 I cannot edit or add any article anymore. In the article manager the save and apply button refuse service. What can I do? It's quite urgent because I can't add new articles to my website or edit articles.

User avatar
airton
Joomla! Ace
Joomla! Ace
Posts: 1369
Joined: Sun Nov 04, 2007 1:12 am
Location: Brazil
Contact:

Re: --can't save or apply changes in articles --

Post by airton » Mon Jul 20, 2009 8:58 pm

Hello guys and galls,

It's very difficult to find out what the issue might be by only guessing on the little info you provided so far.

Please, use the Forum Post Assistant (link in the orange box named Forum Rules on top of this thread) and post a complete report from that tool here.

Also, go to Site --> Global Configuration --> Server and set the Error Reporting option to Maximum, then try to save or edit an article. If you see any error messages after that operation, post them here. Remember to set the error reporting to default after testing.

Thanks,
Airton Torres
Joomla Bug Squad http://groups.google.com/group/joomlabugsquad
Community website - http://community.joomla.org
Unsolicited support PMs will be deleted and the user added to the foes list.

JuliaG
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jul 23, 2009 2:32 pm

Re: --can't save or apply changes in articles --

Post by JuliaG » Thu Jul 23, 2009 2:40 pm

I have the same problem since upgrading to 1.5.12. I can't add any new articles, any images into the articles or amend any previous articles. It just doesn't save and everything is lost when I close. :'(

User avatar
tusker
Joomla! Ace
Joomla! Ace
Posts: 1075
Joined: Tue Dec 25, 2007 2:15 pm
Location: Baroda - India
Contact:

Re: --can't save or apply changes in articles --

Post by tusker » Thu Jul 23, 2009 2:45 pm

most of the time problems are related to missed files or files without proper permissions applied. FTPing sometimes create problems. Double check if you are updated/upgraded your installations properly or not.
ONE WORLD OPEN WORLD - WAR TODAY GIVE PEACE A CHANCE
http://indiavoice.info - India News & Information Portal
http://indiadaily.indiavoice.info - India Daily Infotainment

(Powered by Joomla!)

fbc
Joomla! Intern
Joomla! Intern
Posts: 73
Joined: Tue May 02, 2006 6:43 pm
Location: guadalajara,jalisco,mexico
Contact:

Re: --can't save or apply changes in articles --

Post by fbc » Thu Jul 23, 2009 2:51 pm

It was my isp's squid cache server and my own...

Since it happened right after an upgrade, I decided to dump my firefox cache and wait 20-30 minutes.

And walla! It was enough time for my ISP's squid cache to timeout, and it all began working again.
Frank B.
Guadalajara, Jalisco, Mexico

User avatar
tusker
Joomla! Ace
Joomla! Ace
Posts: 1075
Joined: Tue Dec 25, 2007 2:15 pm
Location: Baroda - India
Contact:

Re: --can't save or apply changes in articles --

Post by tusker » Thu Jul 23, 2009 2:58 pm

sometimes solutions are simpler and we dig hard without any particular reason..
ONE WORLD OPEN WORLD - WAR TODAY GIVE PEACE A CHANCE
http://indiavoice.info - India News & Information Portal
http://indiadaily.indiavoice.info - India Daily Infotainment

(Powered by Joomla!)

JuliaG
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jul 23, 2009 2:32 pm

Re: --can't save or apply changes in articles --

Post by JuliaG » Tue Jul 28, 2009 9:03 am

I am quite a novice when it comes to Joomla and I don't really know exactly how to go about dumping caches as described by fbc. If you could explain in more detail I will attempt this as I still haven't solved my adding articles problem yet and I'm not sure what to do.

I tried turning error reporting up to maximum as advised and attempted to add an article again, but nothing happened and no error was registered. Any ideas? Getting quite desperate now as my website is fast becoming out of date!

Help!

Rob_Masana
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jul 22, 2009 9:47 pm

Re: --can't save or apply changes in articles --

Post by Rob_Masana » Wed Jul 29, 2009 1:23 am

I'm having similar issues in 1.5.13 with the recent tinyMCE and media manager patch in both IE(both 7 and 8) and Firefox. When using IE 8 I get the following error
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6; SU 3.010; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)
Timestamp: Wed, 29 Jul 2009 01:15:15 UTC


Message: 'tinyMCE.activeEditor' is null or not an object
Line: 297
Char: 4
Code: 0
URI: /administrator/index.php?option=com_content&sectionid=-1&task=edit&cid[]=1

and in Firefox I get this error (from firebug)
Failed to load source for:/administrator/index.php?option=com_content&sectionid=-1&task=edit

Any info/help is much appreciated!

mockefj
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Tue Jul 21, 2009 4:34 pm

Re: --can't save or apply changes in articles --

Post by mockefj » Wed Jul 29, 2009 9:08 am

I've got the same problem after I upgraded. The "apply" and "save" button won't work! Nothing happens when I click on them

Atlinho
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sat Jul 25, 2009 7:23 pm

Re: --can't save or apply changes in articles --

Post by Atlinho » Wed Jul 29, 2009 9:29 am

I also had this problem, and tried different things as suggested here on the forum but it didn't work for me.

When I also faced a problem with moving my site from a folder to the root, I couldn't wait anymore, because when moving to root I suddenly couldn't login back-end, even if I changed the configurationfile correct.

My solution (which also solve the article problem):

1. Backup both database and all files on server, and store them on your computer.
2. Deleted all files on my server.
3. Downloaded Joomla 1.5.13 full installation and did a clean install on my server. Now you have a clean install of Joomla on your site.
4. Entered my database via phpmyadmin, and deleted all tables. So the database was clean. Uploaded my databasebackup from my computer. (Now you will se that all your members, articles etc. are there)
5. Uploaded all componentfiles, modules etc.,that was stored at my computer, via FTP. If you look in all folders in the clean Joomlainstall and compare it to the backup you have on your computer, you will see which files that is missing on your server to get all components etc. to show on your website. (All this means that you should upload all files that doesn't have anything to do with Joomla Core)
6. Finito:) Your site should now look exactly as it was before you did this prossess, but know your articles will work correctly!

This job takes some time, but if you are desperat, this is a solution that will fix it. If my FTP was working like it should, and not try to [censored] up all the time, it would have went much faster than it did :p

mockefj
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Tue Jul 21, 2009 4:34 pm

Re: --can't save or apply changes in articles --

Post by mockefj » Wed Jul 29, 2009 12:56 pm

I installed a fresh new database, and a new installation, and it still won't work!

mockefj
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Tue Jul 21, 2009 4:34 pm

Re: --can't save or apply changes in articles --

Post by mockefj » Wed Jul 29, 2009 1:04 pm

I found the problem, it has something to do with the Tiny editor, install a new one like FCK editor and all is fine!

User avatar
Rowby
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 193
Joined: Sun Dec 11, 2005 9:13 pm
Location: California
Contact:

Re: --can't save or apply changes in articles --

Post by Rowby » Thu Jul 30, 2009 10:46 pm

SInce the problem was only happening in my articles (and not having a similar problem, for example with Saving Global Configuraiton Settings), I did what Mocketj suggested and switched my article editor.

Problem fixed!

...Rowby

JuliaG
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jul 23, 2009 2:32 pm

Re: --can't save or apply changes in articles --

Post by JuliaG » Fri Jul 31, 2009 1:39 pm

Thank you so much. I have tried most of the other suggestions above plus I upgraded to 1.5.13 and nothing worked. I have now installed JCE editor and selected it in the global configuration and everything is working once again. I can't tell you how relieved I am!!!!! :)

User avatar
Yatko
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Mar 22, 2007 7:26 am
Location: US
Contact:

Re: --can't save or apply changes in articles --

Post by Yatko » Sun Aug 09, 2009 9:53 am

Hi everyone,

I had the same problem, what I did was deleting the following directory:
/plugins/editors
and uploaded a new one from the latest full ackage.

Solved! :)

Kyrian
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Sep 03, 2009 4:12 am

Re: --can't save or apply changes in articles --

Post by Kyrian » Thu Sep 03, 2009 4:14 am

hi all..
I'm coming here to you cause my site is actually dead. First i'm french, so sorry for my english.

Here what happened : After updated joomla 1.5.10 to 1.5.14, I added JRE cache accelerator as well. Few hours later, I sent articles and the page made a long time to appear.

But this is not the big point. I "Turn error reporting to maximum in global configuration." and here is the message :

"Erreur d'encodage de contenu. La page que vous essayez de voir ne peut être affichée car elle utilise un type de compression invalide ou non pris en charge."

Translated (approximatively) : "Error of contents encoding. The page you try to see cannot be shown because it uses a type of compression invalidate or not supported"

I did a backup from my manager, only sql backup. They told me it will take severals minutes but I don't know how many and my site is down everywhere.

What could I do ? How can I change this configuration without my admin panel ? Is it possible by mysql ? Do I have to do a full backup (SQL and Servor) from 3 days ago ? If it's due to the GZIP enabled, how can I disable it ?

Please let me know,

Regards

Kyrian
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Sep 03, 2009 4:12 am

Re: --can't save or apply changes in articles --

Post by Kyrian » Thu Sep 03, 2009 4:26 am

Me again, I solve the problem by changing the $mosConfig_gzip value to 0 in configuration.php file.
Hope it won't happen again.
:)

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18812
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: --can't save or apply changes in articles --

Post by infograf768 » Thu Sep 03, 2009 11:58 am

Kyrian wrote:Me again, I solve the problem by changing the $mosConfig_gzip value to 0 in configuration.php file.
Hope it won't happen again.
:)
This is for Joomla 1.0

In 1.5 would be
var $gzip = '0';
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

tusharuk
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Mon Aug 31, 2009 5:19 pm

Re: --can't save or apply changes in articles --

Post by tusharuk » Thu Sep 03, 2009 7:18 pm

hi all,

am very new to joomla, infact i am learning, in my config.php the values are same but still the problem remain same. is this something to do with java etc. coz when i try to select any module etc. just geting msg in IE on the status bar page error or in firefox it get "done" but nothing happen.

User avatar
stormanf
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Feb 16, 2009 10:32 pm
Location: Kingston, Ontario, Canada
Contact:

Re: --can't save or apply changes in articles --

Post by stormanf » Mon Sep 28, 2009 7:00 pm

I have had the same problem since performing updates to Joomla 1.5.13, 14 & finally 15 - the "Save" and "Cancel" buttons of the FrontEnd editor (JCE 1.5.4) do nothing. I've tried most of the suggestions on this forum (new install of JCE, removing extraneous TinyMCE files, changing $gzip to "0", etc.), even setting the default editor to "none", but nothing seems to work. I'm using Firefox 3.0.11 and IE 7 on Windows XP. My host's server is an Apache version 2.2.11 (unix), php version 5.2.6. My site is at http://www.sydenhamstreet.ca/index.php and my email is cewalker@visionweaver.net. Any help would be appreciated -- I've been at this for a week!

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18812
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: --can't save or apply changes in articles --

Post by infograf768 » Tue Sep 29, 2009 7:14 am

stormanf wrote:I have had the same problem since performing updates to Joomla 1.5.13, 14 & finally 15 - the "Save" and "Cancel" buttons of the FrontEnd editor (JCE 1.5.4) do nothing. I've tried most of the suggestions on this forum (new install of JCE, removing extraneous TinyMCE files, changing $gzip to "0", etc.), even setting the default editor to "none", but nothing seems to work. I'm using Firefox 3.0.11 and IE 7 on Windows XP. My host's server is an Apache version 2.2.11 (unix), php version 5.2.6. My site is at http://www.sydenhamstreet.ca/index.php and my email is cewalker@visionweaver.net. Any help would be appreciated -- I've been at this for a week!
Test disabling any extension adding some js (JCE utilities, mediaobjects)
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
stormanf
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Feb 16, 2009 10:32 pm
Location: Kingston, Ontario, Canada
Contact:

Re: --can't save or apply changes in articles --

Post by stormanf » Wed Sep 30, 2009 3:09 pm

Hi,

I've just spent an hour experimenting with disabling most plugins-even JCE, TinyMCE and SEF -- but curiously, I still can log into the frontend and get an editor -- which won't save or cancel.

One thing occurs to me: in a subdirectory on our server we still have a test installation of Joomla 1.5.9 which contains an older version of our site. It's a different directory, but could this be affecting the main site, which is in the root directory? The frontend in this version has always been able to save edits, but of course it uses the older Javascript version of the editor.

Would it help if I sent you an email of the code of an edit page so you could check the Javascript?

Charlie

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18812
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: --can't save or apply changes in articles --

Post by infograf768 » Thu Oct 01, 2009 5:10 am

stormanf wrote: One thing occurs to me: in a subdirectory on our server we still have a test installation of Joomla 1.5.9 which contains an older version of our site. It's a different directory, but could this be affecting the main site, which is in the root directory? The frontend in this version has always been able to save edits, but of course it uses the older Javascript version of the editor.
It can't have any impact.
If you wish, send me by pm a superadmin name/password for me to log into your site and see what kind of js error one gets when one saves/cancels.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group


Locked

Return to “Joomla! 1.5 Bug Reporting”