Template not working after enabling sef urls

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Locked
valdonatas
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Mon Jan 25, 2010 11:06 am

Template not working after enabling sef urls

Post by valdonatas » Fri Jan 29, 2010 8:44 am

Helo,

I have just uploaded my website to the server. I was developing it on my local computer with sef urls turned on (if that makes any difference). Now, when it's on the server - if sef urls is enabled, I get the content with no styling (template not working). Besides, If I click on any link I get such url:
domain/index.php/index.php/index.php/index.php/thepage
Please help what could be wrong.

I am using joomla 1.5.15, legacy 1.0, php 5

mfkap
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jan 29, 2010 8:44 pm

Re: Template not working after enabling sef urls

Post by mfkap » Fri Jan 29, 2010 8:53 pm

Sorry, my previous post was incorrect (browser cache issue). I am still encountering the problem.

It is a fresh install, only plugin is AllVideos. Everything works fine except when I turn on SEF URL's, all pages except the main page display with no template (no graphics, colors, etc). Working without SEF UrL's for now, but would like to turn them on at some point. This happens with all the default templates, no template modifications have been made.

Linux/MySQL/10.5.15

fadler
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Mar 06, 2010 10:40 am

Re: Template not working after enabling sef urls

Post by fadler » Sat Mar 06, 2010 10:46 am

valdonatas, make sure you also select "Add suffix to URLs" as "Yes" and try again. Frank

jmikepat
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Mar 25, 2010 6:30 pm

Re: Template not working after enabling sef urls

Post by jmikepat » Thu Mar 25, 2010 7:55 pm

experiencing the same thing. changed "...suffix to url" to "yes" on global config, but still doing the same thing. also getting the "index.php" being added to the url.

dahauss
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Aug 24, 2009 8:09 pm

Re: Template not working after enabling sef urls

Post by dahauss » Mon May 10, 2010 3:58 am

I have the same issue.. running 1,5 joomla.. If I turn on the SEF url setting, the template doesnt work... I have to turn it off. what is causing this?
my site is www.unlimitedsounds.com

dacharles
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Aug 23, 2010 7:42 am

Re: Template not working after enabling sef urls

Post by dacharles » Sat Sep 11, 2010 11:19 am

The template problem may related to the htaccess.txt file. When you turn on the SEF url setting, make sure to change the htaccess.txt to .htaccess and be careful with the RewriteBase / in the file if your joomla installation is not in the root directory.

seanctc
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Thu Aug 11, 2011 3:31 pm

Re: Template not working after enabling sef urls

Post by seanctc » Thu Sep 01, 2011 6:52 pm

I know this post is a year old, but I have the exact same issue, I have searched and searched with no solution, i've done everything in the book, the pages are just not styled did the orignal posters solve this?, Apache rewrite is working fine did the redirect test, my Joomla site is in root so don't have to change anything there, $ var live in config php file set many different ways still not working.

No style = ?

manearaluca
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Wed Jun 24, 2009 6:51 am

Re: Template not working after enabling sef urls

Post by manearaluca » Mon Nov 07, 2011 8:40 am

Hi seanctc,

Did you find the answer by now?

Thanks,
Raluca.

seanctc
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Thu Aug 11, 2011 3:31 pm

Re: Template not working after enabling sef urls

Post by seanctc » Wed Nov 09, 2011 10:06 am

Hi Raluca,
To be honest I can't quite remember, I have a feeling I was mislead and told not to change $ var live to point to my site address as it was in root but after posting this I tried and the styling worked, hope you get it sorted.


Locked

Return to “Joomla! 1.5 Bug Reporting”