Upload image: Not a valid image.

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Forum rules
Forum Rules
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
demolg
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sun Jul 19, 2009 11:02 am
Contact:

Upload image: Not a valid image.

Post by demolg » Sun Jan 31, 2010 5:10 pm

Jooomla 1.15.15
When I upload photos to the article gives an error: Not a valid image.


Some photos uploaded fine. Some of the problem.

At other sites (facebook, wikipedia, ...) that photos uploaded fine.
http://autoa.org - cars, crash tests and magazines.

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11767
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Upload image: Not a valid image.

Post by brian » Sun Jan 31, 2010 6:08 pm

what type of image is it? What is its file extension?
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

demolg
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sun Jul 19, 2009 11:02 am
Contact:

Re: Upload image: Not a valid image.

Post by demolg » Mon Feb 01, 2010 11:15 am

http://autoa.org - cars, crash tests and magazines.

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11767
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Upload image: Not a valid image.

Post by brian » Mon Feb 01, 2010 11:58 am

It uploaded fine on my site. Did you check to ensure that jpg is in the list of allowed filetypes in the global configuration. It should be by default but perhaps it is missing. You should also note that your file is .JPG not .jpg and on some systems that could be an issue.
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

demolg
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sun Jul 19, 2009 11:02 am
Contact:

Re: Upload image: Not a valid image.

Post by demolg » Mon Feb 01, 2010 12:19 pm

Thank you. You are right. Added setting in "JPG" and it works.
http://autoa.org - cars, crash tests and magazines.

Jen76
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Aug 30, 2010 6:32 pm

Re: Upload image: Not a valid image.

Post by Jen76 » Mon Aug 30, 2010 6:40 pm

It's an issue with your host. They added the following in the .htaccess file in my root directory:

Code: Select all

<IfModule php_config>
php_value upload_max_filesize 20971520
php_value post_max_size 20971520
</IfModule>

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11767
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Upload image: Not a valid image.

Post by brian » Mon Aug 30, 2010 7:18 pm

Jen that had nothing at all with this post
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

Jen76
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Aug 30, 2010 6:32 pm

Re: Upload image: Not a valid image.

Post by Jen76 » Mon Aug 30, 2010 8:10 pm

I had the same issue of getting a "Not a valid image" when uploading images in media manager. Having my hosting company make that change solved it for me. I thought that's what this post was for for getting a "not a valid image" error notice.

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11767
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Upload image: Not a valid image.

Post by brian » Mon Aug 30, 2010 8:22 pm

Changing the upload size was not this users problem. They were trying to upload an image with a file extension of .JPG which was not in the list of allowed file extensions. I've be very surprised it the changes you describe would have any effect on your issue. If the image you were trying to upload was too big (which is what your code is to adjust) then the error message would have been different.
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

esmeralda
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jan 26, 2011 5:46 pm

Re: Upload image: Not a valid image.

Post by esmeralda » Wed Jan 26, 2011 7:01 pm

I've got an odd problem in that joomla's media manager lets me upload some images but not others. To be more precise, some show up and are imported successfully while others come up blank with only the name showing.

They are all .jpg files, were created in a batch process, are between 10kb and 13kb and do not contain spaces nor capital letters in their names. Permissions are also the same and I am quite simply baffled.

What am I overlooking?

Many thanks in advance for any suggestions.

matthewa
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Mar 04, 2011 3:14 am

Re: Upload image: Not a valid image.

Post by matthewa » Fri Mar 04, 2011 3:28 am

Hi all,
i've also been having this problem, but only on one host that is separate from other sites i manage.
i couldnt get phoca gallery to create thumbnails or anything.
i eventually clicked on parameters (in phoca gallery), scroll to the bottom. i changed the space on disk amount by adding a 0 at the end. this allowed phoca gallery to start processing photos/thumbnails, albeit hit and miss, but they are the first photos i have added in a year.
changing permissions form 755 to 777 didnt help at all.

i have found if i add too many photos via ftp, i have to delete them, then re load and phoca works ok.

i reckon that if we disabled thumbnail creation until they made it to a gallery then all would be ok.

hope this helps some of you.

I still cant add photos directly into phoca gallery, but at least the ftp option is functional. i seem to reall using dreamweaver when we initially builtthis site but i'm not sure.
the only fix i haven't tried is changing the php.ini file as i dont have access to it. i've got a help desk question open about that right now.

shilk
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Tue Feb 07, 2012 5:39 am

Re: Upload image: Not a valid image.

Post by shilk » Fri Feb 17, 2012 5:39 am

i also got same problem..but in ma globalconfig jpg files are allowed..den wat went wrong am nt understanding:(


Locked

Return to “Joomla! 1.5 Bug Reporting”