anchor link in article not preserved in modal box

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Locked
luisraposo
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Sat Apr 04, 2009 6:26 pm
Location: Portugal
Contact:

anchor link in article not preserved in modal box

Post by luisraposo » Mon Dec 20, 2010 10:33 pm

hello,

I have an article with internal anchor links:
<a href="#Duvidas">Duvidas</a>
<a name="Duvidas"></a>Duvidas..

this works fine when reading the article.

Inside a component, I open this article, on a modal box
<a class="XXX modal" title="EVENT"
href="<?php echo JRoute::_('index.php?option=com_content&view=article&id=86&tmpl=component&task=preview'); ?>" rel="{handler:'iframe', size: {x:630, y:400}, onShow:$('sbox-window').setStyles({ 'padding':'15px' })}" <?php JText::_( 'EVENT E-PAYMENT' ); ?> </a>

The article opens fine, but the inner anchor links do not work,
since they open within the site template, and not the component template,
meaning, links get changed to: <website>/component/content/article/86#Duvidas
missing the "tmpl=component&task=preview" options

Please notice: I use SEF

Is there a way to make this anchor link work inside a modal box?

regards,
luis raposo

itatommy
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Sep 08, 2011 7:04 am

Re: anchor link in article not preserved in modal box

Post by itatommy » Thu Sep 08, 2011 7:30 am

Hej
I have the same problem.
href="index.php?option=com_content&view=article&id=13&tmpl=component"
is replaced with
index.php/<menyname>/id=13

It works if the article is on frontpage
Index.php/component/content/article?id=13
but not on a ‘menu’ page displaying category blog view.

Any workaround?

Joomla 1.7.0
JoomlaCK

Regards

itatommy
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Sep 08, 2011 7:04 am

Re: anchor link in article not preserved in modal box

Post by itatommy » Thu Sep 08, 2011 8:15 am

Hej
Found it.
Global configuration - Search engine friendly URLs - No.
regards


Locked

Return to “Joomla! 1.5 Bug Reporting”