Tools for automated migration to Joomla 1.5

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Forum rules
Forum Rules
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
Adler
Joomla! Intern
Joomla! Intern
Posts: 82
Joined: Wed Aug 09, 2006 4:44 am
Location: Wildwood, NJ - On The Jersey Shore
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by Adler » Sun Aug 13, 2006 5:37 am

Hi All,

I just hosted my Joomla site @ SiteGround. I'm new to Joomla, and should I ask my host if they will up-grade or stop work on what I am doing and look forward to new things?
Adler

Wilwood, NJ - On The Jersey Shore
Linux Web Site
Biotech Blog

friesengeist
Joomla! Guru
Joomla! Guru
Posts: 842
Joined: Sat Sep 10, 2005 10:31 pm

Re: Re : Re: Tools for automated migration to Joomla 1.5

Post by friesengeist » Sun Aug 13, 2006 3:23 pm

Hi Pachat,
Pachat wrote: - Joomla 1.5 requires safe_mode. I don't have a root access on the servers I use, and there are safe_mode off.
that's not 100% right: Joomla! 1.5 now can handle servers with safe_mode=on, but it does not require it. Do you mind deleting this line in your list?

Thanks in advance,
Enno
We may not be able to control the wind, but we can always adjust our sails

User avatar
davidgal
Joomla! Guru
Joomla! Guru
Posts: 963
Joined: Sat Aug 20, 2005 9:19 am
Location: Israel
Contact:

Re: Tool for migration to 1.5 -when?

Post by davidgal » Sun Aug 13, 2006 7:58 pm

eyezberg wrote: Another 2 weeks, no news.. any chance to get a heads up on the migration tool ?
Would like to try and migrate a live site to 1.5, just to see what happens..
Hi eyesberg,

Sorry about the non-responsiveness lately. Hard to keep focus with the war over here and so on.

I have posted the latest version of the migration tool at http://forge.joomla.org/sf/go/projects. ... m_migrator

I've tried it out several times and it seems to be OK. It is designated a beta so any input from you will be very much appreciated.

Cheers,

David
David Gal

User avatar
eyezberg
Joomla! Hero
Joomla! Hero
Posts: 2860
Joined: Thu Aug 25, 2005 5:48 pm
Location: Geneva mostly
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by eyezberg » Mon Aug 14, 2006 6:35 pm

en bayot hope all is well.
will test.
Sometimes one pays most for the things one gets for nothing.
The important thing is not to stop questioning. Curiosity has its own reason for existing. AE
http://joomla15.[URL banned].com for J! 1.5 screenshots
http://www.eyezberg.com

User avatar
davidgal
Joomla! Guru
Joomla! Guru
Posts: 963
Joined: Sat Aug 20, 2005 9:19 am
Location: Israel
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by davidgal » Tue Aug 15, 2006 8:30 pm

eyezberg wrote: en bayot hope all is well.
will test.
Toda. All fine and in one piece.
David Gal

User avatar
eyezberg
Joomla! Hero
Joomla! Hero
Posts: 2860
Joined: Thu Aug 25, 2005 5:48 pm
Location: Geneva mostly
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by eyezberg » Mon Sep 25, 2006 8:48 pm

I just tried to test the migration tool. You may want to update the download in the first post to point to the new Forge version.. ;)
It seems to work more or less using the MIGRATION dump, except for one error:

Code: Select all

Database Errors Reported
Erreur de syntaxe pr�s de ';
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) V' � la ligne 1 SQL=INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'shout\\', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'source', '4');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flip', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'photo', '6');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'events as2doc', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'event as2doc', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'configuration', '3');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'soutbox', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'mosets', '27');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'joomlaboard', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'board', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'calendar', '3');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'calender', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'masha', '3');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'shopping cart', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'eooooo', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'template', '18');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'templates', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'editor', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'Hello', '4');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'quick preview', '4');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'expose', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'customization', '3');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flash 8', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flash8', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flash movie', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flv', '39');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'blazePDF', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flash menu', '4');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'favicon', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'avatar', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'bit-101', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'MOSImage Control', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flash table', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'tables', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flashtable', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'swf2pdf', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'drop downs', '3');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'tree', '6');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flipz.swf', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flipz', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'duplicate', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'download frontpage', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'Shout It!', '5');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'data.swf', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'preview', '4');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'musique', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'music', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'gallery joomla', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'GhostWire', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'form', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'form.fla', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'Mosets.com Shout It!', '3');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'as2doc', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'intro', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'intros', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'ahostmaster', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'bludd', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'amazon associates', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flash overlap', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flashtrak', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'test', '3');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'counter', '4');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'Sepy', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'glossary', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'download imagevue', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'sel2Draw', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'KineticFusion', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'phplist', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'javascript', '3');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'pollster', '9');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'link module', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'Romiglia', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'water ripples', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flash2exe', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'polster 2.0', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'pollster 2.0', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'fscommand', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'xml flash menu', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'quizz', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'joo', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'boundingbox_mc', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'AUTOLOGIN', '23');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'AUTO LOGIN', '10');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'download', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'login', '5');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'shour', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'sitemap', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'banners', '2');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'textflow', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'Mosets Shout It!', '11');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'htmlfix', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'flash doesn\'t lo', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'browseforfolder', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'web', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'web\'s', '1');
INSERT INTO `jos_core_log_searches` (`search_term`, `hits`) VALUES ( 'web\"\"', '2')
-------------
The site looked more or less ok (have to add the media..), but all mainmenu links lead to error pages?!
Sometimes one pays most for the things one gets for nothing.
The important thing is not to stop questioning. Curiosity has its own reason for existing. AE
http://joomla15.[URL banned].com for J! 1.5 screenshots
http://www.eyezberg.com

User avatar
eyezberg
Joomla! Hero
Joomla! Hero
Posts: 2860
Joined: Thu Aug 25, 2005 5:48 pm
Location: Geneva mostly
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by eyezberg » Tue Sep 26, 2006 5:53 pm

Tried to install com_migrator on latest 1.5 SVN, all ok. When trying to access, empty page with
Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in c:\easyphp1-8\www\j11\administrator\components\com_migrator\admin.migrator.php on line 274

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in c:\easyphp1-8\www\j11\administrator\components\com_migrator\admin.migrator.php on line 293

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in c:\easyphp1-8\www\j11\administrator\components\com_migrator\admin.migrator.php on line 294

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in c:\easyphp1-8\www\j11\administrator\components\com_migrator\admin.migrator.php on line 294
Restricted access
Sometimes one pays most for the things one gets for nothing.
The important thing is not to stop questioning. Curiosity has its own reason for existing. AE
http://joomla15.[URL banned].com for J! 1.5 screenshots
http://www.eyezberg.com

User avatar
davidgal
Joomla! Guru
Joomla! Guru
Posts: 963
Joined: Sat Aug 20, 2005 9:19 am
Location: Israel
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by davidgal » Tue Sep 26, 2006 9:55 pm

Hi eyes,

com_migrator is not needed on J! 1.5 nor is it meant to work with 1.5. It is specifically to be used on J!1.0.x and older sites (including Mambo) for the purpose of preparing a specific data dump to be used for import during the installation process of J! 1.5.

The component itself does not do the migration into 1.5 - the installation does this.

Shana Tova,

David
David Gal

kashbash
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Fri Dec 30, 2005 7:52 pm

Re: Tools for automated migration to Joomla 1.5

Post by kashbash » Fri Sep 29, 2006 2:41 pm

i got a Live webstie made in Joomla 1.0.8 . Using migrator tool i made the 3 dump files +1 report.html file. and downloaded to my local PC desktop.

i went on to install the Joomla 1.5 on my LOCAL PC Server(LAMP). Now when i try to use those 3 migration scripts i am taken back to step 1 of installation.

what could be the problem?
1-- Can one import the DUMP into Local Server joomla 1.5? or

2- should i install the 1.5 on my Internet server and then upload the scripts and execute to the hosting site?

User avatar
davidgal
Joomla! Guru
Joomla! Guru
Posts: 963
Joined: Sat Aug 20, 2005 9:19 am
Location: Israel
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by davidgal » Sat Sep 30, 2006 10:38 am

kashbash wrote: i got a Live webstie made in Joomla 1.0.8 . Using migrator tool i made the 3 dump files +1 report.html file. and downloaded to my local PC desktop.

i went on to install the Joomla 1.5 on my LOCAL PC Server(LAMP). Now when i try to use those 3 migration scripts i am taken back to step 1 of installation.

what could be the problem?
1-- Can one import the DUMP into Local Server joomla 1.5? or

2- should i install the 1.5 on my Internet server and then upload the scripts and execute to the hosting site?
Please read the migration instructions at [url=http://I would like to understand what the values are in your configuration.]I would like to understand what the values are in your configuration.
[/url]

In the first step create a dump of your old site using com_migrator. NOTE you only need the one file labeled MIGRATION for import to the new J! 1.5 site.
In the second step start installing J! 1.5 (evenl locally if you wish). During the installation steps when you reach the Main Configuration Step -6, You can find the data migration options. Choose option 3 for migration data. This is where you load the single MIGRATION file.

The other files that com_migrator dumps are for pure back-up purposes or for manual migration of 3PD component data.

Hope this helped,
David Gal

hornos
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 176
Joined: Fri Aug 19, 2005 7:08 pm
Location: France
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by hornos » Thu Oct 05, 2006 7:20 pm

Hi,

Hmm, tested on a local installation
- com_migrator 1.0.8 installed on a J! 1.0.11 installation
- dump 1011_20061005_210905_MIGRATION.sql.gz successfully generated
- tried to import 1011_20061005_210905_MIGRATION.sql.gz dump in J! 1.5 step 6 installation and got the following error:

Code: Select all

Fatal error: Call to undefined function: handleerrormessage() in c:\program files\easyphp1-8\www\15\libraries\pattemplate\patErrorManager.php on line 208
Note: I used J! 1.5 rev. 5335

User avatar
ianmac
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4785
Joined: Sat Sep 24, 2005 11:01 pm
Location: Toronto, Canada

Re: Tools for automated migration to Joomla 1.5

Post by ianmac » Thu Oct 05, 2006 8:42 pm

Can someone put this into Q&T?

Ian

Phailure
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jul 20, 2006 7:34 pm

Re: Tools for automated migration to Joomla 1.5

Post by Phailure » Mon Oct 09, 2006 6:39 pm

hornos wrote: Hi,

Hmm, tested on a local installation
- com_migrator 1.0.8 installed on a J! 1.0.11 installation
- dump 1011_20061005_210905_MIGRATION.sql.gz successfully generated
- tried to import 1011_20061005_210905_MIGRATION.sql.gz dump in J! 1.5 step 6 installation and got the following error:

Code: Select all

Fatal error: Call to undefined function: handleerrormessage() in c:\program files\easyphp1-8\www\15\libraries\pattemplate\patErrorManager.php on line 208
Note: I used J! 1.5 rev. 5335
im getting the same error, except when i view my main page [beta.n4rd.com] and of course the linux path instead of windows. what's up with that?

User avatar
ianmac
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4785
Joined: Sat Sep 24, 2005 11:01 pm
Location: Toronto, Canada

Re: Tools for automated migration to Joomla 1.5

Post by ianmac » Tue Oct 10, 2006 6:20 pm

basically, there are still things being worked out with error handling...  an error has occured, and called the errorhandling script and a method to handle the error, but the method doesn't exist.  I'll post this to Q&T to make sure it gets looked after (although it has been noted before).

Ian

Phailure
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jul 20, 2006 7:34 pm

Re: Tools for automated migration to Joomla 1.5

Post by Phailure » Tue Oct 10, 2006 6:27 pm

is there any way to disable the error reporting so i don't get this?

User avatar
ianmac
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4785
Joined: Sat Sep 24, 2005 11:01 pm
Location: Toronto, Canada

Re: Tools for automated migration to Joomla 1.5

Post by ianmac » Wed Oct 11, 2006 12:46 pm

I don't think you can do this without modifying the core files...  if you want to try it out, the file to change is libraries/joomla/utility/error.php.  On the bottom there are three lines:

Code: Select all

JError::setErrorHandling(E_ERROR, 'callback', array('JError','customErrorPage'));
JError::setErrorHandling(E_WARNING,'message', array('JError','customErrorPage'));
JError::setErrorHandling(E_NOTICE, 'message', array('JError','customErrorPage'));
If you change the message in the last two to callback, you will be able to see the error that is being generated.

Ian

Phailure
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jul 20, 2006 7:34 pm

Re: Tools for automated migration to Joomla 1.5

Post by Phailure » Wed Oct 11, 2006 2:18 pm

oh wow thank you ill try that out.

EDIT: it's utilities, not utility, right?

EDIT2: and actually, it says

Code: Select all

JError::setErrorHandling(E_ERROR, 'callback', array('JError','customErrorPage'));
JError::setErrorHandling(E_WARNING, 'message');
JError::setErrorHandling(E_NOTICE, 'message');
but ill try that regardless.

EDIT3: Fatal error: Call to a member function getCfg() on a non-object in /home/.hoofman/phailure/betan4rd/libraries/joomla/document/error/error.php on line 127

is what it gives me :(

i will mess with it some.

edit4:

Code: Select all

JError::setErrorHandling(E_ERROR, 'callback', array('JError','customErrorPage'));
JError::setErrorHandling(E_WARNING, 'callback', array('JError','customErrorPage'));
JError::setErrorHandling(E_NOTICE, 'callback', array('JError','customErrorPage'));
gives me an internal server error. i dunno. whatever. i'm going to install the most recent build. sorry for bothering you.
Last edited by Phailure on Wed Oct 11, 2006 2:54 pm, edited 1 time in total.

User avatar
ginslo
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Jun 27, 2006 1:12 am
Location: San Luis Obispo, CA

Re: Tools for automated migration to Joomla 1.5

Post by ginslo » Thu Oct 12, 2006 10:38 pm

Phailure wrote:

Code: Select all

JError::setErrorHandling(E_ERROR, 'callback', array('JError','customErrorPage'));
JError::setErrorHandling(E_WARNING, 'callback', array('JError','customErrorPage'));
JError::setErrorHandling(E_NOTICE, 'callback', array('JError','customErrorPage'));
gives me an internal server error. i dunno. whatever. i'm going to install the most recent build. sorry for bothering you.
Hmm, I'm getting same error (Call to undefined function: handleerrormessage() ... ) on last step of fresh install. Tried suggested edits (shown above). My webserver became extremely overloaded at time of test (55+ load average) (Coincidence or related? Don't know, but am hesitant to try again because it's a shared host).

ianmac: Pls reply to this thread with further instructions/suggestions. Thanks.

-gary

Spencer
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Tue Sep 19, 2006 8:09 pm

Re: Tools for automated migration to Joomla 1.5

Post by Spencer » Fri Oct 13, 2006 2:26 am

worked:)
Last edited by Spencer on Fri Oct 13, 2006 2:37 am, edited 1 time in total.

User avatar
ginslo
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Jun 27, 2006 1:12 am
Location: San Luis Obispo, CA

Re: Tools for automated migration to Joomla 1.5

Post by ginslo » Fri Oct 13, 2006 2:36 am

ginslo wrote:Call to undefined function: handleerrormessage() ...
I found the solution to this error and it's quite simple. The directory in which Joomla is installed must be writable by Apache. Mine was not. Once I changed ownership and permissions the installation process completed with no errors.

-gary

Spencer
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Tue Sep 19, 2006 8:09 pm

Re: Tools for automated migration to Joomla 1.5

Post by Spencer » Fri Oct 13, 2006 3:18 am

Wher do I find the: Old table prefix  ??

I get this error when I try to upload: Upload failed - archive unpack error

Had no problem packing old site.

Read all docs and am stuck.

diri
Joomla! Guru
Joomla! Guru
Posts: 702
Joined: Wed Sep 21, 2005 9:27 am
Location: Somewhere

Re: Tools for automated migration to Joomla 1.5

Post by diri » Fri Oct 13, 2006 12:44 pm

Over here I ran com_migration 1.0.8 once with success. Since than table #__sections is missing at this site. Data is not included in dump ...  >:(

User avatar
viktor
Joomla! Intern
Joomla! Intern
Posts: 51
Joined: Thu Feb 16, 2006 9:30 pm

Re: Tools for automated migration to Joomla 1.5

Post by viktor » Fri Oct 13, 2006 11:00 pm

I am able to pass through all this and successfully completed installation.

However, when I click on Admin icon on the success screen I get the following error.

JFTP::_passive: Unable to obtain IP and port for data transfer

How to get through this?

Thanks

draconid
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Dec 20, 2005 9:04 am

Re: Tools for automated migration to Joomla 1.5

Post by draconid » Sat Oct 14, 2006 12:11 pm

Phailure wrote: EDIT3: Fatal error: Call to a member function getCfg() on a non-object in /home/.hoofman/phailure/betan4rd/libraries/joomla/document/error/error.php on line 127

is what it gives me :(
I'm having this same error when trying to install - having made the changes suggested above regarding swapping message to callback.
Last edited by draconid on Sat Oct 14, 2006 12:13 pm, edited 1 time in total.

User avatar
tjay
Joomla! Explorer
Joomla! Explorer
Posts: 325
Joined: Thu Aug 18, 2005 1:50 am
Location: New Orleans
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by tjay » Sat Oct 14, 2006 1:14 pm

viktor wrote:
I am able to pass through all this and successfully completed installation.

However, when I click on Admin icon on the success screen I get the following error.

JFTP::_passive: Unable to obtain IP and port for data transfer

How to get through this?

Thanks
Same problem here, I am sure it is something that will make me feel silly when I figure it out
This day it is my wish that I helped you to live

mixed
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Sep 02, 2005 7:50 am
Location: Sydney, Australia
Contact:

Re: Tools for automated migration to Joomla 1.5

Post by mixed » Sun Oct 15, 2006 3:16 am

eyezberg wrote: I just tried to test the migration tool. You may want to update the download in the first post to point to the new Forge version.. ;)
Since this topic is now sticky, I agree that it would be helpful David if you updated your first page to include the link to the forge, and perhaps delete the attached file, so you don't have people downloading the old code and then raising support issues here.  Took me a while to find the link to the latest version but I will go and download it and give it a go.

Thanks for all your work on it!!

Spencer
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Tue Sep 19, 2006 8:09 pm

Re: Tools for automated migration to Joomla 1.5

Post by Spencer » Mon Oct 16, 2006 12:26 am

Spencer wrote: Wher do I find the: Old table prefix  ??

I get this error when I try to upload: Upload failed - archive unpack error

Had no problem packing old site.

Read all docs and am stuck.
Anyone?

User avatar
ianmac
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4785
Joined: Sat Sep 24, 2005 11:01 pm
Location: Toronto, Canada

Re: Tools for automated migration to Joomla 1.5

Post by ianmac » Mon Oct 16, 2006 4:37 am

sorry folks, didn't keep up with this thread...

the changes I suggested are not a fix to any particular problem...  merely a fix to a problem with the error handler that prevents more helpful output from being displayed...

If anyone is having trouble I can try to help, but I can't make any guarantees...

Good luck,
Ian

diri
Joomla! Guru
Joomla! Guru
Posts: 702
Joined: Wed Sep 21, 2005 9:27 am
Location: Somewhere

Re: Tools for automated migration to Joomla 1.5

Post by diri » Tue Oct 17, 2006 10:14 am

Tested migration from 1.0.11 again. I used com_migrator from forge (archive claims to be 1.0.8, version shown is 1.0.7).

This time table #__sections has not been dumped. ;

But:
After installation with those migration data frontend of new installation showed an error message only with some different reasons.

Only issue I found with full debugging enabled has been something like "article(0) not found".

Maybe this is of any help.

System information:
v1.0.11: Windows, PHP5, mysql5, apache2.2.3
v1.5b: Linux, apache1.xy, PHP5, hosted environment with own sub-domain

Installing sample data worked fine so far.

User avatar
ccondrup
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 219
Joined: Tue Aug 23, 2005 9:54 am
Location: Oslo

Re: Tools for automated migration to Joomla 1.5

Post by ccondrup » Wed Oct 18, 2006 3:28 am

Spencer: Your old table prefix is most likely mos_ or jos_ - you find your prefix by using phpmyadmin to view your old database.


My feedback on the migrator tool:
I just downloaded the com_migrator from the Joomla! Forge, and used it on a a8eJoomla 1.0.10 install.
It worked flawlessly, although I feel such a tool should include the old sites META description and keywords - they are not subject to change just with a site upgrade.

Ran into this problem when choosing migrate old data in the setup of J!1.5 beta:
Notice: Undefined offset: 0 in /home/user/public_html/joomladir/libraries/joomla/database/database.php on line 747
This notice unfortunatly causes headers to be sent, so after this, there are 5 lines of "headers already sent" errors, and then the whole page breaks... differently in each browser:

1a) In Firefox 1.5.0.7, after loading the migration script and pressing "next", the same errors as in IE are shown (see attachement), but here the Firefox dialog prompt "Do you want to send POSTDATA again?" (image) is displayed at the same time. Other than those errors it's a blank page, nowhere to click except for ordinary browser back... which I don't use in these situations, but a lot of people do, which would probably mess up the installation?

1b) In Internet Explorer 6, when I press next to load the migration data, it shows the same errors, but also the initial page below, see the attached screenshot. The page reloads, it reports that "SQL script installed successfully", but at the same time it has blanked out all the fields I just entered above, and well, there are those same above mentioned errors. However I cannot just fill the fields again and proceed, it just stops the entire process at this page. If I try to fill the remaining fields and press next, theres just a 404 error, which I'm guessing has to do with the javascript behind the next button not being correct after the page reloaded with errors.

* In both cases the data is migrated into the new database, so that part is working.
Now, are those errors caused by a bug in J!1.5 beta or the migration tool? I don't know, so I am ranting away here:

Current status:
I can get 1.5 beta running as a clean install without data, and with sample data. Works fine.

I can get the migrated content installed by first going through step 1 (a or b) and then just run the installer again, but choosing "backup old tables", not installing any data, and then renaming the bak_ tables to jos_ again.

... But with the migrated data I cannot see the frontend, I get this error:
Fatal error: Call to a member function on a non-object in /home/user/public_html/joomladir/libraries/joomla/common/abstract/tree.php on line 42
I can however access the backend with the migrated data - all is correctly displayed in backend, all content and users from a8eJoomla 1.0.10-0.3 are present.

I thought of one thing: I had the extended menu module installed on the old site. With this I had created a lot of submenus.  So I searched that tree.php error, read threads -1- -2- and -3- . It seems that I have to go through each menu item and declare a type. That is gonna take a while with 150+ items..

Is it supposed to be like that? In that case, anyone that had mod_exmenu installed should prepare for quite some work when migrating!

Linux server, shared hosting env.
PHP 4.4.2 (cgi w/ suphp)
MySQL 4.1.21-standard

I'll update here after going through all menuitems to report if it actually worked... thanks in advance for any hints anyone may have, hope this was not way offtopic. At this point it seems there will be need for a separate forum with its own team just for migration, I think a lot of ppl will need assistance...
Thanks for your time. - Chris.
You do not have the required permissions to view the files attached to this post.
Did you know there's a Joomla irc channel? Chat to Joomla people live 24/7 - Join #joomla on the Freenode network ( irc.freenode.net )


Locked

Return to “Joomla! 1.5 Bug Reporting”