Probl. med tekst i en modul

Diskusjon og informasjon om oversettelser

Moderators: sone12, Per Yngve Berg

edorf67
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Wed Apr 18, 2012 10:41 pm

Probl. med tekst i en modul

Postby edorf67 » Fri May 29, 2015 8:58 pm

Hei!
Har kjøpt en "template" som benytter diverse moduler, hvor noen av disse har engelsk språk. Jeg har satt innstillingene i Joomla til norsk, både for siden og admin. Jeg prøver nå å endre denne teksten til norsk, men ute å lykkes. Jeg har prøvd å overstyre ordene, uten at det hjalp (gjorde dette for alle mulighetene, altså både nettsted og admin, både for norsk og engelsk - uten hell). Jeg har også søkt i filene for modulen (eks: mod_sp_quickcontact) etter feks "Message..." uten å finne dette, så da lurer jeg på om noen av dere har tips til hvor dette ordet (og andre) kan "gjemme" seg? I så fall hadde det vært strålende, da jeg begynner å bli rimelig lei av å "bænge" hodet mot veggen... :'(

PS! For ordens skyld: Jeg er ny i Joomla....om det ikke var åpenbart :laugh:

På forhånd takk for svar og ha en fortsatt fin kveld! :)

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24402
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Probl. med tekst i en modul

Postby Per Yngve Berg » Sat May 30, 2015 7:14 am

Har du satt på Debug og Language Debug i Global Konfigurasjon?

Da kan du se om strengene blir oversatt ved at det settes tegn rundt strengen.

Streng som er oversatt: **Streng**
Streng som er oversatt, men mangler i språkfil: ??Streng??
Streng som ikke er oversatt: Streng


Oversettelsen foregår ved å bruke funksjonen JTEXT i koden.

Code: Select all

<?php echo JText::_('TPL_BEEZ3_SKIP_TO_CONTENT'); ?>


Du må også ha et norskt språkpakke til malen og moduler/komponenter

eks. språkfil for Beez3-malen: /templates/beez3/language/en-GB/en-GB.tpl_beez3.ini

edorf67
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Wed Apr 18, 2012 10:41 pm

Re: Probl. med tekst i en modul

Postby edorf67 » Sat May 30, 2015 10:01 am

Takk for tipset, Per Yngve!
Slo nå på Debug og da kommer det opp tekst både med ** og ??
I tilfellet nevnt ovenfor, kommer det opp **Message...** noe som, om jeg har forstått deg riktig, betyr at strengen er oversatt. Ergo burde den vel dukke opp når jeg søker etter den i "Overstyringer"? Det kommer opp ett tilfelle under "Engelsk - Brukersted". Denne har jeg overstyrt, uten at det var til hjelp.

Under "Innhold" ligger det 1 språkfil, Engelsk. Jeg vil tro at "Overstyring" ikke har påvirkning på denne filen? Jeg prøvde også å avpublisere denne filen for å se om det kunne være til hjelp, men det var det dessverre ikke.

Norsk språkpakke til malen, finnes dessverre ikke.
Har prøvd å se etter språkpakke til modulen (SP Quick Contact), men ikke funnet den så langt. Alternativet for meg nå, slik jeg ser det, er å se om jeg kan finne den engelske språkfilen som ligger under "Innhold" og se om jeg ikke kan endre teksten der. Ser ingen annen mulighet, men om du har forslag til noe annet, mottas det med takk! :-)

edorf67
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Wed Apr 18, 2012 10:41 pm

Re: Probl. med tekst i en modul

Postby edorf67 » Sat May 30, 2015 4:28 pm

Ups! Prøvde å endre i koden, men det skulle jeg vist ikke ha gjort. Nå forsvant teksten helt, og det nytter ikke å endre tilbake igjen... Ja, ja, der lærte jeg det :-[

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24402
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Probl. med tekst i en modul

Postby Per Yngve Berg » Sat May 30, 2015 10:18 pm

Språkfilene kan ligge på flere steder, under language eller under language for komponenten.
Nederst på siden med debug på, er det en liste over språkfiler som er lastet og hvilke som ikke kan lastes.

For å oversette kopierer du f.eks. language/en-GB/en-GB.tpl-beez3.ini til language/nb-NO/nb-NO.tpl-beez3.ini og oversetter fila med en tekst-editor. Du kan bruke standard editor på Linux. Bruker du Windows, last ned Notepad++ fra download.com. Filen skal lagres som utf8 uten BOM.

edorf67
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Wed Apr 18, 2012 10:41 pm

Re: Probl. med tekst i en modul

Postby edorf67 » Sun May 31, 2015 12:08 am

Takk for tipset, Per Yngve! Det løste problemet! :-)
Trodde språkfilene for en modul lå i modul-mappen, men der har jeg blitt "lurt" ;-)

Tusen takk for hjelpen! :-)


Return to “Oversettelser”

Who is online

Users browsing this forum: No registered users and 3 guests