No visual integration for joomla/phpbb

Discuss the integratoin of phpbb and Joomla! here.

Moderator: General Support Moderators

egrohs
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Sun Jan 30, 2011 4:52 am

No visual integration for joomla/phpbb

Postby egrohs » Wed Mar 02, 2011 4:39 am

Disclaimer: I am a noob in every sense of the word here so please be patient.

So I followed the steps outlined on Mehdi's page for bridge installation, and when all was said and done, I do not have visual integration. When I click on my forum button in the top menu, I get taken to my phpbb page. It is just not within my joomla page and there is no link to go back to my joomla homepage so I have to click back on the browser. Pretty confident I did something wrong here.

Also, the steps on Mehdi's page didn't exactly go as planned. One thing I was unclear on was #5, the edit configuration of my bridge. My site name, the root, is http://www.njteachertalk.com. My forum is located at http://www.njteachertalk.com/phpbb3. This is how I edited:

$joomIntegrate = 3;
$joomUrl="http://njteachertalk.com/";
$joomRel= "../"; // relative path from phpbb
$joomQS="option=com_phpbb&Itemid=53"; //you might want to override the Itemid

Also, for #6, although I uploaded the hacked and bridge folders to the phpbb3 root using FTP, the style, bridgesilver does not show up on the administration panel of php under styles. It does show up in the root directory in FTP under styles. In addition, when I go to authentication in the admin panel of php, and scroll for a method, joomla 15 is not there. Just db, ldap, and apache.

What did I do wrong? Please help. I have been working on this all week before I decided to post. Very frustrated.

User avatar
RussW
Joomla! Exemplar
Joomla! Exemplar
Posts: 9352
Joined: Sun Oct 22, 2006 4:42 am
Location: Sunshine Coast, Queensland, Australia
Contact:

Re: No visual integration for joomla/phpbb

Postby RussW » Wed Mar 02, 2011 4:49 am

Bridges are just that - Bridges between applications, they integrate user login, but visual styles are still integral only to each application, you will need to modify the theme/template in phpbb to match what you want and make the two applications look similar.

As for the steps you followed, you will need to discuss this with the "bridge" developer, this is the Joomla! forums and the bridge configuration is not directly part of Joomla!

but, hazarding a guess based on the information given;

Code: Select all

  $joomIntegrate = 3;
  $joomUrl="http://njteachertalk.com/";
  $joomRel= "../"; // relative path from phpbb
  $joomQS="option=com_phpbb&Itemid=53"; //you might want to override the Itemid


Code: Select all

  $joomIntegrate = 3;    << Sorry, No Idea
  $joomUrl="http://www.njteachertalk.com/";   << add "www"
  $joomRel= "../"; // relative path from phpbb  << looks ok
  $joomQS="option=com_phpbb&Itemid=53"; //you might want to override the Itemid  << item id would be the itemid of the link in J! to phpbb3
Joomla! on the fabulous Sunshine Coast...
hotmango, web & print http://www.hotmango.me/
The Styleguyz https://www.thestyleguyz.com/

jezthomas
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri May 25, 2012 6:16 am

Re: No visual integration for joomla/phpbb

Postby jezthomas » Wed Jun 06, 2012 4:42 am

egrohs wrote:Disclaimer: I am a noob in every sense of the word here so please be patient.

So I followed the steps outlined on Mehdi's page for bridge installation, and when all was said and done, I do not have visual integration. When I click on my forum button in the top menu, I get taken to my phpbb page. It is just not within my joomla page and there is no link to go back to my joomla homepage so I have to click back on the browser. Pretty confident I did something wrong here.

Also, the steps on Mehdi's page didn't exactly go as planned. One thing I was unclear on was #5, the edit configuration of my bridge. My site name, the root, is http://www.njteachertalk.com. My forum is located at http://www.njteachertalk.com/phpbb3. This is how I edited:

$joomIntegrate = 3;
$joomUrl="http://njteachertalk.com/";
$joomRel= "../"; // relative path from phpbb
$joomQS="option=com_phpbb&Itemid=53"; //you might want to override the Itemid

Also, for #6, although I uploaded the hacked and bridge folders to the phpbb3 root using FTP, the style, bridgesilver does not show up on the administration panel of php under styles. It does show up in the root directory in FTP under styles. In addition, when I go to authentication in the admin panel of php, and scroll for a method, joomla 15 is not there. Just db, ldap, and apache.

What did I do wrong? Please help. I have been working on this all week before I decided to post. Very frustrated.


Hi egrohs,

Hope you got your mehdi bridge problem sorted.
I'm also looking to use this bridge to integrate joomla and phpbb and you've managed to get further than me! So I thought I'd ask you something about the instructions on the mehdi bridge website as I am halfway through but am struggling to understand them. I've searched all over the forum, and have emailed mehdi for advice, but there seem to be a lot of people asking questions and not many answers.
From the instructions on the mehdi bridge website,
http://www.mehdiplugins.com/misc/phpbbjoom.htm
I have reached number 3 – Install joomla component. It says install it in joomla’s backend, and then , ‘create an "External link" Item that directly point to your phpbb install (example: http://www.mysite.com/phpbb/).’.
I’m guessing that this means that from Extension Manager I want to use the Install from URL option? Or is this create an external link something completely different, that I have to do after the installation?

From my joomla admin page for my site, I choose Extensions from the menu, then Install/Uninstall.
I then use the url http://localhost/joomla15sample/phpbb3/ which points to where my forum is running.
I get the message :
Unknown Archive Type


Warning: file_put_contents(/Applications/XAMPP/xamppfiles/htdocs/joomla15sample/tmp/) [function.file-put-contents]: failed to open stream: Is a directory in /Applications/XAMPP/xamppfiles/htdocs/joomla15sample/libraries/joomla/filesystem/file.php on line 304
Any ideas what this means and how I can resolve it?

Thanks for your help,

Jez


Return to “phpbb - Joomla! Integration”

Who is online

Users browsing this forum: No registered users and 2 guests