PhpBB And Mambo Problem

Discuss the integratoin of phpbb and Joomla! here.

Moderator: General Support Moderators

Locked
Fossil_Sys
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Aug 21, 2005 9:52 am

PhpBB And Mambo Problem

Post by Fossil_Sys » Sun Aug 21, 2005 10:00 am

I posted over on mamboserver.com, but it seems there's some huge uproar going on over there. SO, here I am. I'm just going to paste my other post over here..
-------

This is going to be tough to explain without writing a two page problem here, but I'll try and sum it up as best I can.

A friend and I have a website with mambo and phpBB. We wanted to have a "members only" type download section on the site. The problem was people got confused and we recieved a ton of email because it was two different logins (one for the forums, one for mambo). So.. my friend decided to redo the whole thing and downloaded a plugin of some type for mambo and joined the mambo and phpbb login as one. In the process we lost ALL of our members on the forums and site. I don't know the plugins name, but I noticed the cookie name for both mambo and phpBB was mosplus. Googled that, and it seems like that's probably what he installed, mosplus. Anyhow, it worked just fine for a while.

Here's where the problem starts. This friend and I had a disagreement about w/e and he left so now it's me. A random passer by to our forums let me know he couldn't log in. I know mine worked so I tried making a new name to login and got this.

----------
phpBB : Critical Error

Error doing DB query aro groups

DEBUG MODE

SELECT g.* FROM mos_core_acl_aro_groups AS g INNER JOIN mos_core_acl_groups_aro_map AS m ON m.group_id = g.group_id INNER JOIN mos_core_acl_aro AS a ON a.aro_id = m.aro_id WHERE a.value = 92

Line : 167
File : sessions.php
-----------

If you make a new account and login from the front page of our website, it works fine. You can browse the site and forums as one, the way it should work. However, If you login from the phpbb login link on the forums, you get the error. I'm pretty much clueless as to what to do because I didn't install it. Not only that, I've never been very good with php, phpbb or mambo to begin with. At this point just "unhooking" the forums from mambo is fine with me. I'll use an .htaccess file or something for the members only section and take the login form off the front page. Any ideas on what is causing this problem? Or at least a way to uninstall whatever it is that links them together? I'd could always redo the whole thing but that would be twice in a few months, the members would be unhappy to say the least. So I'd like to try and fix this without making any major changes if at all possible. Also, I have made no changes that would have caused the forum login to stop working.

Forgive me if I'm posting in the wrong place, or this plugin isn't supported here, etc etc. I've been searching for days (not an exaggeration) and this is the only place I have found to post. Any help would be greatly appreciated.

User avatar
mark
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Thu Aug 18, 2005 10:58 pm

Re: PhpBB And Mambo Problem

Post by mark » Mon Aug 22, 2005 10:45 am

It might be worth you also posting your question here at

http://demo.impleri.net/forums/viewforum.php?f=2 - where you can get support for Mambo plus  - mambo phpBB integration

Mark

Fossil_Sys
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Aug 21, 2005 9:52 am

Re: PhpBB And Mambo Problem

Post by Fossil_Sys » Mon Aug 22, 2005 10:48 am

Thank you sir, will do. :)


Locked

Return to “phpbb - Joomla! Integration”