Problema com url http nos artigos

Moderator: ariadneduvessa

Post Reply
portugaonline
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Mar 02, 2018 4:09 pm

Problema com url http nos artigos

Post by portugaonline » Fri Mar 02, 2018 4:20 pm

Boas,

Estou com um problema nos artigos em que ao colocar um url com http, ao gravar ele converte automaticamente para https.
Já desliguei o editor, já coloquei directamente no código, e fica sempre com https.

Alguém já teve o mesmo problema que possa me ajudar.

portugaonline
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Mar 02, 2018 4:09 pm

Re: Problema com url http nos artigos

Post by portugaonline » Fri Oct 26, 2018 9:30 am

Bom dia,

Ainda estou com o mesmo problema, coloco um link externo num artigo que é http, e o joomla ao guardar o artigo coloca o link em https, e eventualmente o link dá erro ao abrir. Tenho o meu site com SSL, já desativei da configuração global o Forçar HTTPS, e continua igual. Alguém consegue me ajudar.

danielosasp
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Nov 14, 2018 12:09 pm

Re: Problema com url http nos artigos

Post by danielosasp » Thu Nov 22, 2018 1:55 pm

Também Acho que isso é estranho.

Billyspencer
I've been banned!
Posts: 23
Joined: Tue Mar 19, 2019 12:39 am
Contact:

Re: Problema com url http nos artigos

Post by Billyspencer » Tue Mar 19, 2019 11:36 am

portugaonline wrote:
Fri Mar 02, 2018 4:20 pm
Boas,

Estou com um problema nos artigos em que ao colocar um url com http, ao gravar ele converte automaticamente para https.
Já desliguei o editor, já coloquei directamente no código, e fica sempre com https.

Alguém já teve o mesmo problema que possa me ajudar.
As novas versões do Joomla estão desenhadas para funcionar em Https desde que o teu dominio tenha um certificado atribuido.

Podes editar essa opção directamente no ficheiro htaccess, mas aconselho a usar sempre o https pois existem versoes do google chrome que já nem deixam abrir websites em protocolo seguro.

portugaonline
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Mar 02, 2018 4:09 pm

Re: Problema com url http nos artigos

Post by portugaonline » Tue Mar 19, 2019 12:37 pm

O meu dominio usa https e funciona bem.

o meu problema são os sites externos, em que quando insiro um link de um site que usa apenas http e não tem certificado, automaticamente o joomla coloca https, e assim essas ligações dão sempre erro.

Billyspencer
I've been banned!
Posts: 23
Joined: Tue Mar 19, 2019 12:39 am
Contact:

Re: Problema com url http nos artigos

Post by Billyspencer » Wed Mar 20, 2019 8:24 pm

portugaonline wrote:
Tue Mar 19, 2019 12:37 pm
O meu dominio usa https e funciona bem.

o meu problema são os sites externos, em que quando insiro um link de um site que usa apenas http e não tem certificado, automaticamente o joomla coloca https, e assim essas ligações dão sempre erro.
Eu nunca vi esse problema antes. Mas tenta postar directamente no forum em ingles, la tem muitos mais caras para ajudar.

Lembro-te que se traduzires o artigo por google translate, menciona isso! Ja vi membros que ficam "lixados" quando o ingles não está 100 % correcto

carloscsilva
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Mon Apr 22, 2019 1:44 pm

Re: Problema com url http nos artigos

Post by carloscsilva » Mon Apr 22, 2019 3:01 pm

pode ser um redirecionamento por parte do teu host ou domain registar. Ja verificaste? por exemplo na cloudflare se activares o https ele fica activo em todos os URLS


Post Reply

Return to “Portuguese Forum”