Read More ... Link parameter in Section Blog Layout is ignored.

Locked
zizani
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Aug 18, 2007 11:28 pm

Read More ... Link parameter in Section Blog Layout is ignored.

Post by zizani » Fri Jan 04, 2008 12:50 am

By default the parameter is global. The Read More  ... Links still do not appear on content articles after setting the parameter to "show".

Regards,
Last edited by zizani on Mon Jan 07, 2008 7:08 pm, edited 1 time in total.

 
User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Read More ... Link parameter in Section Blog Layout is ignored.

Post by mcsmom » Fri Jan 04, 2008 2:45 pm

SO you are saying that in globalcontent parameters  you have it set to "show.'?

Check  the parameter settings for (a) the menu link  and (b) the article itself, since these should both override the global settings.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

zizani
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Aug 18, 2007 11:28 pm

Re: Read More ... Link parameter in Section Blog Layout is ignored.

Post by zizani » Sat Jan 05, 2008 6:40 am

mcsmom wrote: SO you are saying that in globalcontent parameters  you have it set to "show.'?

Check  the parameter settings for (a) the menu link  and (b) the article itself, since these should both override the global settings.
Yes, on Section Blog Layout menu item page, the Read More ... Link parameter by default was "Use Global", and I set it to "Show", expecting that Read More links would show on every article in the section I created. They did not.

I've downloaded the RC4, and as a test, have created a section with 2 categories containing one article each. The section uses the section blog layout, which seems to be the only place to set the Read More ... Link parameter.

Regards,

zizani
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Aug 18, 2007 11:28 pm

Re: Read More ... Link parameter in Section Blog Layout is ignored.

Post by zizani » Mon Jan 07, 2008 5:18 am

zizani wrote:
mcsmom wrote: SO you are saying that in globalcontent parameters  you have it set to "show.'?

Check  the parameter settings for (a) the menu link  and (b) the article itself, since these should both override the global settings.
Yes, on Section Blog Layout menu item page, the Read More ... Link parameter by default was "Use Global", and I set it to "Show", expecting that Read More links would show on every article in the section I created. They did not.

I've downloaded the RC4, and as a test, have created a section with 2 categories containing one article each. The section uses the section blog layout, which seems to be the only place to set the Read More ... Link parameter.

Regards,
I set both Read More ... Link and Show Intro Text parameters to "Show" , the Read More Link still does not appear. Have anyone tried and run into this problem with RC4?

Regards,

User avatar
1nf1n17yLOVE
Joomla! Explorer
Joomla! Explorer
Posts: 279
Joined: Wed May 17, 2006 10:52 pm
Contact:

Re: Read More ... Link parameter in Section Blog Layout is ignored.

Post by 1nf1n17yLOVE » Mon Jan 07, 2008 6:25 am

Im not sure about your setup, but read more links works here, even each read more css page class suffix creates a relative read more_suffix css.

example

tarif-star.de

Ok i use only category blog layout ....

So not sure
Last edited by 1nf1n17yLOVE on Mon Jan 07, 2008 6:34 am, edited 1 time in total.

zizani
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Aug 18, 2007 11:28 pm

Re: Read More ... Link parameter in Section Blog Layout is ignored.

Post by zizani » Mon Jan 07, 2008 8:44 am

1nf1n17yLOVE wrote: Im not sure about your setup, but read more links works here, even each read more css page class suffix creates a relative read more_suffix css.

example

tarif-star.de

Ok i use only category blog layout ....

So not sure
Thanks for the reply. It works. I did not know that in order for Read More ... Link to show there must be a special line to insert into the text by clicking on Read More button. Parameters can be left at their default value which is "Use Global".

Regards,

User avatar
3wP
Joomla! Explorer
Joomla! Explorer
Posts: 261
Joined: Mon May 14, 2007 6:29 pm
Location: Norway

Re: Read More ... Link parameter in Section Blog Layout is ignored.

Post by 3wP » Mon Jan 07, 2008 12:31 pm

Good then :)

Can someone move this to solved?

Less post = less mess ;)

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Read More ... Link parameter in Section Blog Layout is ignored.

Post by mcsmom » Mon Jan 07, 2008 12:34 pm

zizani,

please go to your first post and modify it by changing the icon to solved.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: Read More ... Link parameter in Section Blog Layout is ignored.

Post by Robin » Wed Jan 09, 2008 9:07 pm

moving to resolved

 

Locked

Return to “Q&T 1.5.x Resolved”