[SOLVED] seo router -svn 9840 vs 9909: category-blog under section-blogs

Locked
User avatar
rufuz
Joomla! Explorer
Joomla! Explorer
Posts: 303
Joined: Wed May 09, 2007 10:07 am
Location: Rome
Contact:

[SOLVED] seo router -svn 9840 vs 9909: category-blog under section-blogs

Post by rufuz » Tue Jan 08, 2008 3:00 pm

svn build 9909  upgraded  from 9840 (seo always on) , what changed:

svn 9840:
I had in main menu a section-blog of "food" section  and under this  a category-blog of "fruits" category.

in fruits category there is an article "apples.html" not linked directly in the main menu.

This was working fine. 
-When clicked on a linked title of apples.html, page (with the set-up of fruit category blog page) showed up correctly.

-Breadcrumbs showed the right path ---------  home>food>fruits>apples.html  and each link perfecly gave the right blog page (e.g. fruits landing on "fruits.html" category-blog page)

now svn 9909:

While main menu section-blog page works, title links of "apples.html" from frontpage or from food section-blog page, lands on a blank page.
If I link directly article "apples.html" in main menu under category-blog "fruits", title links start working (this was necessary before), though it is not a great solution:

1. In breadcrumbs -----  home>food>fruits>apples.html  "fruits" link doesn't  redirect to category-blog page but to a blank page
2. Is absolutely annoying to link every article in main menu.

resuming, it seems that a -category-blog menu item- under a -section-blog item menu-  structure doesn't route anymore as in build 9840, and I don't find an alternative  way to do it.

If I switch off seo "trinity" all return to work as expected.

bye

ricc.
Last edited by rufuz on Wed Jan 09, 2008 5:04 pm, edited 1 time in total.

 
AmyStephen
Joomla! Champion
Joomla! Champion
Posts: 7056
Joined: Wed Nov 22, 2006 3:35 pm
Location: Nebraska
Contact:

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by AmyStephen » Tue Jan 08, 2008 3:05 pm

Ricc -

The article apples.html - is it in the fruits category blog?

If so, I assume the URL is:

http://example.com/section-menu-item/ca ... pples.html

And when you directly link to apples.html, are you using the URL created by the blog? (The example I gave previously?)

Amy

User avatar
rufuz
Joomla! Explorer
Joomla! Explorer
Posts: 303
Joined: Wed May 09, 2007 10:07 am
Location: Rome
Contact:

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by rufuz » Tue Jan 08, 2008 3:36 pm

AmyStephen wrote: The article apples.html - is it in the fruits category blog?
exactly...
right... 

so the difference is:    -svn 9840: this adress shows a page apples.html in a layout that is the same assigned to "fruits" category. 
                              -svn 9909: this adress shows a blank page.

unfortunately for me using section-blog layout is a must, if I needed  category-blogs only in first menu level life would be easier, they work fine...
AmyStephen wrote: And when you directly link to apples.html, are you using the URL created by the blog? (The example I gave previously?)
I'm using article internal link (not ext url), under "fruits" category-blog menu item, under "food" section-blog that is first menu level.

thanks Amy

bye :)

ricc.

 

AmyStephen
Joomla! Champion
Joomla! Champion
Posts: 7056
Joined: Wed Nov 22, 2006 3:35 pm
Location: Nebraska
Contact:

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by AmyStephen » Tue Jan 08, 2008 5:33 pm

I created a Section called Fruit with three Categories: Apples, Bananas, and Orange, each with several articles.

I created a Menu Item called Fruit Section Blog that is an Articles >>Section / Blog for the Fruit section.

I created a Menu Item called Fruit Apples Category Blog, parent is above menu item, that is an Articles >>Category / Blog for the Apples category.

I created an Article named Uncategorized Article (It has not Section / Category). Instead of that article, I crated a link to one of the Apple Category articles: Red Delicious. The URL I used was fruit-section-blog/fruit-apples-category-blog/1-apples/7-red-delicious.html.

All looks fine --> http://joomlaplace.org/sefurls

Ricc - I will gladly give you Admin access to set up the scenario if I did not understand. But, I am unable to reproduce an error.

Please let me know.
Amy :)

++++

Edit -


Also Red Delicious links to it's a proper page from the Frontpage - and from the Section Blog. (I say "a" proper page because this is an example of user generated duplicate content - so - J! has to pick one to link to - and it does.)

All Breadcrumbs are fine. Links on Breadcrumbs for all levels are fine.
Last edited by AmyStephen on Tue Jan 08, 2008 5:50 pm, edited 1 time in total.

User avatar
rufuz
Joomla! Explorer
Joomla! Explorer
Posts: 303
Joined: Wed May 09, 2007 10:07 am
Location: Rome
Contact:

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by rufuz » Tue Jan 08, 2008 9:36 pm

AmyStephen wrote: I created an Article named Uncategorized Article (It has not Section / Category). Instead of that article, I crated a link to one of the Apple Category articles: Red Delicious. The URL I used was fruit-section-blog/fruit-apples-category-blog/1-apples/7-red-delicious.html.
this step is not perfectly clear to me...  Yes you can pm me with an access, to understand better :)
AmyStephen wrote: Also Red Delicious links to it's a proper page from the Frontpage - and from the Section Blog. (I say "a" proper page because this is an example of user generated duplicate content - so - J! has to pick one to link to - and it does.)
yes I see a duplicated content... :(

Amy you are so great, and this idea to post an entire joomla installation wonderfull. Very usefull.

Unfortunately my site is still offline, I'm only waiting to solve this problem...

What make me esitate is the fact I have 2 version of my site, as said 9840 and 9909.

The first one is perfectly working, no need to create dummy articles, no duplicates, absolutely easy and plain workflow.

For the second one, the best solution is what you showed, but I'm just curious about what happened in the upgrade...

If you have the change to downgrade that installation, you could confirm...

thank you very very much, as always!  ;)

bye

ricc.

User avatar
rufuz
Joomla! Explorer
Joomla! Explorer
Posts: 303
Joined: Wed May 09, 2007 10:07 am
Location: Rome
Contact:

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by rufuz » Wed Jan 09, 2008 2:36 pm

Amy, I -think- I got it...

Look at vehicles section I created...  it works like I wanted...

section    - vehicles
category  - cars
articles    - ford Torino (love it  ;) )

link to article is always (from front page, sect blog & cat blog): vehicles/cars/6-cars/15-ford-torino.html  so no duplicates and readable section/category structure.

breadcrumbs works always fine ---- vehicles is linked to a working vehicles.html section blog page, cars to a working cars.html blog page.

can you confirm?

After some investigation and  found:

upgrading from -svn 9840 to 9909 doesn't change routing, and in the changelog there's no trace of the change I initially supposed.

I don't exactly what happened to my site but after dumping my database of 9840 to 9909 I checked all was working, let me intending the reason of my blank pages was not  the upgrade.

Even I couldn't see any differences between old and new db, apart some new articles I wrote in other sections, 
solution was, after re-dumping newest database, to delete menu items and redo them.  That worked and I got back full section/category blog functionality...

I wait your opinion... ( crossing my fingers, just in case you could find somenthing I missed in this process  ;) )

thanks a lot!!!

bye

ricc.
Last edited by rufuz on Wed Jan 09, 2008 2:40 pm, edited 1 time in total.

User avatar
3wP
Joomla! Explorer
Joomla! Explorer
Posts: 261
Joined: Mon May 14, 2007 6:29 pm
Location: Norway

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by 3wP » Wed Jan 09, 2008 2:51 pm

SEF issues are also being worked on right now so you might want to try things again as soon as our belowed 1.5 goes stable ;)

apart from that know amy will b'back with good feedback on the topic in general :)
Last edited by 3wP on Wed Jan 09, 2008 2:52 pm, edited 1 time in total.

AmyStephen
Joomla! Champion
Joomla! Champion
Posts: 7056
Joined: Wed Nov 22, 2006 3:35 pm
Location: Nebraska
Contact:

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by AmyStephen » Wed Jan 09, 2008 2:57 pm

Looks good, Ricc. Just like we want it to look. Thanks for double-checking - it's very important.

There is one SEF URL issue that Ian has provided a patch for - and that has to do with placing a non-SEF URL into an article or a menu item, then, turning on SEF URLs for your site. Joomla! was not converting those correctly. The patch has corrected that error. 3wP - that patch is what Elin asked that you test. But, the issue is not related to this question.

The work that Ricc has been looking into has to do with system generated duplicate content, something he and I have both been watching for in J! v 1.5 for a long time. If you use SEF URLs, Joomla! does not create this type of duplication.  Ricc is confirming that fact, as have I, with the testing above.

Thanks! And, Ricc, thanks for taking this time to do that for our community. PERHAPS we are getting closer?  8)

Hope so!
Amy :)

User avatar
rufuz
Joomla! Explorer
Joomla! Explorer
Posts: 303
Joined: Wed May 09, 2007 10:07 am
Location: Rome
Contact:

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by rufuz » Wed Jan 09, 2008 3:15 pm

3wp I think issues you're talking about are related to this track http://joomlacode.org/gf/project/joomla ... em_id=8936

Is something about translating, and if I understand well, by the moment to override it is necessary to manually sef translate links in your content... 


Amy, yes we are getting closer, pesonally I feel I can go online now... (next week I'll deposit a logo, buy some domains, and start a new adventure. Hope uploading will not a hard task! ) 

if you agree I can put a solved mark to this thread

bye

ricc.   

User avatar
3wP
Joomla! Explorer
Joomla! Explorer
Posts: 261
Joined: Mon May 14, 2007 6:29 pm
Location: Norway

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by 3wP » Wed Jan 09, 2008 3:35 pm

i am just to eager lol..


i love joomla  :pop  :-[

AmyStephen
Joomla! Champion
Joomla! Champion
Posts: 7056
Joined: Wed Nov 22, 2006 3:35 pm
Location: Nebraska
Contact:

Re: seo router -svn 9840 vs 9909: category-blog under section-blogs stops workin

Post by AmyStephen » Wed Jan 09, 2008 4:19 pm

Yes, please. Solved is a-okay with me.  8)

Thanks!
Amy

 

Locked

Return to “Q&T 1.5.x Resolved”