Bug in mailto link. (email icon in content link)

Post Reply
User avatar
rasterblaster
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 225
Joined: Wed Sep 12, 2007 4:17 am
Location: Melbourne Australia
Contact:

Bug in mailto link. (email icon in content link)

Post by rasterblaster » Tue Feb 05, 2008 6:24 pm

I have been wonering why my mail to a friend link looks so crappy, and after looking at the code, I see there is a template that is called that does not exist in the joomla install. (1.5 stable or nightly...)

the screenshot is attached below of what it looks like...

The source of the popup window for the mailto has the line




Now in that directory there is no template.css

Ideas?  Fixes???
You do not have the required permissions to view the files attached to this post.
Have a look at some cool Sci-fi art and Science Fiction Sculpture by Martin Dolan here...
http://www.marty.com.au Made from scrap metal, chrome and other found objects!

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18628
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Bug in mailto link. (email icon in content link)

Post by infograf768 » Wed Feb 06, 2008 9:48 am

On last SVN here the source is


No other CSS is called for.

As Milkyway default is
a:link, a:visited {

text-decoration: none;

font-weight: normal;

}



a:hover {

text-decoration: underline;

font-weight: normal;

}
The Close Window link is pure old style html  ;)
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18628
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Bug in mailto link. (email icon in content link)

Post by infograf768 » Wed Feb 06, 2008 10:20 am

Looks like you are using a template override which does include these css and not default template.
One should use in the component.php override:

baseurl ?>/templates/rhuk_milkyway/css/template.css" type="text/css" />

direction == 'rtl') : ?>
baseurl ?>/templates/rhuk_milkyway/css/template_rtl.css" type="text/css" />
and then add a com_mailto folder in the html folder of the template
copy /components/com_mailto/views/mailto/tmpl/default.php in there and modify to add classes or ids
then add the new css in template.css
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18628
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Bug in mailto link. (email icon in content link)

Post by infograf768 » Wed Feb 06, 2008 10:21 am

Not bug.
Moving to resolved.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Bug in mailto link. (email icon in content link)

Post by mcsmom » Wed Feb 06, 2008 10:23 am

FYI, System is a template that exists, it is the default that is called when there is nothing in the other templates or overrides.

It contains the css and layout for lots of the common elements.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.


Post Reply

Return to “Q&T 1.5.x Resolved”