[NOT A BUG] Component route error for PHP 5.0.4

User avatar
juanparati
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 123
Joined: Thu Nov 08, 2007 6:00 pm
Location: Aarhus (Denmark)

[NOT A BUG] Component route error for PHP 5.0.4

Postby juanparati » Fri Sep 05, 2008 12:51 pm

For Joomla 1.5.6

PHP 5.0.4 don't execute correcly the function _parseULR in uri.php.

I had problems and I find the solutions in this thread: http://forum.joomla.org/viewtopic.php?f=428&p=1404482

Some people have the same problem and the solution is change this line in the line 725:

Code: Select all

   if (version_compare( phpversion(), '4.4' ) < 0)


for this one:

Code: Select all

if (version_compare( phpversion(), '4.4' ) < 0 || version_compare(phpversion(), '5.0.4') == 0)


This can fix a lot of 404 errors.
Last edited by mihu on Thu Sep 18, 2008 4:22 pm, edited 2 times in total.
Reason: Corrected status tag
From the code to the reality!

User avatar
Tonie
Joomla! Master
Joomla! Master
Posts: 16584
Joined: Thu Aug 18, 2005 7:13 am

Re: [BUG] Component route error for PHP 5.0.4

Postby Tonie » Fri Sep 05, 2008 1:00 pm

Maybe one of the devs does want to change it, but PHP 5.0.4 is not supported on Joomla!. There are just too many specific problems in this versions that affect Joomla!.

User avatar
juanparati
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 123
Joined: Thu Nov 08, 2007 6:00 pm
Location: Aarhus (Denmark)

Re: [BUG] Component route error for PHP 5.0.4

Postby juanparati » Fri Sep 05, 2008 6:06 pm

Actually it is a bug of PHP 5.0.4.

I had some problems in the past when trying to install moodle with this version.

It would be a great idea to make a special mention about this PHP version in the joomla installation.
From the code to the reality!

Stasys
Joomla! Ace
Joomla! Ace
Posts: 1318
Joined: Wed Aug 17, 2005 11:06 pm
Location: Lithuania
Contact:

Re: [BUG] Component route error for PHP 5.0.4

Postby Stasys » Fri Sep 05, 2008 10:19 pm

why can't you upgrade to 5.2.6 ???
Lithuanian Joomla! Community http://www.lithuanianjoomla.com
lietuviškas Joomla! puslapis, naujienos, straipsniai, forumas, vertimai
always be open source, and be free as freedom

User avatar
juanparati
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 123
Joined: Thu Nov 08, 2007 6:00 pm
Location: Aarhus (Denmark)

Re: [BUG] Component route error for PHP 5.0.4

Postby juanparati » Sat Sep 06, 2008 9:00 am

Some people like my customers are using virtual hostings, and they can't update the php or mysql version.
From the code to the reality!

User avatar
juanparati
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 123
Joined: Thu Nov 08, 2007 6:00 pm
Location: Aarhus (Denmark)

Re: [BUG] Component route error for PHP 5.0.4

Postby juanparati » Tue Sep 16, 2008 12:46 pm

Ok, I have patched some files for fix the PHP 5.0.4 compatibility and few minutes ago I wrote to the system administrate for update or downgrade the PHP version.

All patches was made around uri.php and functions relatives to the routes.

I have learnt the lesson: PHP 5.0.4 don't can have sex with Joomla 1.5.x :'(
Last edited by juanparati on Wed Sep 17, 2008 8:07 pm, edited 1 time in total.
From the code to the reality!

User avatar
ircmaxell
Joomla! Ace
Joomla! Ace
Posts: 1926
Joined: Thu Nov 10, 2005 3:10 am
Location: New Jersey, USA
Contact:

Re: [BUG] Component route error for PHP 5.0.4

Postby ircmaxell » Tue Sep 16, 2008 11:30 pm

It's plain and simple. 5.0.4 has a LARGE number of CRITICAL bugs. The URL routing is only one of these bugs. We WILL NOT support 5.0.4. If you modify the core to work on it, do not expect ANY support what so ever (or don't expect security either)... My recommendation: If your host refuses to update, find a new host. They obviously don't care about security...
Anthony Ferrara - Core Team - Development Coordinator - Bug Squad - JSST

http://moovum.com/ - The Bird is in the air! Get Mollom Anti-Spam on your Joomla! website with Moovur...
http://www.joomlaperformance.com For All Your Joomla Performance Needs

User avatar
juanparati
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 123
Joined: Thu Nov 08, 2007 6:00 pm
Location: Aarhus (Denmark)

Re: [NOT A BUG] Component route error for PHP 5.0.4

Postby juanparati » Wed Sep 17, 2008 8:17 pm

Thanks you for you advice ircmaxell.

I assume that PHP 5.0.4 is equal to problems (For Joomla, for Moodle, Drupal, etc), I still have bad experiencies with this version in the past. Today I am waiting for the Hosting provider response about the upgrade/downgrade.
From the code to the reality!

User avatar
mihu
Joomla! Guru
Joomla! Guru
Posts: 741
Joined: Mon Mar 20, 2006 8:17 am

Re: [NOT A BUG] Component route error for PHP 5.0.4

Postby mihu » Thu Sep 18, 2008 4:24 pm

I will move this thread to resolved.
Lesson Learned, avoid PHP 5.0.4
bento2go.com - We DO NOT sell bento !!


Return to “Q&T 1.5.x Resolved”

Who is online

Users browsing this forum: No registered users and 1 guest