Page 1 of 1

FAQ: Why does Internet Explorer ignore the Statement?

Posted: Wed Sep 21, 2005 12:48 pm
by HarryB
Many existing Joomla templates have the following statement as the first line of the index.php file:

   

This conforms to the W3 specifications and is interpreted correctly by browsers other than Internet Explorer (IE).  Unfortunately, having this statement the head  of the template's index.php file causes IE (including the current 6.0 version) to go into Quirks Mode.  Read this to learn about Quirks Mode and IE.

To prevent IE from entering Quirks Mode, replace the and statements at the top of the template's index file with:

";
if (ereg( "MSIE",  $HTTP_USER_AGENT)) 
{
  echo $doc_type;
  echo '';
  $browtype = "You are using IE";
}
else

  echo '';
  echo $doc_type; 
  $browtype = "You are not using IE";
}
?>


Hopefully the future IE 7 release will correct this and bring IE in line with the W3 specifications.

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Wed Sep 21, 2005 2:10 pm
by bluesaze
Mmm Maybe this should be inculded in the upcoming joomla 1.0.1 ...... less headache for the end users

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Wed Sep 21, 2005 2:16 pm
by HarryB
bluesaze wrote: Mmm Maybe this should be inculded in the upcoming joomla 1.0.1 ...... less headache for the end users
No...its not a Joomla core deficiency...its an issue for 3rd-party template builders to consider, not the Joomla core developers.

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Fri Oct 14, 2005 5:25 pm
by acepp
is this why when i view some of my templates in IE it shows it all funny compared to firefox?

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Fri Oct 14, 2005 6:00 pm
by Tonie
Basically yes. The current version of Internet Explorer is notorious for not keeping up with CSS standards. Hopefully version 7 which will be released next year will be better in this regard.

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Wed Nov 02, 2005 5:31 am
by schultkl
Instead of browser sniffing (x_x)  couldn't you just insert the following in the segment?

Code: Select all

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
That's what Jeffrey Zeldman recommends in his book, "designing with web standards," page 158.  See source code here: http://zeldman.com



Kevin

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Wed Nov 02, 2005 6:54 pm
by damog
Why? Mainly because IE sucks hardly.  >:(

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Thu Nov 03, 2005 11:25 am
by Jinx
The xml prolog isn't needed when serving pages as text/html. In Joomla 1.1 we have removed it from the included templates and are forcing the use of meta tag. We will advocate template developers todo the same.

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Wed Jan 04, 2006 10:52 am
by CHCG
Hi! I am desperately searching for a cure for the rhuk solarflare ii template displaying weird in IE6 for Windows. I have modified the template and it looks fine in all my Mac-based browsers. The URL is http://www.anotherproject.se. I am, however, not savvy enough to understand how to alter the index file to make it work in all IE for Windows. Could someone with the expertise help me through this, by exemplifying it in the copied code below?

Code: Select all

<?php
defined( '_VALID_MOS' ) or die( 'Restricted access' );
// needed to seperate the ISO number from the language file constant _ISO
$iso = explode( '=', _ISO );
// xml prolog
echo '<?xml version="1.0" encoding="'. $iso[1] .'"?' .'>';
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<?php mosShowHead(); ?>
<?php
Thank you for your kind assistance!

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Mon Jan 09, 2006 5:07 pm
by HarryB
CHCG wrote: Hi! I am desperately searching for a cure for the rhuk solarflare ii template displaying weird in IE6 for Windows. I have modified the template and it looks fine in all my Mac-based browsers. The URL is http://www.anotherproject.se. I am, however, not savvy enough to understand how to alter the index file to make it work in all IE for Windows. Could someone with the expertise help me through this, by exemplifying it in the copied code below?

Code: Select all

<?php
defined( '_VALID_MOS' ) or die( 'Restricted access' );
// needed to seperate the ISO number from the language file constant _ISO
$iso = explode( '=', _ISO );
// xml prolog
echo '<?xml version="1.0" encoding="'. $iso[1] .'"?' .'>'
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<?php mosShowHead(); ?>
<?php
Thank you for your kind assistance!
Change this statement..

  echo ''
to...

// echo ''

This may help some, but think you may also have to change the width in some of the css statements in the template_css.css file too....

Think there are more threads here in forum regarding this issue with the solarflare ii template....try searching the forum for more on this issue...

Good luck...

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Mon Jan 09, 2006 10:19 pm
by CHCG
Thank you for your kind help, HarryB. As you anticipated, your solution solved more than some of the problem: It mended the broken structure!!! I will now see if I can fix the rest in the css. I must say, getting things right for IE is tricky!

Regards,

Chris

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Tue Jan 10, 2006 1:25 am
by absalom
That's what you get with quirks mode..

Quirks  8)  ???

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Wed Jan 18, 2006 8:21 am
by magsglass
HarryB wrote: Change this statement..

  echo ''
to...

// echo ''
:-* Thank you HarryB!  Adding these two little forward slashes just solved the text resizing problem I've been wrestling with all day!

~Mag

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Thu Dec 07, 2006 9:21 pm
by sitearsiv
Thank you... :)

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Wed Dec 13, 2006 7:45 pm
by kevin_chambers
Hmmm.  My page is still messed up even with commenting out that one line in the rhuk solarflare ii template.  I'm seeing that modules are not displaying in their correct locations.  Like the frontpage content is displaying under the left main menu rather then next to it.  demo.rolwheels.com.  Any help would be great.  thx.

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Thu Dec 14, 2006 6:37 am
by acepp
Is this still an issue with IE7?

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Thu Dec 14, 2006 12:49 pm
by kevin_chambers
IE6.  What I have learned is that I am using the scrolling news module in the "top" location.  The width parameter was set just a hair too long and caused the whole template to bump over a location (just in IE6).  The scrolling news module doesn't seem to scroll on IE6 or IE7 so I may just replace it all together.  Other than that, my main menus are not displaying correctly (just in IE6) so I may have to adjust the height in the .CSS or something. 

Rumor has it that there is another version of this solarflare template that is not a fixed width.  Anyone have a pointer to that?
Thx.

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Mon Dec 18, 2006 11:13 pm
by imrich
I found this because many of my visitors tell me that things don't look right with IE6.

I did testing and everything looks just fine with IE7 (yes they seemed to have fixed the issues in IE7! :D )

However the majority of my visitors are still using IE6.

So I'm trying to fix some templates so that they will work with BOTH IE6 and IE7.

From what I've been reading, by changing the order of the !doctype and the XML prolog statement you can force IE6 into quirks mode ore not. See here:
http://www.quirksmode.org/css/quirksmode.html
Explorer Windows special: the xml prolog
In Explorer 6 Windows, Microsoft implemented one extra rule: if a doctype that triggers strict mode is preceded by an xml prolog, the page shows in quirks mode. This was done to allow web developers to achieve valid pages (which require a doctype) but nonetheless stay in quirks mode.

Note that this behaviour has been removed from Explorer 7.
I don't think the code above that just tests for MSIE will work as it seems to not check for versions below IE 7.

Just saying IE sucks doesn't help much as the majority of visitors to my web sites are using IE (like it or not).

Does anyone have a suggested change to templates which will work for IE 6 and below as well as IE 7 (and above)?

Re: FAQ: Why does Internet Explorer ignore the Statement?

Posted: Thu Dec 20, 2007 8:05 am
by karryberry
thats strange, i use w3o to validate my html and i dont seem to be having this issue? weird!

Re: FAQ: Why does Internet Explorer ignore the <!DOCTYPE> State

Posted: Mon Mar 31, 2008 2:41 pm
by Iroken22
I have the exact same problem with my joomla site when viewing it in IE6. I have tried all the steps listed here and cannot find a fix. my site is http://www.peoriatroop333.org.

Re: FAQ: Why does Internet Explorer ignore the <!DOCTYPE> State

Posted: Wed May 14, 2008 1:11 am
by bestfunnyman
I had luck.Works in IE6 and IE7 with this fix...i was really careful at reading.This is very important because i have 76.95%
from IE.

Re: FAQ: Why does Internet Explorer ignore the <!DOCTYPE> State

Posted: Sat Jun 28, 2008 11:49 pm
by lagibosen
yup it work in IE 7