PHP register_globals setting is `ON` instead of `OFF`

Discuss the FAQ's here, and get in touch with the FAQ Team.
Post Reply
WebDesigner
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Jul 10, 2007 5:03 pm

PHP register_globals setting is `ON` instead of `OFF`

Post by WebDesigner » Tue Jul 10, 2007 5:19 pm

Hi,
I have this error:  PHP register_globals setting is `ON` instead of `OFF`  on my pages.  I have gone to the globals.php file and the file shows:  define( 'RG_EMULATION', 0 );

But I still get that error.  What am I missing? ???

Thanks
Sue :pop

User avatar
wood_flower
Joomla! Explorer
Joomla! Explorer
Posts: 292
Joined: Wed Nov 30, 2005 3:33 pm
Location: Hanoi, Vietnam
Contact:

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by wood_flower » Tue Jul 10, 2007 5:26 pm

Put the following line of code to the .htaccess file found in your Joomla root directory (where configuration.php file exists):

Code: Select all

php_flag register_globals off
If your Joomla root directory does not already have .htaccess file, create one and put the above line of code to it.
Last edited by wood_flower on Tue Jul 10, 2007 5:28 pm, edited 1 time in total.
http://designforjoomla.com/ - Visit now for:
- Professional Joomla templates
- Reliable Joomla extensions
- Joomla tutorials, tips and trick

WebDesigner
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Jul 10, 2007 5:03 pm

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by WebDesigner » Tue Jul 10, 2007 5:40 pm

Thanks Wood Flower .. Okay I did that .  But there is a lot of junk in that file .. do I leave all that in there??  I hope I put it in the right place. 

I even put a # infront of it and it still doesn't work.  I still get that error.

thanks
Sue :-[

WebDesigner
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Jul 10, 2007 5:03 pm

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by WebDesigner » Tue Jul 10, 2007 5:49 pm

okay ..  my  mistake .. I was putting that in the htaccess.txt file ..  The htaccess file will not let me open it up ..  Now this is an install directly from my hosting control panel.  Since it wouldn't let me open that up, I put in a new one .. Now I can't even get to any of my pages at all.

I get this:  Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Sue >:(

User avatar
wood_flower
Joomla! Explorer
Joomla! Explorer
Posts: 292
Joined: Wed Nov 30, 2005 3:33 pm
Location: Hanoi, Vietnam
Contact:

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by wood_flower » Tue Jul 10, 2007 5:54 pm

How about the content of the .htaccess file you created? Just the line of code i given or also the content from htaccess.txt file shipped with Joomla?
http://designforjoomla.com/ - Visit now for:
- Professional Joomla templates
- Reliable Joomla extensions
- Joomla tutorials, tips and trick

WebDesigner
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Jul 10, 2007 5:03 pm

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by WebDesigner » Tue Jul 10, 2007 6:07 pm

okay.  I guess I'm not understanding this .  I uninstalled and reinstalled Joomla so that I would get the htaccess file it had in there.  I did get it to open and there was nothing there  :laugh: .. 

But when I put php_flag register_globals off  in the file and upload it, I get the internal error.  When I put the # before it, or take it out, I can get in the site but it still shows that I have it on even tho it's show off.

So am I to put the code you gave me:  php_flag register_globals off  in the htaccess file and the htaccess.txt file??  I'm not understanding. 

thanks
Sue ??? ???

User avatar
wood_flower
Joomla! Explorer
Joomla! Explorer
Posts: 292
Joined: Wed Nov 30, 2005 3:33 pm
Location: Hanoi, Vietnam
Contact:

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by wood_flower » Tue Jul 10, 2007 6:24 pm

If you are using Apache 2 then you should visit the URL below and read the comment made by hbinduni at gmail dot com:

http://www.php.net/register_globals
http://designforjoomla.com/ - Visit now for:
- Professional Joomla templates
- Reliable Joomla extensions
- Joomla tutorials, tips and trick

User avatar
wood_flower
Joomla! Explorer
Joomla! Explorer
Posts: 292
Joined: Wed Nov 30, 2005 3:33 pm
Location: Hanoi, Vietnam
Contact:

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by wood_flower » Tue Jul 10, 2007 6:32 pm

http://designforjoomla.com/ - Visit now for:
- Professional Joomla templates
- Reliable Joomla extensions
- Joomla tutorials, tips and trick

WebDesigner
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Jul 10, 2007 5:03 pm

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by WebDesigner » Tue Jul 10, 2007 6:37 pm

Well I will look at them but don't think they will do any good.  I don't understand what they are saying anyhow.  Guess I will either live with it the way it is or find another program to use.

Thanks for your quick response.

Sue
:pop

teejay818
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Mon Feb 12, 2007 8:02 pm
Location: Phoenix, Arizona

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by teejay818 » Sat Jul 14, 2007 3:29 pm

Sue,

I am dealing with this issue now. In laymen's terms... this has to do with a setting on your hosting server. You can do some work arounds (found on this forum) but they may not work. That is the boat I am in too. The best answer is to change hosting. There is a list of joomla hosts with correct server environments in the FAQ, but I will add the link since it takes alot of time to learn your way around this forum... Lots of variation in price and services, so you may want to look through them all.

http://forum.joomla.org/index.php/topic,6856.0.html

Hope this helps cut past all the steps and gets you to where you want to go...

Tracy  ;)

WebDesigner
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Jul 10, 2007 5:03 pm

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by WebDesigner » Sat Jul 14, 2007 3:38 pm

Thanks Tracy, but I have been with this hosting company as a reseller for almost 6 years.  The Joomla program came from the server in the first place.  Don't think I want to change hosting company ..

Sue
:pop

User avatar
brad
Joomla! Master
Joomla! Master
Posts: 13419
Joined: Fri Aug 12, 2005 12:38 am
Location: Sydney - Australia
Contact:

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by brad » Sat Jul 14, 2007 9:11 pm

WebDesigner wrote: Thanks Tracy, but I have been with this hosting company as a reseller for almost 6 years.  The Joomla program came from the server in the first place.  Don't think I want to change hosting company ..

Sue
:pop
You might want to seriously consider it. A host that does not show, from their server settings that they care about security could have serious consequences to your business. But, it's your decision. All the best.
Brad Baker
https://xyzulu.hosting
https://www.joomlatutorials.com <-- Joomla Help & Tutorials

WebDesigner
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Jul 10, 2007 5:03 pm

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by WebDesigner » Sat Jul 14, 2007 9:21 pm

hmmmm..  Didn't know any one said they didn't care about security ..  How did we get on the subject bashing my hosting company ..  I just wanted a way to show that the global setting was on OFF instead of ON.

Sue

User avatar
brad
Joomla! Master
Joomla! Master
Posts: 13419
Joined: Fri Aug 12, 2005 12:38 am
Location: Sydney - Australia
Contact:

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by brad » Sat Jul 14, 2007 9:27 pm

register_globals has been off by default in php4 for a long time. I'm not trying to bash your host, I don't even know who it is ;) however, I am trying to point out that a host that by default ignores the php authors when it comes to security settings is a bit of a worry. It's a serverwide security risk.
Brad Baker
https://xyzulu.hosting
https://www.joomlatutorials.com <-- Joomla Help & Tutorials

teejay818
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Mon Feb 12, 2007 8:02 pm
Location: Phoenix, Arizona

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by teejay818 » Tue Jul 17, 2007 3:29 am

Thanks for confirming this decision. I signed up with a hosting company that claimed to be the #1 Joomla Host... NOT! Asked about the server setting and the support tech sent me that other hosting companies paid to be listed as a joomla host in the forum... This made me smile... Why? Because I have to migrate servers to get the server settings secure. My project is important (even if only in my own mind), and although pretty new to this, I want to protect it... Lesson learned: No one really cares about your project if you don't.

Have a good one..  ;D

User avatar
brad
Joomla! Master
Joomla! Master
Posts: 13419
Joined: Fri Aug 12, 2005 12:38 am
Location: Sydney - Australia
Contact:

Re: PHP register_globals setting is `ON` instead of `OFF`

Post by brad » Tue Jul 17, 2007 5:53 am

teejay818 wrote: .. the support tech sent me that other hosting companies paid to be listed as a joomla host in the forum...
Just to make sure no one is confused, no host pays Joomla to be listed on our forum in this thread: http://forum.joomla.org/index.php/topic,6856.0.html

I know that is probably not what you mean't but I am just making sure.
Brad Baker
https://xyzulu.hosting
https://www.joomlatutorials.com <-- Joomla Help & Tutorials


Post Reply

Return to “FAQ Discussion Board”