DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Discuss the FAQ's here, and get in touch with the FAQ Team.
User avatar
guilliam
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4181
Joined: Thu Aug 18, 2005 10:27 am
Location: Sunny City Cebu, Philippines!
Contact:

DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by guilliam » Sat Feb 11, 2006 4:32 pm

DISCUSSION THREAD from this post: http://forum.joomla.org/index.php/topic,37364.0.html

feel free to discuss here.

- g
"I was one of those who wondered why people would pay so much $$$$ to do something that was so much fun!" -R. Harkrider, Fortran Code Engr.

http://www.joomlaconsultancy.net

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18917
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by leolam » Sat Feb 11, 2006 5:05 pm

Thanks Guilliam for posting the guide and the opportunity for our community to reply! We are most welcome to reply to any inquiry related to the issue! This is also a good place to discuss any issue related to installing a local server in general....where possilble we wil reply and advise!

Leo
Last edited by leolam on Sat Feb 11, 2006 5:08 pm, edited 1 time in total.
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

dschiavon
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Feb 14, 2006 8:19 am

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by dschiavon » Tue Feb 14, 2006 8:32 am

Hi everybody.

I am trying to install the uniform test server on WinXP on my workplace. Server installation goes fine, MySql starts, but when I try to start phpmyadmin all I get is

>>
Warning: require_once(./lang/italian-iso-8859-1.inc.php) [function.require-once]: failed to open stream: No such file or directory in W:\home\admin\www\phpMyAdmin\libraries\select_lang.lib.php on line 307

Fatal error: require_once() [function.require]: Failed opening required './lang/italian-iso-8859-1.inc.php' (include_path='.;/usr/local/PHP/includes;/usr/local/PHP/pear') in W:\home\admin\www\phpMyAdmin\libraries\select_lang.lib.php on line 307
>>

My pc is part of my company intranet, runs Eset nod32 as antivirus and MS IE 6.0.

I know the answer is in the error message I get. But I am just a semiskilled employee.

I know the test server was supposed to be foolproof. But I am probably beyond a developer's concept for 'fool'  ??? .

Thank you for your help anyway.

Diego

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18917
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by leolam » Tue Feb 14, 2006 1:09 pm

dschiavon wrote: Hi everybody.

I am trying to install the uniform test server on WinXP on my workplace. Server installation goes fine, MySql starts, but when I try to start phpmyadmin all I get is

>>
Warning: require_once(./lang/italian-iso-8859-1.inc.php) [function.require-once]: failed to open stream: No such file or directory in W:\home\admin\www\phpMyAdmin\libraries\select_lang.lib.php on line 307

Fatal error: require_once() [function.require]: Failed opening required './lang/italian-iso-8859-1.inc.php' (include_path='.;/usr/local/PHP/includes;/usr/local/PHP/pear') in W:\home\admin\www\phpMyAdmin\libraries\select_lang.lib.php on line 307
>>

My pc is part of my company intranet, runs Eset nod32 as antivirus and MS IE 6.0.

I know the answer is in the error message I get. But I am just a semiskilled employee.

I know the test server was supposed to be foolproof. But I am probably beyond a developer's concept for 'fool'  ??? .

Thank you for your help anyway.

Diego
Your system looks for a file which is not rpesent in the downlaod (at least not on my version). The error happanes because the sytem looks for this

Code: Select all

./lang/italian-iso-8859-1.inc.php
do you need italian? if not disable.....if you do not know how try otherwise the following:
find in: Uniform Server\diskw\home\admin\www\phpMyAdmin\libraries\select_lang.lib on line 305 - 307 this information:
// 5. Defines the associated filename and load the translation
$lang_file = $lang_path . $available_languages[$lang][1] . '.inc.php';
require_once('./' . $lang_file);
save (w/different nam) and delete. Be very precise!

If it does not work just set it back and come back...Once again that " lang/italian-iso-8859-1.inc.php " does not exist and the message is driven partly by the said code. the file select_lang.lib contains two lines of code referring to this stuff as well. If my sugegstion does not help we go into that direction. This file contains all the available translations....... However thats specific italain ISO-file is not available despite being pointed at. Therefore my guess to remove the call on the language file. That should not be a problem because some lines above the issue,  the default language is already being called and this php only addresses the translation.

Just try it. if you save the file you should not have a problem since than we reset the file later on....

Leo
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

dschiavon
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Feb 14, 2006 8:19 am

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by dschiavon » Tue Feb 14, 2006 2:36 pm

Hi Leo,

thank you very much for your help. I tried doing as you wrote, but I messed it up to the point where the server would not even start. So erased everything, unpacked it again and renamed all english language files to italian-etc...php

Perhaps not very elegant but it is working now.

Thank you for your help anyway, from your description I got an idea of how to solve this.

I will come back here as soon as I start figuring out how to use joomla.

bye,

ds

dschiavon
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Feb 14, 2006 8:19 am

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by dschiavon » Tue Feb 14, 2006 3:43 pm

Ok, up and running now.

If I may suggest a tiny improvement to the otherwise good 20-steps guide:

I did not know where nor what the installation directory (point 19) was. I think it would be nice to put the whole path to it Uniform Server\diskw\www\demosite\installation or something similar.

Thank you,

Ds

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18917
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by leolam » Wed Feb 15, 2006 1:22 am

dschiavon wrote: Ok, up and running now.

If I may suggest a tiny improvement to the otherwise good 20-steps guide:

I did not know where nor what the installation directory (point 19) was. I think it would be nice to put the whole path to it Uniform Server\diskw\www\demosite\installation or something similar.

Thank you,

Ds
Glad you got it working!
Thank you for the advise on improvements. I always take those in consideration and I always give feed-back on questions from users directly directed to me. I have to make a slight correction though on your suggestion. Regretfully the path mentioned here is not the correct path! As you have seen from the tutorial (step 4), the server will upon start create a "virtual" disk to run on called "w"  This drive does not exist basically (virtual) and any changes to the files and folders you need to make on the drive you installed the server on. in other words you have to change the name of your installation-diretory in your Joomla-core file structure on the location where you installed Joomla. example: CHANGE
C:\Uniform Server\diskw\www\joomla\installation
  (or whatever the name is you gave to your file) TO
C:\Uniform Server\diskw\www\joomla\installation1
I do not think we need to change the image. This explanation should be sufficient?

Happy Joomla!

Leo
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

ERuiz
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 117
Joined: Thu Nov 24, 2005 5:40 pm
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by ERuiz » Sun Feb 26, 2006 6:12 am

Hello Leo!

Great tutorial! I had been looking around the Internet for quite some time now, on how to get this accomplished, and your tutorial is simply amazing!

I was able to get a copy of Joomla, working in no time, on my computer. But, once I tried to install SMF 1.1 RC2, I got a problem.

I installed Joomla into the /www folder, so I just need to go to http://localhost and Joomla starts without a problem. So I went ahead and created a folder /www/forums

There, I installed SMF 1.1 RC2. When I enter http://localhost/forums/install.php , I get the following an error. I attached a screenshot of this error.

I checked the php.ini file, and it says /tmp


Hope you can help me out, on this one.
You do not have the required permissions to view the files attached to this post.
Last edited by ERuiz on Sun Feb 26, 2006 6:14 am, edited 1 time in total.
Regards,

Efrain Ruiz
Virtual American Airlines
http://www.virtualaa.com

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18917
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by leolam » Sun Feb 26, 2006 6:28 am

ERuiz wrote: Hello Leo!

Hope you can help me out, on this one.
your pathway is wrong i think. You have installed correct your server....your server has a pathway lets say
D:\Uniform Server\diskw\www

Joomla is installed as

D:\Uniform Server\diskw\www\joomla

I think you need to setup SMF as a directory of your joomla-folder (never tried locally but if that does not do the trick i will try to emulate it on my systeme here please verify for me becasue this is not a uniform-server issue....
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

ERuiz
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 117
Joined: Thu Nov 24, 2005 5:40 pm
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by ERuiz » Sun Feb 26, 2006 1:23 pm

Ok, my Joomla is installed in D:\Uniform Server\diskw\www

And it works perfectly. I created a new folder called D:\Uniform Server\diskw\www\forums and placed SMF in that new folder.

But when I try to run the SMF install script, that's when I get the error I posted on my original post.

Hope this clears it out a bit for you. Looking forward to your help on this, my friend.
Regards,

Efrain Ruiz
Virtual American Airlines
http://www.virtualaa.com

DianeH
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 103
Joined: Thu Jan 26, 2006 3:53 pm
Location: UK

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by DianeH » Thu Mar 16, 2006 3:03 pm

I managed to get this running on the second attempt, due to my screens looking nothing like the ones in the tutorial. I thought I would try Uniform server as an alternative to Wamp, which I appear to have messed up completely while trying to import a database from another PC.

Now I have everything working, I am going to try and import the site database again, and I think I have exported it correctly this time, but can someone please tell me where I start PHPMyAdmin? There was an icon in the system tray with Wamp, but this has nothing obvious, unless I haven't looked in the right place. I managed to get to it to set up the database as per the instructions, but somehow it is eluding me this time.

Many thanks.
Diane

ERuiz
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 117
Joined: Thu Nov 24, 2005 5:40 pm
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by ERuiz » Thu Mar 16, 2006 3:06 pm

DianeH wrote: I managed to get this running on the second attempt, due to my screens looking nothing like the ones in the tutorial. I thought I would try Uniform server as an alternative to Wamp, which I appear to have messed up completely while trying to import a database from another PC.

Now I have everything working, I am going to try and import the site database again, and I think I have exported it correctly this time, but can someone please tell me where I start PHPMyAdmin? There was an icon in the system tray with Wamp, but this has nothing obvious, unless I haven't looked in the right place. I managed to get to it to set up the database as per the instructions, but somehow it is eluding me this time.

Many thanks.
When you start Uniform Server, go to http://localhost

On the screens displayed, you will see PHPMyAdmin listed on the ledt hand side of the page.
Regards,

Efrain Ruiz
Virtual American Airlines
http://www.virtualaa.com

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18917
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by leolam » Thu Mar 16, 2006 3:16 pm

difficult to read iisn't it? I thought it was pretty obvious?

STEP 6 :: http://forum.joomla.org/index.php/topic,37364.0.html
Step 6: Open DB-Admin

Now we will start the DataBase administrator called phpMyAdmin.
We are going to do that because we want to create o0ur first database which we will later use for Joomla!
Just follow the instructions on the picture!
The address in your browser should state here: http://localhost/apanel/phpMyAdmin/
did i miss something ?  ;)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

DianeH
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 103
Joined: Thu Jan 26, 2006 3:53 pm
Location: UK

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by DianeH » Thu Mar 16, 2006 3:20 pm

ERuiz wrote:
When you start Uniform Server, go to http://localhost

On the screens displayed, you will see PHPMyAdmin listed on the ledt hand side of the page.
Thank you for your swift reply. No I don't see that. As I was installing I didn't get the fancy screens as shown in the tutorial. They were very basic screens with not as many choices indicated as in the screen grabs. All I can see in localhost is Index of/ at the top of the page and then a table with headers: Name - Last Modified - Size - Description and below that the name of the database I created.

If I don't crack this today I will go back to Wamp. I just thought I would try something different.
Diane

DianeH
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 103
Joined: Thu Jan 26, 2006 3:53 pm
Location: UK

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by DianeH » Thu Mar 16, 2006 3:29 pm

leolam wrote: difficult to read iisn't it? I thought it was pretty obvious?

STEP 6 :: http://forum.joomla.org/index.php/topic,37364.0.html
Step 6: Open DB-Admin

Now we will start the DataBase administrator called phpMyAdmin.
We are going to do that because we want to create o0ur first database which we will later use for Joomla!
Just follow the instructions on the picture!
The address in your browser should state here: http://localhost/apanel/phpMyAdmin/

did i miss something ?   ;)
No it wasn't difficult to read - it would have been better if I was getting the screens as shown, but I wasn't, which made it a little more difficult than it's made out to be. I managed to make the new user in the database using PHPMyAdmin, but then couldn't see how to get back there. The URL wasn't as you indicate above - instead of /apanel/, mine said /a/ and then something else (can't remember as I didn't think I'd need it again), and then UniServer3_2a. The directory structure in the folder where I extracted the server files is at: D:\UniformServer\UniServer3_2a\diskw\www

I created the UniformServer folder and unpacking the files created the one below that.
Diane

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18917
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by leolam » Thu Mar 16, 2006 3:39 pm

DianeH wrote: As I was installing I didn't get the fancy screens as shown in the tutorial. They were very basic screens with not as many choices indicated as in the screen grabs. All I can see in localhost is Index of/ at the top of the page and then a table with headers: Name - Last Modified - Size - Description and below that the name of the database I created.

If I don't crack this today I will go back to Wamp. I just thought I would try something different.
sorry but that points to some mistakes you made during downlaoding or extractrion. Realy belive me because no installtion as such takes oplace. You do not have to do anything at all but downloading and extracting to your disk. The softaware installs itself without you doing anything at all!

SO what goes wrong here?
1. have you downloaded the right version from the sourceforge?
2. what program did you use to extract?
3. did you create a folder befiore you extracted ior did you let it autorun?

I just this afternoon once agin installed this on exactly the same way on the harddisk of a client. I downloaded and extracted. It was including downloadtime exactly 3 minutes (!)

once again:

1. download from sourceforge the zip
2. extract without doing anything to "c" drive
3. open c:\UniformServer and start...the rest goes all by itself!

sorry this basically cannot go wrong so i assume you have either downloaded a corrupt package or extracted wrong. use the http://www.7-zip.org link as provided. the best package available!

:'( and i thought it was monky proof  8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18917
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by leolam » Thu Mar 16, 2006 3:44 pm

DianeH wrote: The directory structure in the folder where I extracted the server files is at: D:\UniformServer\UniServer3_2a\diskw\www

I created the UniformServer folder and unpacking the files created the one below that.
as I said above...extraction done different so the pathway's as shown in the guide do not fit anylonger....This is once agin the path if you just dump the zip to your desktop and than "extract" without doing anything...It creates its own directory so no need to do so...
here is mine just for the statistics: D:\Uniform Server\diskw\www

just follow the guide...therefor it's a guide..... ;)

Leo
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

ERuiz
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 117
Joined: Thu Nov 24, 2005 5:40 pm
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by ERuiz » Thu Mar 16, 2006 3:49 pm

DianeH wrote:
ERuiz wrote:
When you start Uniform Server, go to http://localhost

On the screens displayed, you will see PHPMyAdmin listed on the ledt hand side of the page.
Thank you for your swift reply. No I don't see that. As I was installing I didn't get the fancy screens as shown in the tutorial. They were very basic screens with not as many choices indicated as in the screen grabs. All I can see in localhost is Index of/ at the top of the page and then a table with headers: Name - Last Modified - Size - Description and below that the name of the database I created.

If I don't crack this today I will go back to Wamp. I just thought I would try something different.
My bad! It should be http://localhost/apanel

Sorry for the mishap.
Regards,

Efrain Ruiz
Virtual American Airlines
http://www.virtualaa.com

DianeH
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 103
Joined: Thu Jan 26, 2006 3:53 pm
Location: UK

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by DianeH » Thu Mar 16, 2006 3:57 pm

leolam:

As a complete newbie to setting up a CMS website, I have so far found this site to be a mine of very useful information, for which I am eternally grateful, and we have set up a test site using Wampserver with relative ease. It was only while trying to import a database that a colleague had been working on, from his machine to mine, that I did something silly (I'm assuming) and messed everything up. In trying to start again, I thought I would try Uniform Server as an alternative.

Apart from one or two of my posts having had no replies, I have managed to get through some of the more challenging aspects by much searching on here, and much trial and error. I am quite happy to be told that I have made a mistake, so that I can put things right, so, despite your smilies, I therefore find your last remark quite insulting and unnecessary.

In answer to your questions:
1) I have downloaded an earlier version of the server, because I want to add a calendar component to Joomla which, I have found out, will not work properly with MySQL 5. I therefore wanted an earlier version of this.
2) I used Winzip to extract the files.
3) I created the folder before extracting.
Last edited by DianeH on Thu Mar 16, 2006 4:03 pm, edited 1 time in total.
Diane

DianeH
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 103
Joined: Thu Jan 26, 2006 3:53 pm
Location: UK

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by DianeH » Thu Mar 16, 2006 4:02 pm

ERuiz wrote: My bad! It should be http://localhost/apanel

Sorry for the mishap.
Thank you for trying to help.

I get a 'page cannot be found' with that URL.
Diane

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18917
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by leolam » Thu Mar 16, 2006 4:13 pm

DianeH wrote: Apart from one or two of my posts having had no replies, I have managed to get through some of the more challenging aspects by much searching on here, and much trial and error. I am quite happy to be told that I have made a mistake, so that I can put things right, so, despite your smilies, I therefore find your last remark quite insulting and unnecessary.
sorry if you feel offended by the remark "monkyproof" it was not meant to be an insult in any form at all since i never insult anybody on purpose. Why should I? Support is my business and i never insult boarders nor clients nor friends... We all have started somehow and Diana I am here not to defend my guide. That one is a blast and works without doubt....Please notice that I spend here time to assist you to get a good product running for you. It is not in my interest that I am spending time here?

In answer to your question:
1) I have downloaded an earlier version of the server, because I want to add a calendar component to Joomla which, I have found out, will not work properly with MySQL 5. I therefore wanted an earlier version of this.
Than we have found the reason why it does not look like it as on the images. It is simple: The current myadmin version is a beta-version  and was just a couple of month' s ago launched. The earlier versions did not have the admin panel which is extremely helpful and fully functional especially in changing php.ini settings etc. So it explains everything why you do not have the fancy screens and why the url's are diiferent.

i hope this helps. Let me know if you face more issues.

Leo
Last edited by leolam on Thu Mar 16, 2006 4:16 pm, edited 1 time in total.
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

DianeH
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 103
Joined: Thu Jan 26, 2006 3:53 pm
Location: UK

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by DianeH » Thu Mar 16, 2006 4:18 pm

I can see that you have been of great help to the forum, and I am pleased that people like you are willing to take the time to help others. Many thanks for that.

I am off home now, so I will come back to this tomorrow with, hopefully, a fresh brain.
Diane

DianeH
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 103
Joined: Thu Jan 26, 2006 3:53 pm
Location: UK

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by DianeH » Fri Mar 17, 2006 8:27 pm

Just to upadate my situation.

I didn't have time to try Uniform Server again, but probably will do in the future. In the meantime I needed to get this site on the go, so switched back to Wamp, which I had to reinstall due to messing up the original one. Searched and found the correct way of importing a database from another PC onto mine, which took some time but went OK, had some issues with the site still refusing to open, eventually found that I needed to make some alterations to the configuration.ini file. Managed that, despite a distinct lack of experience with these things, almost had things up and running, and then discovered that my colleague who constructed this Joomla site, and has gone off sick, has an unknown password to get into the Joomla site admin. Email him but get no reply, find solution here to create a new MD5 password, BINGO!!

I now have an earlier version of Wamp, as I want to get the calendar component on the site, which would not work when we had Wamp with MySQL5 installed.

Thanks for all your help. I may need some more, who knows!! But I seem to find the answers here to most issues.
Diane

RichMedia
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sun Jan 22, 2006 12:00 am

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by RichMedia » Sat Mar 25, 2006 8:37 pm

Does anyone have any suggestions or know of a similar tutorial for doing this under OS X? I think I already have most of the pieces installed individually (I'm not too sure about the Perl).

Do the Apache and mySql builds on the local machine need to match those in the live hosting server environment?

thanks!

ERuiz
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 117
Joined: Thu Nov 24, 2005 5:40 pm
Contact:

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by ERuiz » Sat Mar 25, 2006 10:52 pm

I have a question. I am able to run Uniform Server without a problem, but the problem is that since it's running on a Windows XP machine, the  file paths are much different than the ones on my live site, which uses a Linux (unix) server.

Does anyone have a tutorial, on how I can setup my Linux (SUSE 10) box, so that I can run my website locally on it? This way I can use the exact file paths as my live site, making it much easier, when it's time to upload the site to a live server.

Thanks for any help...
Regards,

Efrain Ruiz
Virtual American Airlines
http://www.virtualaa.com

homebrewpc
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Apr 03, 2006 10:51 pm

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy steps!

Post by homebrewpc » Mon Apr 03, 2006 11:35 pm

Hi,

I'm a php/MySQL newbie and would like to run uniserver to learn php. I've followed steps 1-4 from the Installation Guide however the following error message keeps on appearing upon double clicking on Server_Start:-

"The disk w is busy. Use 'Disk Start.vbs' [disk letter].
press any key to continue...

Upon double clicking on Disk Start.vbs the default "W" drive is shown, clicking on O.K. is immediatley followed-up by a "Start the MySQL database server" prompt but uniserver doesn't seem to be running.

Typing in http://localhost in a browser window results in the following error message:-

Unable to connect

     

     
     
     

     
       
       

         

Firefox can't establish a connection to the server at localhost.

       


       
       


    *   The site could be temporarily unavailable or too busy. Try again in a few
          moments.

    *   If you are unable to load any pages, check your computer's network
          connection.

    *   If your computer or network is protected by a firewall or proxy, make sure
          that Firefox is permitted to access the Web.

Can anyone suggest where i'm going wrong and how I need to go about getting uniserver to run properly.

-Amended 01:45am 4th April. Managed to get uniserver to work on another PC via USB Stick. Not sure if the fact that a Y: and Z: are already configured on PC initially tried to run uniserver on are the cause of the problem mentioned however would like to get around this problem if possible.

Am unable to connect to MySQL. From what I can gather a password needs to be set. Can anyone offer any help please?.
Error message as follows:-

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in W:\www\mysqltest.php on line 7
sorry - unable to connect to MySQL


Thank you.
Kind Regards.
Last edited by homebrewpc on Tue Apr 04, 2006 12:42 am, edited 1 time in total.

User avatar
lausianne
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Thu Apr 06, 2006 3:15 pm

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by lausianne » Sat Apr 15, 2006 4:17 pm

Hi,

I just tried to install the Uniform server. I downloaded the exe, so I wouldn' t have to install yet another zip tool.
The exe unzipped itself nicely.

When I start the bat or the vbs, the same thing happens: A new window opens in the browser (Firefox 1.5), and a page starts to load: dark violet with a "The Uniform Server" logo on the top of the page. In the status bar it says "Connecting to localhost", refreshing every ~0.5 s. That's it.

Any hint what's going wrong? Thank you!

User avatar
lausianne
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Thu Apr 06, 2006 3:15 pm

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by lausianne » Sat Apr 15, 2006 4:28 pm

leolam wrote:
[...]

do you need italian? if not disable.....if you do not know how try otherwise the following:
find in: Uniform Server\diskw\home\admin\www\phpMyAdmin\libraries\select_lang.lib on line 305 - 307 this information:
// 5. Defines the associated filename and load the translation
$lang_file = $lang_path . $available_languages[$lang][1] . '.inc.php';
require_once('./' . $lang_file);
save (w/different nam) and delete. Be very precise!

[...]

Leo
After the server finally came up after a few minutes, I got the same problem, and tried your solution. The new error message is:
"Warning: mb_internal_encoding() [function.mb-internal-encoding]: Unknown encoding "" in W:\home\admin\www\phpMyAdmin\libraries\string.lib.php on line 41"

What now? Thank you!

(Update: now happily using WAMP server ...)
Last edited by lausianne on Tue May 30, 2006 9:12 am, edited 1 time in total.

Traconian
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon May 01, 2006 5:33 pm

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by Traconian » Mon May 01, 2006 6:02 pm

Hello World, from Central Oregon, USA

Okay, I'm a noob (aka newb, newbie, newbe, etc....) with Joomla and Uniform Server, but I'm good with computers, usually anyway.

I've installed the Uniform Testserver and everything seems fine, MySQL is running, I've added a user with full privileges through phpmyadmin, I've unzipped all the Joomla (ver 1.08) files into the www directory, and I've renamed the directory to demosite. When I type localhost/apanel/ the phpmyadmin window opens properly, but when I type localhost/demosite I get a 404 NOT FOUND error.

The real path to my local site is: C:\temp\Uniform Server\diskw\demosite
I'm running Windows XP Pro.

Any Ideas?

Traconian of Malygos

self
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Sat Apr 15, 2006 6:08 pm

Re: DISCUSSION: Guide:: Install Local Uniform Testserver & Joomla! in 20 easy st

Post by self » Sun May 14, 2006 4:19 am

Leo - your tutorial is simply a thing of beauty. I am a newbie, totally foreign to my thinking prcess but I thnik I will do some spring cleaning and start from scratch, reinstall Joomla, Uniform Server and have a clean house!
Your efforts are deepley appreciated.


Post Reply

Return to “FAQ Discussion Board”