DISCUSSION: Incorrect Itemid-list of possible solutions

Discuss the FAQ's here, and get in touch with the FAQ Team.
User avatar
DaveBelden
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Thu Apr 06, 2006 6:40 pm
Location: Chicago
Contact:

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by DaveBelden » Thu May 04, 2006 10:08 pm

Kper! Thank you for going the extra mile and providing a screenshot, that's a huge help. Yes, I'm sure it's because you have Flash disabled. I need to figure out a way to account for that in my html/css.

And, I figured out that using Table - Content Category in my menus allows me to control the filter display, so I beat you to it by a few minutes. I wasn't being provided that option when the menus were set as Blog Content Category.

The only thing I still wish is that when I'm viewing my News categories, I could get the News menu (on the left) to show its hover state. This would make a lot of sense from a usability standpoint, but I can't seem to pull it off in the category views.

Thanks again,
Dave

User avatar
kper
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 198
Joined: Fri Aug 26, 2005 11:09 am

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by kper » Fri May 05, 2006 9:14 am

What the hack that Ruben_Tec was trying to implement does is change the type of those automatic category links from table to blog.
DaveBelden wrote: The only thing I still wish is that when I'm viewing my News categories, I could get the News menu (on the left) to show its hover state. This would make a lot of sense from a usability standpoint, but I can't seem to pull it off in the category views.
Hmm. The eternal problem with using hidden menus is losing active menu item highlighting. If you could see it, you would find that the item in your hidden menu is highlighted instead when you click on each of your Table - Content Category listings for the categories in your news section.

You might try Daniel Ecer's Extended Menu. I seem to remember it has an extra feature to discover more reliably what it ought to be highlighting. Plus it can split menus, so your top links to "feature articles" and "news articles" could be part of the main menu. But it does have a bit of a learning curve - something to play about with on a separate test installation.

You could try the following (I haven't tested this - it is purely a random, rather dozy, thought):
Create a static content item (an empty one).
Create a menu link to it.
Make that menu link a sub-item of your "news" menu link.
Unpublish your new static content menu link.
Move your two Table - Content Category links from your hidden menu and make them both sub-items of the unpublished menu link.
Might work!...

An alternative, and similarly untested, approach might be to go for brute force!
Use PHPMyAdmin to directly change (in your MySQL database) the ItemID of each of your Table - Content Category links from your hidden menu ("feature articles" and "news articles") to 26 (the same as your News section blog menu link).
That should do the job, but it might have other undesirable consequences. Back-up and test carefully.

You just have to be inventive with this stuff!  :)
Last edited by kper on Fri May 05, 2006 9:17 am, edited 1 time in total.

User avatar
DaveBelden
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Thu Apr 06, 2006 6:40 pm
Location: Chicago
Contact:

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by DaveBelden » Sat May 06, 2006 4:33 am

Kper,

I appreciate these thoughts/ideas, thank you... I'll try to test them out soon, though of course I've got some bigger fish to deal with first... I've certainly been pretty inventive so far!

Thanks,
Dave

User avatar
kper
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 198
Joined: Fri Aug 26, 2005 11:09 am

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by kper » Sat May 06, 2006 11:51 am

DaveBelden wrote: I've certainly been pretty inventive so far!
No problem, Dave.
You certainly have: and the site is looking great.

User avatar
kper
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 198
Joined: Fri Aug 26, 2005 11:09 am

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by kper » Mon May 08, 2006 8:42 am

I haven't tried it yet, but the newly released OpenSEF RC5 sounds utterly fantastic and may be able to solve many ItemID issues with its "Link Priority" and "Used" features...

http://www.open-sef.org/component/optio ... 74#msg4074

User avatar
DaveBelden
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Thu Apr 06, 2006 6:40 pm
Location: Chicago
Contact:

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by DaveBelden » Mon May 08, 2006 5:46 pm

Thanks, I'll check it out!

Dave

User avatar
kenmcd
Joomla! Champion
Joomla! Champion
Posts: 5672
Joined: Thu Aug 18, 2005 2:09 am
Location: California
Contact:

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by kenmcd » Thu May 11, 2006 6:14 am

kper wrote: I haven't tried it yet, but the newly released OpenSEF RC5 sounds utterly fantastic and may be able to solve many ItemID issues with its "Link Priority" and "Used" features...

http://www.open-sef.org/component/optio ... 74#msg4074
kper,

Love to have your help.
RC5 adds some of the features needed for URL management, but it is not quite there yet.
RC6 is targeted to add complete control.

I have been watching this thread and was planning to post when I have a complete solution.
The goal in OpenSEF 2.0.0-RC6 is to enable you to select the URL/Path pair you want to use and always have that be the default.

In RC5 you can select the Path with the Used button, the FURL is somewhat fixed by the Link Type Priority.
The goal is to have you be able to select the FURL/Path pair and have that be the one always used.

kper, if you would like to help, please join the OpenSEF forum, PM me that you have joined, and then I will add you to the private Testers Forum.
Then we can use your brain.
;D
Actually, I would like to have your knowledgeable input on the issue.
I know what I want.
I would also like to know exactly what you want.

THANKS!

KM
██ LibreTraining

User avatar
kper
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 198
Joined: Fri Aug 26, 2005 11:09 am

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by kper » Thu May 11, 2006 9:31 am

Sounds like you are pretty much on track for what I want, but yes I would love to help, then we can get some of these issues sorted out (as far as possible) for everyone's benefit.
kenmcd wrote: Then we can use your brain.
Though I'm not sure I can live up to this bit - I think I probably sound a lot more competent than I actually am because I don't post enough to reveal what I don't know  ;)

You'll see that I did actually register on the Open-SEF forum a few days ago, when I saw the RC5 announcement, but I haven't posted anything yet because I wanted to set out clearly what I was asking for, in terms which took into account current Joomla limitations, and I haven't yet had time to install RC5 to understand what it does with link priority etc. so far...

I don't use PM myself because I don't like to be dragged into all the stuff which goes on generally in the background (so don't be offended if you try to PM me and it blocks you - it blocks everyone!), but I would certainly love to get involved, and help in any way I can, by being on the testers forum. I can also PM you a unique email address which you can contact me on, if you like.

Regarding being able to select the URL/Path pair, one thing I most want is to be able to get rid of the blogcategory/blogsection reference in the URL. It is not relevant to visitors and I want to hide Joomla's quirks from them.

I personally think that blog and table listings should just be two sides of the same coin, determined by parameters - but that is not within the power of Open-SEF to change  :(

Anyway, see you on Open-SEF later in the day? (Must do some work now, I'm afraid!) I suppose that will mean tomorrow for you?...

In the meantime, this might give some more food for thought.
http://forum.joomla.org/index.php/topic ... #msg322001
I'm not sure how, or whether, Open-SEF could help with such a scenario...

smashingyoungman
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Mon Dec 19, 2005 1:57 pm

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by smashingyoungman » Tue Jun 13, 2006 8:27 am

I don't know if this has been mentioned yet, but just an observation of mine.

I use SMF, OpenSEF and SMF Discussbot. I kept getting URLs pointing to the same content with several different itemids, which of course nuked my module layouts. I had to keep deleting/unpublishing the bad URLs in OpenSEF. I was pulling my hair out trying to find out where these mysterious itemids were coming from—they certainly didn't point to any items in my menus. Well, they did...sort of.

One thing I had forgotten about was Discussbot. Links back to the original articles in many forum threads pointed to URLs with old itemids from now deleted menu items. Every time somone clicked one of these, it generated a FURL off the old itemid. After trawling through all the forum posts with links pointing to URLs with defunct itemids and editing/removing them, the problem went away.

A pretty obvious thing to overlook I know, but I thought I would mention it in case anyone else is having a similar issue while using SMF and Discussbot, and maybe overlooked it themselves.

AmyStephen

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by AmyStephen » Sat Jul 01, 2006 11:57 pm

Can someone with the proper authority update the FAQ Item and change "http://forum.opensourcematters.org/" to "forum.joomla.org" so that the links work?

Thanks! Amy

User avatar
kenmcd
Joomla! Champion
Joomla! Champion
Posts: 5672
Joined: Thu Aug 18, 2005 2:09 am
Location: California
Contact:

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by kenmcd » Sun Jul 02, 2006 8:29 am

██ LibreTraining

AmyStephen

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by AmyStephen » Sun Jul 02, 2006 3:18 pm

Good - thanks, Ken. 

User avatar
55thinking
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 186
Joined: Mon Sep 05, 2005 8:58 am
Location: Madrid
Contact:

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by 55thinking » Thu Jul 13, 2006 9:22 am

Hello

I have been reading several of  posts regarding itemid issues in the forum, and I really think that a complete check should be done for the 1.0.10 release

The idea would be to approach these problems from a real case, that is set-up a new Joomla install from scratch:

1. Information architecture - CONTENT

5 Sections
3 Categories per section --> Total 15
5 Items per categories --> Total 75 items

2. Menu architecture - MENU

LEVEL 1: Home (com_front page) | Section 1 (Blog section page) | Section 2 (Blog section page)...| Section 5 (Blog section page)| Contact (com_contact)

LEVEL 2

Section 1 (Blog section page)

  Category 1.1 (Blog category page)
  Category 1.2 (Blog category page)
  Category 1.3 (Blog category page)

LEVEL 3

Section 1 (Blog section page)
  Category 1.1 (Blog category page)
      Item 1.1.1 (content item page)
      Item 1.1.2 (content item page)
      Item 1.1.3 (content item page)
      Item 1.1.4 (content item page)
      Item 1.1.5 (content item page)

OK now that I have organised my content/menu this way

What will happen with pathway ?
What will happen to read more links ?
What will happen to Section/Category name/linkings ?
What will happen to active menu highlighting (LEVEL 1, LEVEL 2, LEVEL 3) ?
What will happen with module display per page ?
Other issues ?

For any question: OK / NOK --> If a problem is detected, clearly describe the behaviour and provide a workaround if any

This practical approach would help in identifying problems in a real context. I offer full availability to help in testing + writing the tutorial.

PLEASE HAVE A LOOK TO THE RESULTS HERE:
http://forum.joomla.org/index.php/topic ... 94820.html

I wish experts could come up to confirm problems & provide possible workarounds

From my reading both kper & kenmcd are the experts about these issues.

Any help is more than welcomed, this itemid issue is very complex and annoying...
Last edited by 55thinking on Fri Jul 14, 2006 8:42 am, edited 1 time in total.
55 Thinking - Strategy Design Technology 
Good looking, Fast and Usable web solutions   
http://www.55thinking.com/

dama
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Jul 20, 2006 1:05 pm
Location: offshore

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by dama » Fri Jul 21, 2006 9:51 am

ppl, this does the trick for me, tho i dont really know what i did :D

change the line 556 in content.html.php from

Code: Select all

		if ( $row->_Itemid && $row->_Itemid != 99999999 ) {
			// where Itemid value is returned, do not add Itemid to url
			$row->Itemid_link = '&Itemid='. $row->_Itemid;
to

Code: Select all

		if ( $row->_Itemid && $row->_Itemid != 99999999 ) {
			// where Itemid value is returned, do not add Itemid to url
			$row->Itemid_link = '&Itemid='. $mainframe->getItemid( $row->id, 0, 1);
read more link in blog section content list now works fine, showing the full home\section blog\category\item in pathway and loads the appropriate module assigned to the item
hope it helps...
cheers!
Last edited by dama on Fri Jul 21, 2006 10:09 am, edited 1 time in total.

User avatar
55thinking
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 186
Joined: Mon Sep 05, 2005 8:58 am
Location: Madrid
Contact:

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by 55thinking » Fri Jul 21, 2006 10:59 am

Dama

your hack completely solve the issue

Thanks a lot!
55 Thinking - Strategy Design Technology 
Good looking, Fast and Usable web solutions   
http://www.55thinking.com/

User avatar
dejavu
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Aug 08, 2006 2:26 pm
Location: Buenos Aires
Contact:

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by dejavu » Wed Aug 09, 2006 6:22 pm

Thats all right.
But...
what happend if I want to show a module (like a banner) on the "article´s list view", but I dont show this module on the "Article´s content view" ???
La Felicidad es todo aqueyo que llamamos... Felicidad

zz_james
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Jul 27, 2006 7:30 pm

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by zz_james » Fri Aug 11, 2006 10:54 am

I don't know if this works for everyone but I made a menu of 'list -content section' for each of my sections, the menu is not included in the template but now my 'read more...' and breadcrumb/pathway works :)



James

zz_james
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Jul 27, 2006 7:30 pm

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by zz_james » Fri Aug 11, 2006 11:16 am

that should be



for the site which now works...

zz_james
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Jul 27, 2006 7:30 pm

Re: DISCUSSION: Incorrect Itemid-list of possible solutions

Post by zz_james » Fri Aug 11, 2006 11:32 am

Oh no. sorry people that  generates ok breadcrumb, but I don't like those ugly list pages.... back to the table-category solution I think.

James


Locked

Return to “FAQ Discussion Board”