[DISCUSSION] Hello_world component

Discuss the FAQ's here, and get in touch with the FAQ Team.
Locked
User avatar
globule
Joomla! Guru
Joomla! Guru
Posts: 551
Joined: Tue Aug 30, 2005 9:11 pm
Location: Aix-En-Provence, France
Contact:

[DISCUSSION] Hello_world component

Post by globule » Tue Aug 01, 2006 8:45 pm

Hi all,

We (I'm not the only one working on it) translated 2 "Hello World" tutorials :

for 1.0.x : http://help.joomla.org/content/category/12/112/125/
for 1.5.x : http://dev.joomla.org/index.php?option= ... ello_world

and I have some questions/comments to do:

1. the first tuto (1.0.x) is on "help" subdomain and the second (1.5.x) on "dev". Is it because the 2nd is not finished?
2. in the second tuto (1.5.x) there is a code error in the second at chapter 3.1.2.2 A few preparations. In the "hello.html.php - version 2", the 'foreach' statement (or the function) is not closed.
3. the first tuto exposes how to use PatTemplates but I can see nothing about it in the second one (1.5.x)
4. the example of moofx integration is not shown with PatTemplate (too)
5. there is no object class for database, as core components uses, in this tutos

I'm currently testing the tuto for 1.5.x to publish our translation to french in the same time Joomla 1.5.x will be published.
May the forge be with you!
http://www.joomlation.eu (intl)
http://www.joomlation.org (fr)

User avatar
Tonie
Joomla! Master
Joomla! Master
Posts: 16584
Joined: Thu Aug 18, 2005 7:13 am

Re: [DISCUSSION] Hello_world component

Post by Tonie » Mon Aug 07, 2006 11:54 am

The first tut is on help.j.org because that was created in the time before the Joomla project started. Nowadays, dev resources go to dev.j.org.

The second tutorial was started, PT hasn't indeed been added. I think it was hackwar who did the tutorial, he will probably be busy with his SOC project. I can fix the wrong code later today, thanks for that!

User avatar
Tonie
Joomla! Master
Joomla! Master
Posts: 16584
Joined: Thu Aug 18, 2005 7:13 am

Re: [DISCUSSION] Hello_world component

Post by Tonie » Tue Aug 08, 2006 4:43 pm

I closed the foreach statement.

User avatar
globule
Joomla! Guru
Joomla! Guru
Posts: 551
Joined: Tue Aug 30, 2005 9:11 pm
Location: Aix-En-Provence, France
Contact:

Re : [DISCUSSION] Hello_world component

Post by globule » Tue Aug 08, 2006 5:35 pm

Thanks
May the forge be with you!
http://www.joomlation.eu (intl)
http://www.joomlation.org (fr)


Locked

Return to “FAQ Discussion Board”