DISCUSSION - How to set up/install Joomla on Win XP for local testing

Discuss the FAQ's here, and get in touch with the FAQ Team.
Lifepod-i
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri May 18, 2007 2:05 am

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by Lifepod-i » Mon Jun 11, 2007 10:25 pm

Thanks heaps for your advice. I'll hav a go...

User avatar
Ginza
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 135
Joined: Fri Oct 27, 2006 1:16 am
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by Ginza » Thu Jul 12, 2007 12:46 pm

is it possible to give domain name for http://localhost/joomla?

for example when i type http://mysite.com it would open up the http://localhost/joomla
Coming Soon!

rising_sun
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jul 12, 2007 5:44 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by rising_sun » Thu Jul 12, 2007 6:40 pm

hi there, im new to joomla.
i tried to follow waseem's instruction on: http://forum.joomla.org/index.php/topic,25954.0.html to setup joomla for local testing
unfortunately i am unable to proceed from step 1
as instructed i filled as below:

    * Host Name = localhost
    * MySQL User Name = root
    * MySQL Password = blank (don't put anything in this box)
    * MySQL Database Name = anyhting you like (eg joomladb)
    * MySQL Table Prefix = jos_ (this is set as default but you can change it)
    * Make sure that install sample data is ticked
    * Click "next"

But then i get a message saying "password and username provided are incorrect".

could anyone help me

User avatar
Waseem Sadiq
Joomla! Ace
Joomla! Ace
Posts: 1441
Joined: Mon Sep 12, 2005 7:41 pm
Location: Glasgow - Scotland
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by Waseem Sadiq » Thu Jul 12, 2007 7:17 pm

Hi RS,

It sounds like you've set up a password for your database admin user, that's not a problem tho, just make sure you're using the same settings in this step:
    * Host Name = localhost
    * MySQL User Name = root
    * MySQL Password = blank (don't put anything in this box)
    * MySQL Database Name = anyhting you like (eg joomladb)
    * MySQL Table Prefix = jos_ (this is set as default but you can change it)
    * Make sure that install sample data is ticked
    * Click "next"
You'll find the settings in the config.inc.php file of your wamp installation (ie C:\wamp\phpmyadmin)

the settings you're looking for are on lines 72 and 73 of that file:

Code: Select all

$cfg['Servers'][$i]['user']          = 'root';      // MySQL user
$cfg['Servers'][$i]['password']      = '';          // MySQL password (only needed
Hope this helps!

Waseem :)
http://www.bulletprooftemplates.com/ - Joomla Templates and Consultancy

rising_sun
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jul 12, 2007 5:44 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by rising_sun » Thu Jul 12, 2007 8:02 pm

thanks waseem,
but I am not using a password, just leaving it blank.
still i get the message "password and username provided are incorrect"
any idea?

User avatar
Waseem Sadiq
Joomla! Ace
Joomla! Ace
Posts: 1441
Joined: Mon Sep 12, 2005 7:41 pm
Location: Glasgow - Scotland
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by Waseem Sadiq » Thu Jul 12, 2007 8:42 pm

I'm not certain what could be causing that if your database username and password are as default - ie root and blank

Are you able to see the wamp homepage?

If so click the link for phpmyAdmin - if there is no password set up for the root user you'll see a big warning at the bottom of the page. If you don't see the warning then you must have a password set, check the file I referenced.

If none of that works then I'd try posting over at the wamp forums (try this link - http://www.wampserver.com/phorum/read.p ... 85&t=13685)

Waseem
http://www.bulletprooftemplates.com/ - Joomla Templates and Consultancy

chadburg
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Oct 20, 2006 1:01 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by chadburg » Fri Jul 20, 2007 2:42 pm

Hi,
I followed your tutorial for hosting on a local pc for testing, etc. and it worked great.  I was  working away all day yesterday and shut off the computer as usual.  This morning it will nto pull up the site and says "could not connect to the database".  I have tried opening up the phpmyadmin panel, but my knowledge is very limited and usually I follow tutorials exactly - step by step to get something workign.  Is there a resaon that my database would work yesterday and today would not bring up the site?  Wamp says that everything is running.  Thanks.

chadburg
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Oct 20, 2006 1:01 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by chadburg » Fri Jul 20, 2007 2:57 pm

I re-installed and found out that my database from yesterday did not even exist anymore.  Is there something I did or din't do that might have caused this to happen?

User avatar
DeanMarshall
Joomla! Hero
Joomla! Hero
Posts: 2352
Joined: Fri Aug 19, 2005 2:26 am
Location: Lancaster, Lancashire, United Kingdom
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by DeanMarshall » Fri Jul 20, 2007 11:23 pm

It seems likely that your PC has two installations of MySQL - and you
installed into one MySQL and today when you restarted the PC the
original MySQL is running and the db is not found.

You need to stop the MySQL service on your PC - then start the
one on your Wamp.  Or vice versa.

Chances are your original data from the Joomla install is in one or other of these two database services' databases
wampmysqld - the Wamp MySQL service
MySql  - the standard windows MySQL service

Type 'services.msc' into the run dialog box that appears when you go to 'Start' -> 'run'
Stop both services then start one - try wamp.
Then stop them and try the other mysql service.

Dean
Dean Marshall Consultancy - six Joomla experts - http://www.deanmarshall.co.uk/

Joomla Experts - Joomla Support http://www.deanmarshall.co.uk/joomla-se ... pport.html

User avatar
jaysunp
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sat Sep 16, 2006 1:59 am
Location: Planet Earth
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by jaysunp » Sun Jul 22, 2007 8:42 pm

If this is too far off topic let me know...

Can someone explain how to change permissions to files within WAMP running on a windowsXP machine?

I have a dev site locally on WAMP using the Simple Image Gallery plugin. The files associated with the plugin load with 666perms by default and I have been unable to change them so that the plugin will work.

Any suggestions?

Thanks,
jaysunp
All the best,
jason bradley

Freeing Minds from the Matrix
GemstoneUniversity.org

ruven
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Mon Jul 23, 2007 10:39 am
Location: Southern California
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by ruven » Thu Jul 26, 2007 5:32 am

I got it all working on my first try, yay me!

But then my first attempt at actually changing something = failure!

I wanted to change the template to one of the ones i downloaded from one of the template sites.

And instead i got this error.
Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 4877256 bytes) in C:\wamp\www\joomla\administrator\includes\pcl\pclzip.lib.php on line 3236
Im have no clue... any help ?

BTW, yes... im new at this.
http://www.DailySportsPages.com - Sports News and Rumors

User avatar
DeanMarshall
Joomla! Hero
Joomla! Hero
Posts: 2352
Joined: Fri Aug 19, 2005 2:26 am
Location: Lancaster, Lancashire, United Kingdom
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by DeanMarshall » Thu Jul 26, 2007 12:24 pm

@jaysunp:
File permisssions don't usually come into it on Windows machines - athough some of the later server operating systems this may happen.
If you get permission errors on windows it is more likely you have a path setting that is incorrect or a folder doesn't exist.


@ruven:
see this post from earlier in the thread - it should point you in the right direction:
http://forum.joomla.org/index.php/topic ... #msg764784

Dean
Dean Marshall Consultancy - six Joomla experts - http://www.deanmarshall.co.uk/

Joomla Experts - Joomla Support http://www.deanmarshall.co.uk/joomla-se ... pport.html

ruven
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Mon Jul 23, 2007 10:39 am
Location: Southern California
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by ruven » Thu Jul 26, 2007 9:45 pm

DeanMarshall wrote:
@jaysunp:
File permisssions don't usually come into it on Windows machines - athough some of the later server operating systems this may happen.
If you get permission errors on windows it is more likely you have a path setting that is incorrect or a folder doesn't exist.


@ruven:
see this post from earlier in the thread - it should point you in the right direction:
http://forum.joomla.org/index.php/topic ... #msg764784

Dean
Thanks Dean.... and thanks for all the other great help in this thread.
I just started last night but i see that youve helped quite a bit of people in the past.
Folks werent kidding when they said that the Joomla Community was top notch.
http://www.DailySportsPages.com - Sports News and Rumors

anitajj
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Jul 19, 2007 9:12 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by anitajj » Wed Aug 08, 2007 6:11 pm

Hi. Thank you Thank you. I'm a newbee and this tutorial worked immediately, flawlessly .... now ... I'm studying "how to migrate to server"... Can you please clarify where you say:

"Tick all of: add DROP TABLE, add IF NOT EXISTS, add AUTO_INCREMENT value, Enclose table and field names with backquotes"

Did you mean "Tick all OFF???" Are you meaning I should UNCHECK the boxes for "add Drop Table", "add if not exists" and "add auto_increment value"???

Thanks so much for all the help, Anita

User avatar
Waseem Sadiq
Joomla! Ace
Joomla! Ace
Posts: 1441
Joined: Mon Sep 12, 2005 7:41 pm
Location: Glasgow - Scotland
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by Waseem Sadiq » Thu Aug 09, 2007 12:06 pm

Hi Anita,

I meant the other way around, make sure all of those checkboxes ARE checked :)

Hope this helps,

Waseem
http://www.bulletprooftemplates.com/ - Joomla Templates and Consultancy

islandgrl
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Aug 23, 2007 10:19 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by islandgrl » Wed Aug 29, 2007 6:19 pm

I want to say a big THANKS for your tutorial. After two days of reading posts, testing and retesting, I came upon your post and now problem solved.  :D

User avatar
Waseem Sadiq
Joomla! Ace
Joomla! Ace
Posts: 1441
Joined: Mon Sep 12, 2005 7:41 pm
Location: Glasgow - Scotland
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by Waseem Sadiq » Thu Aug 30, 2007 2:19 pm

You're welcome Islandgrl :)

Glad to have helped another newbie board the Joomla train

Waseem
http://www.bulletprooftemplates.com/ - Joomla Templates and Consultancy

anitajj
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Jul 19, 2007 9:12 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by anitajj » Thu Aug 30, 2007 5:34 pm

Waseem Sadiq wrote: Hi Anita,
I meant the other way around, make sure all of those checkboxes ARE checked :)
Hope this helps,
Waseem
Thanks so very much.... I have successfully installed joomla on both a godaddy server and a freehostia free hosting site. Your tutorial was excellent. Anita

Assyrian
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Apr 01, 2007 5:31 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by Assyrian » Sun Sep 02, 2007 6:36 am

Hi Waseem,

I have followed all your steps and everything went perfectlly fine. Thank you so very much.

The only problem I'm having is not being able to test Mamboezine component. I installed the component with no problems what so ever, but when I tried to use it by adding the categories from the backend, I saw the names of the cats just like brackets (). The same component works fine on a live site. Any Idea?

Thank you again.

User avatar
Waseem Sadiq
Joomla! Ace
Joomla! Ace
Posts: 1441
Joined: Mon Sep 12, 2005 7:41 pm
Location: Glasgow - Scotland
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by Waseem Sadiq » Sun Sep 02, 2007 8:34 pm

Hi Assyrian,

I'm afraid that I have no experience what-so-ever of the mamboezine component so wouldn't know where to start with this :(

Sorry :)

Waseem
http://www.bulletprooftemplates.com/ - Joomla Templates and Consultancy

caltucker
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Sat Nov 25, 2006 8:49 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by caltucker » Wed Sep 19, 2007 2:59 pm

Hi! I have done as instructed and everything works great, BUT

It seems my text that was in the jos_content table got screwed up.

The following symbol appears all over my content on my localhost:  Â

It seems it is replacing the apostrophe, but it also appears in other instances.

Here is an example taken from intro text on the live site that was part of the import into my localhost :

HORNETÂ BASEBALL GOLF TOURNAMENTÂ APPROACHES!

User avatar
Waseem Sadiq
Joomla! Ace
Joomla! Ace
Posts: 1441
Joined: Mon Sep 12, 2005 7:41 pm
Location: Glasgow - Scotland
Contact:

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by Waseem Sadiq » Thu Sep 20, 2007 12:49 pm

Hi Caltucker,

The symbol you're seeing is most likely due to the template you're using rather than the db. This is a common UTF-8 issue, if you search the forum you're bound to find the fix :)

Hope this helps,

Waseem
http://www.bulletprooftemplates.com/ - Joomla Templates and Consultancy

caltucker
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Sat Nov 25, 2006 8:49 pm

Re: DISCUSSION - How to set up/install Joomla on Win XP for local testing

Post by caltucker » Thu Sep 20, 2007 4:50 pm

Hi Waseem!

I searched the forum and came up with nothing regarding that symbol, or what exactly you mean by UTF...

It seems that no matter which way I dump the database, it inserts these weird symbols into the data.

Does anyone have a suggestion on what I should do?

Should I dump the database, open it in a notepad application and find and replace all of those symbols? Or is there an easier way.

And, is the data being corrupted in another way, besides that symbol.

As far as templates, I use all Rocket Theme...


Post Reply

Return to “FAQ Discussion Board”