[SOLVED] Print, email, PDF links don't work if turned on for page only

Confirmed bugs that have been Fixed - Joomla 1.0.x



[New Threads cannot be started in this forum]
Locked
juliecracker
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Thu Jan 05, 2006 7:58 am

[SOLVED] Print, email, PDF links don't work if turned on for page only

Post by juliecracker » Sat Mar 24, 2007 5:59 pm

Description:
Turning off the Print/Email/PDF icons in Content / Global Configuration results in any attempt to turn them ON for a specific content item failing with the error "You are not authorized to view this resource."  Originally reported/discussed in this thread: http://forum.joomla.org/index.php?topic=102236

Reported on:
Originally discovered in 1.0.11 upgrade (did not exist in 1.0.10).  Also confirmed in 1.0.12 clean install.

Classification:
High

Affected functions:
Print/PDF/email links do not function at all if the icons are turned off by default in Content / Global Configuration.  When the user clicks one of those links (turned on for only a specific content item), they get a popup window with only the text "You are not authorized to view this resource."

Related files:
Unknown.

Steps to replicate:
1. In 1.0.12 (or 1.0.11) Administrator, open Site > Global Configuration, click on Content tab.

2. Select Radio Button "Hide" for PDF Icon, Print Icon, and/or Email Icon (it does not appear the settings interact), Save settings.
[For http://www.advancedparagliding.com, all 3 are set to "Hide"]

3. Go to any published Content item and Edit it.

4. Select Parameters tab and change "Email icon" to "Show" (instead of "Use Global").
[This was done for http://www.advancedparagliding.com/content/view/15/56/]

5. In web browser, navigate to your website and open the Content item in question.
[Can be seen for Julie Spiegler Bio: http://www.advancedparagliding.com/content/view/15/56/]

6. Click the Email icon.  Instead of getting a popup window with an email form, you get a popup window with the message "You are not authorized to view this resource."

Analysis:
[Q&T] Confirmed/Unable to confirm/Rejected
Any other comments

Proposed fix(es):
Since sites built prior to 1.0.11 were configured for this to work correctly (supporting setting the Global Configuration to Hide those icons, then only turning them on for individual content items), the only real "fix" is to make it work the same way again.  The workaround appears to set the icons to "Show" in the Global Configuration and then edit _every single content item_ in your entire site to manually override and set to "Hide".

Topic / Artifact ID:
http://forum.joomla.org/index.php?topic=102236
This appears to be the same problem (minimally described): http://forum.joomla.org/index.php/topic,153233.0.html

System info:
My installations exhibiting the problem are:
on Dreamhost servers (Linux 2.4.29, i686, GNU/Linux; Apache/1.3.37)
Joomla 1.0.11 (upgraded from 1.0.3 and 1.0.8)
Other users have confirmed seeing the same behavior on 1.0.12 (clean install)
Last edited by juliecracker on Sat Mar 24, 2007 6:02 pm, edited 1 time in total.

drumsage
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Fri Aug 26, 2005 1:44 pm

Re: Print, email, PDF links don't work if turned on for page only

Post by drumsage » Mon Mar 26, 2007 4:45 am

I experienced the same issue ... which is how/why I found this thread.

I resolved the problem, temporarily, but setting the Global Configuration to SHOW the Email link by default.
I have a large site and database; I really don't want to have to manually change every content item.

I hadn't noticed this problem until Joomla 1.0.12.
The feature was working properly prior to this update.

MartyK
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Mar 08, 2007 11:05 am

Re: Print, email, PDF links don't work if turned on for page only

Post by MartyK » Tue May 08, 2007 7:55 am

I have the same problem, but it’s only with the email icon, the pdf and print icons work fine. But the email one gives me the message "You are not authorized to view this resource".
And what we did (which was suggested) was enabling the global setting of the email icon in the global site configuration. Bu this puts it on every page. I only want it to work on the pages I have specifically enabled it on.

Does anyone have a proper solution??

User avatar
RobS
Joomla! Ace
Joomla! Ace
Posts: 1367
Joined: Mon Dec 05, 2005 10:17 am
Location: New Orleans, LA, USA
Contact:

Re: Print, email, PDF links don't work if turned on for page only

Post by RobS » Mon May 14, 2007 9:34 pm

Fixed in SVN.  Thanks for reporting.
Rob Schley - Open Source Matters
Webimagery - http://www.webimagery.net/ - Professional Consulting Services
JXtended - http://www.jxtended.com/ - Free and Commercial Joomla! Extensions

juliecracker
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Thu Jan 05, 2006 7:58 am

Re: Print, email, PDF links don't work if turned on for page only

Post by juliecracker » Tue May 15, 2007 2:57 am

RobS wrote: Fixed in SVN.  Thanks for reporting.
What was fixed?

Can you share the fix so that we can apply a patch/workaround in the meantime?

Thanks,
j

bambam82
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Mon Apr 16, 2007 10:49 am
Location: Utrecht
Contact:

Re: Print, email, PDF links don't work if turned on for page only

Post by bambam82 » Tue Jul 17, 2007 10:01 am

RobS wrote: Fixed in SVN.  Thanks for reporting.
I would also like to know...
http://www.bamweb.nl/ // custom OpenBSD solutions

LikeStuff
Joomla! Guru
Joomla! Guru
Posts: 786
Joined: Mon Jul 24, 2006 2:06 am

Re: [SOLVED] Print, email, PDF links don't work if turned on for page only

Post by LikeStuff » Fri Jul 20, 2007 10:16 pm

I'd like to know too..

wiredeyes
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Sep 22, 2006 11:32 pm

Re: [SOLVED] Print, email, PDF links don't work if turned on for page only

Post by wiredeyes » Fri Aug 24, 2007 12:15 pm

This bug is still evident somewhat in the 1.0.13 version, if you disable globaly then enable email icon in a menu item but don't enable in the actual content item (Tested with dynamic content) then the same error occours, if you set menu to global and content to show then it also wont work (in fact it wont even show the icon. so basicly both have to be enabled if global is set to hide.

juliecracker
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Thu Jan 05, 2006 7:58 am

Re: [SOLVED] Print, email, PDF links don't work if turned on for page only

Post by juliecracker » Sat Jan 12, 2008 8:28 am

In what way was this "SOLVED"?  It is still an issue in 1.0.13.


Locked

Return to “Q&T 1.0.x Resolved”